AMD E450 & Ati 6320. Speed issues.

Questions about hardware and drivers
Forum rules
Before you post please read this

AMD E450 & Ati 6320. Speed issues.

Postby Giroscopic on Thu May 31, 2012 9:30 pm

Hi, i recently installed LMDE 12 , xfce. I followed the install guides for the propietary drivers, and i am currently "successfully" using my computer with fglrx drivers up.

The problem im having is that, despite AMD advertising fluent HD fullscreen videos, the GPU is aparently not capable of keeping up, and skips a lot of frames when reproducing videos fullscreen, both youtube and actual mkv format types from my hard drive.

So... my choices
1) my gpu is actually not capable of fluent HD fullscreen
2) im missing some drivers/plugins configuration that will provide the missing acceleration.

so, here is a terminal output
$ lspci -nn
00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] Family 14h Processor Root Complex [1022:1510]
00:01.0 VGA compatible controller [0300]: ATI Technologies Inc Wrestler [Radeon HD 6320] [1002:9806]
00:01.1 Audio device [0403]: ATI Technologies Inc Wrestler HDMI Audio [Radeon HD 6250/6310] [1002:1314]
00:05.0 PCI bridge [0604]: Advanced Micro Devices [AMD] Family 14h Processor Root Port [1022:1513]
00:06.0 PCI bridge [0604]: Advanced Micro Devices [AMD] Family 14h Processor Root Port [1022:1514]
00:07.0 PCI bridge [0604]: Advanced Micro Devices [AMD] Family 14h Processor Root Port [1022:1515]
00:11.0 SATA controller [0106]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] [1002:4391]
00:12.0 USB controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397]
00:12.2 USB controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396]
00:13.0 USB controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397]
00:13.2 USB controller [0c03]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396]
00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 42)
00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383] (rev 40)
00:14.3 ISA bridge [0601]: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller [1002:439d] (rev 40)
00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384] (rev 40)
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 0 [1022:1700] (rev 43)
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 1 [1022:1701]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 2 [1022:1702]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 3 [1022:1703]
00:18.4 Host bridge [0600]: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 4 [1022:1704]
00:18.5 Host bridge [0600]: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 6 [1022:1718]
00:18.6 Host bridge [0600]: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 5 [1022:1716]
00:18.7 Host bridge [0600]: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 7 [1022:1719]
01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)
02:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5116 PCI Express Card Reader [10ec:5209] (rev 01)

I have no idea why there are so many entries, its a fresh install with the non free drivers installed. Any thougts welcomed
Giroscopic
Level 1
Level 1
 
Posts: 18
Joined: Thu May 31, 2012 6:50 pm

Linux Mint is funded by ads and donations.
 

Re: AMD E450 & Ati 6320. Speed issues.

Postby tacit on Sat Jun 02, 2012 10:10 pm

Hi. Owner of an E-350 here. I know the terrible performance you're speaking of. Even the AMD Catalyst 12.4 release had poor performance.

That seems to be fixed with the Catalyst 12.6a Beta release, though there is an annoying AMD watermark (impossible to remove?) in the bottom-right corner of the screen, everything works much better. Still an occasional crash on resuming from suspend but the performance issues are pretty much gone.
tacit
Level 1
Level 1
 
Posts: 6
Joined: Sat May 21, 2011 12:28 am

Re: AMD E450 & Ati 6320. Speed issues.

Postby Giroscopic on Sun Jun 03, 2012 6:42 pm

thanksfor the info man, ill give it a try today and ill post the results

using catalyst 12,4 also.
Giroscopic
Level 1
Level 1
 
Posts: 18
Joined: Thu May 31, 2012 6:50 pm

Re: AMD E450 & Ati 6320. Speed issues.

Postby pipe1984 on Mon Jun 18, 2012 5:05 am

I have an HP netbook DM1-4310ss HD 6320 card. I have AMD proprietary drivers version 12.4. Videos 1080p mkv do not work well. Another problem I found is that by connecting the HDMI to the TV sound can be heard on TV. Hope you can help me. Thank you.
pipe1984
Level 1
Level 1
 
Posts: 7
Joined: Tue May 29, 2012 5:34 am

Re: AMD E450 & Ati 6320. Speed issues.

Postby Giroscopic on Thu Jun 21, 2012 1:32 am

So.... i tried....

Catalist 12.6beta, seemed fined, videos were doing ok, but wine + games where not working, failure to even launch them.
Drivers from repositories. Same issue, works ok for movies, but not for games with wine.
Currently gonna try 12.4 but not optimistic about it...

at this point i just beleive my computer is full of trash packages from all the drivers and i have NO idea how to clean things up


UPDATE: Tried reinstalling everything. Got my hands on the catalyst 12.4. Seems good enough to work with the video decoding i was having problems with.
my Video card is capable of so much more though.... i installed the unnamable W7, and i get such a great graphics performance... i hate not being able to fully debug and install the proper drivers on linux. I wish i knew how
Giroscopic
Level 1
Level 1
 
Posts: 18
Joined: Thu May 31, 2012 6:50 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 4 guests