FIX: Missing amd-ucode/microcode_amd.bin /3.4 kernel

Questions about hardware and drivers
Forum rules
Before you post please read this

FIX: Missing amd-ucode/microcode_amd.bin /3.4 kernel

Postby GeneC on Thu Jul 19, 2012 11:26 am

Anyone seeing this error on boot?

microcode: failed to load file amd-ucode/microcode_amd.bin


I just started seeing it in LMDE/SID
Code: Select all
System:    Host zordon Kernel 3.4.0-4.dmz.2-liquorix-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition


You need to install
Code: Select all
amd64-microcode

Its in the Debian SID repos.


Before
Code: Select all
gene@zordon:~$ dmesg | grep micro
microcode: CPU0: patch_level=0x010000b6
microcode: failed to load file amd-ucode/microcode_amd.bin
microcode: CPU1: patch_level=0x010000b6
microcode: failed to load file amd-ucode/microcode_amd.bin
microcode: CPU2: patch_level=0x010000b6
microcode: failed to load file amd-ucode/microcode_amd.bin
microcode: CPU3: patch_level=0x010000b6
microcode: failed to load file amd-ucode/microcode_amd.bin
microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba


After

Code: Select all
gene@zordon:~$ dmesg | grep micro
microcode: CPU0: patch_level=0x010000b6
microcode: CPU0: new patch_level=0x010000c8
microcode: CPU1: patch_level=0x010000b6
microcode: CPU1: new patch_level=0x010000c8
microcode: CPU2: patch_level=0x010000b6
microcode: CPU2: new patch_level=0x010000c8
microcode: CPU3: patch_level=0x010000b6
microcode: CPU3: new patch_level=0x010000c8
microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba


Reference:
http://aptosid.com/index.php?name=PNphp ... ic&p=15202
GeneC

AMD Phenom2x4 3.2 ghz, 12GB DDR3, Nvidia GTX 460

Qiana (Cinnamon/XFCE)
Sparky XFCE (Debian Testing)
LMDE Cin 2.2 (SID)
User avatar
GeneC
Level 7
Level 7
 
Posts: 1538
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Linux Mint is funded by ads and donations.
 

Re: FIX: Missing amd-ucode/microcode_amd.bin /3.4 kernel

Postby austin.texas on Wed Sep 05, 2012 11:08 am

If you have an AMD cpu and you install the 3.4 kernel you will get this microcode error.
microcode: failed to load file amd-ucode/microcode_amd.bin


Go to here: http://www.amd64.org/support/microcode.html
and download the latest package.
The instructions for installing the patches are included in the download.
Works great.
Mint 17 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 9
Level 9
 
Posts: 2626
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 3 guests