[SOLVED] auto-mount permission help wanted

Questions about hardware and drivers
Forum rules
Before you post please read this

[SOLVED] auto-mount permission help wanted

Postby mack_mcash on Mon Jul 23, 2012 7:52 am

Hi, all.

I used this method to auto-mount, from this thread:
Code: Select all
http://forums.linuxmint.com/viewtopic.php?f=50&t=106864

Code: Select all
[1] Find the correct UUID number for your windows partitions:

Code: Select all
    sudo blkid -c /dev/null

[2] Create permanent mountpoints for your partitions to live in, for example:

Code: Select all
    sudo mkdir /media/Data

[3] Edit fstab as root:

Code: Select all
    gksudo gedit /etc/fstab

[4] Add the following lines to the end of fstab, examples:

Code: Select all
    UUID=8C169E22169E0CF8 /media/Data ntfs defaults,umask=000,nls=utf8,windows_names 0 0

Substitute the correct UUID numbers from step [1] and the correct mountpoints from step [2].

[5] If you have already mounted these partitions manually through computer(icon) - unmount them.

[6] Run the following command that will test for errors and if there are none mount the partitions to their new home without requiring a reboot:

Code: Select all
    sudo mount -a

to auto-mount an NTFS-Data partition at boot time and this partition did indeed get mounted properly at boot; however, when I attempted to open any file, for example, a text file, it would not let me open it up because the file belongs to 'root'.

How, please, would I go about fixing this permission issue in order to use this data-partition, that is now mounted, as my own home with my files in it?

Thanks for any help with this,
mack :)
Last edited by mack_mcash on Mon Jul 23, 2012 3:10 pm, edited 1 time in total.
mack_mcash
Level 1
Level 1
 
Posts: 24
Joined: Sat Jun 02, 2012 10:54 am

Linux Mint is funded by ads and donations.
 

Re: auto-mount permission help wanted

Postby altair4 on Mon Jul 23, 2012 8:01 am

That line in fstab will mount with owner = root but with read / write permissions to everyone ( umask=000 ).

If you run the following command:
Code: Select all
ls -dl /media/Data

It should come back with something like this:
drwxrwxrwx 1 root root 4096 Jul 22 17:55 /media/Data


If you want to replace root with you add a "uid=1000" to the list of options:
Code: Select all
UUID=8C169E22169E0CF8 /media/Data ntfs defaults,umask=000,uid=1000,nls=utf8,windows_names 0 0

But that shouldn't be necessary.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5986
Joined: Tue Feb 03, 2009 10:27 am

Re: auto-mount permission help wanted

Postby mack_mcash on Mon Jul 23, 2012 3:09 pm

Thank you, very much, for your quick reply and answer, altair4.

mack
mack_mcash
Level 1
Level 1
 
Posts: 24
Joined: Sat Jun 02, 2012 10:54 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 5 guests