CUPS for Kodak wifi printer

Questions about hardware and drivers
Forum rules
Before you post please read this

CUPS for Kodak wifi printer

Postby hallergard on Wed Aug 01, 2012 4:24 am

Bought myself a KodakESP1.2 aiO wireless printer. Seems to install the driver ESP C110 okay, but when printing the test page I get this message: "PDF file is damaged - attempting to reconstruct xref table"

After some googling I have come to believe that this problem could solved by installing a newer cups version, my present being 1.5.2-5 and cups-filters 1.0.2-1. Am using normal up-to-date Mint 1202 Debian 64-bits. How can I upgrade the cups version?? Romeo did not help.
hallergard
Level 1
Level 1
 
Posts: 26
Joined: Wed Aug 01, 2012 4:11 am

Linux Mint is funded by ads and donations.
 

Re: CUPS for Kodak wifi printer

Postby hallergard on Wed Aug 01, 2012 6:20 am

I am new to Debian, but now found Debian Packages. Tried to install cups and cups-filters with wheezy and sid, but in both cases I had problems with libfontconfig1 > 2.90 which was not to be installed due to other dependencies. So I guess I will just have to wait till cups 1.5.3 arrives to LMDE?
hallergard
Level 1
Level 1
 
Posts: 26
Joined: Wed Aug 01, 2012 4:11 am

Re: CUPS for Kodak wifi printer

Postby Monsta on Wed Aug 01, 2012 6:43 am

Ohh... another package demanding libfontconfig1 >= 2.9.0...

I guess you'll have to wait for Update Pack 5 to arrive. As zerozero mentioned here, installing the new fontconfig stuff alone may break something in your current install.
Meanwhile, Update Pack 5 just hit the Incoming repo, that means it's being tested and prepared for release. New fontconfig packages seem to be there, according to the package list.
Monsta
Level 8
Level 8
 
Posts: 2018
Joined: Fri Aug 19, 2011 3:46 am

Re: CUPS for Kodak wifi printer

Postby hallergard on Wed Aug 01, 2012 1:27 pm

Thanks Monsta. Seems I was on the right track, and am now locking forward to the arrival of the Update Pack 5.
hallergard
Level 1
Level 1
 
Posts: 26
Joined: Wed Aug 01, 2012 4:11 am

Re: CUPS for Kodak wifi printer

Postby hallergard on Thu Aug 02, 2012 6:51 am

Could not wait. Installed fontconfig etc from incoming. Same error message as before, when trying to print the test page.

Installed cups (all plus dependencies etc) from wheezy. No problem to install with the above fontconfig present. Trying to print: some paper feed and message "Connected to printer", after abt 10 sec the paper is ejected and message "Rendering completed". Log says job is done. Only problem is that the paper is blank. Well, actually there are some faint colored dots, from left: a short horisontal line, three lines in 0, 120 and 240 degrees orientation to each other, and then a strange pattern.

Installed cups etc from sid and also newer version of fontconfig etc and printer-driver-c2esp ver 24.2. Same as above wheezy.

Seems I might have a very long wait?
hallergard
Level 1
Level 1
 
Posts: 26
Joined: Wed Aug 01, 2012 4:11 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 4 guests