Black Screen after Login

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

Black Screen after Login

Postby jhin on Sat Feb 09, 2013 6:47 pm

Hi everyone,

during the last update something went wrong and now my system is broken.

Problem:
The system boots fine and shows the graphical login screen but once I fill in my credentials and press enter, the screen just turns black except for the mouse cursor, which I can still move. Apart of that, nothing happens, the screen stays black except for the mouse. I can switch to the terminals (ctrl-alt-fx). All packages are installed nicely, apt-get is telling me I'm completely up-to-date.

System:
- Radeon X700 SE
- LMDE running Mate, cat /proc/version shows:
Code: Select all
Linux version 3.2.0-4-amd64 (debian-kernel@lists.debian.org) (gcc version 4.6.3 (Debian 4.6.3-12) ) #1 SMP Debian 3.2.32-1


Analysis I've done so far:
- Starting a graphical session from the console (either xstart oder service mdm restart/start) leads to the same result
- Adding a new test user and logging in as the test user does also not solve the problem. Thus my profile does not seem to be the problem.
- I do not have a /etc/X11/Xorg.conf file, but according to my research this should be ok...? In fact I already tried creating a dummy Xorg.conf containing just a short entry for the radeon driver, but this also did not have any effect.
- The graphics card worked nicely before the update. I already tried installing lots of different versions of free and non-free drivers, to no avail.
- I checked the Xorg logs, they contain no error messages.
- mdm is installed correctly

I've spent this whole day with trying stuff and crawling forums and irc channels and now I have no further idea on what to do. What annoys me most is that I don't even know what the problem is! Is it some X configuration stuff? Is it a driver problem? Or something completely different?

Any help would be much, much appreciated...

Kind regards, jhin
jhin
Level 1
Level 1
 
Posts: 2
Joined: Sat Feb 09, 2013 5:55 pm

Linux Mint is funded by ads and donations.
 

Re: Black Screen after Login

Postby jhin on Sat Feb 09, 2013 7:20 pm

Uhm yeah... :oops: .... I just realized that obviously MATE got uninstalled during the update. :lol: :lol: :lol:
I was quite sure that it was there since "sudo service mdm restart/start" or "/etc/init.d/mdm start/restart" did not issue any error messages, but checking whether the packages were actually there revealed that they were NOT. :P
jhin
Level 1
Level 1
 
Posts: 2
Joined: Sat Feb 09, 2013 5:55 pm

Re: Black Screen after Login

Postby Stimpeh on Sat Feb 16, 2013 3:36 am

very...VERY...FUNNNY ;) :lol: :roll:
Stimpeh
Level 1
Level 1
 
Posts: 8
Joined: Thu Dec 27, 2012 6:08 pm
Location: France

Re: Black Screen after Login

Postby mowglie on Wed Mar 13, 2013 1:45 am

thank you for this! been scratching my noggin raw for days. same situation as yours except cinnamon wasnt installed. nuts!
mowglie
Level 1
Level 1
 
Posts: 2
Joined: Wed Mar 13, 2013 1:40 am

Re: Black Screen after Login

Postby Thubo on Sat Mar 23, 2013 2:37 pm

Hi,
I've the same / similar problem here...I wanted to exchange mdm for gdm...bad idea.

What I did:
Code: Select all
apt-get purge mdm
apt-get install gdm


After the restart I could login (using the well known standard MATE Login Screen), but the screen stays black. I can see and move my mouse and switch to another console with ctrl+alt+F2...

What I tried meanwhile:
Code: Select all
apt-get get purge gdm
apt-get install mdm

and I also reinstalled any packages coming with mate-core, mate-common, mate-desktop.

Still no use. I still can see the login screen and login properly, but then the screen goes black and the only thing I can do is move the mouse around.

Anyone any ideas what I'm missing?
Thanks in advance
Thubo

UPDATE:
If I click on "sessions" in the login screen and choose "MATE" I can login properly - yet the option "Run xclient script" fails".
Is there a way to repair this?
Thubo
Level 1
Level 1
 
Posts: 14
Joined: Mon Mar 18, 2013 10:10 am
Location: Munich, Germany

Re: Black Screen after Login

Postby oliver_me03 on Sun May 04, 2014 11:50 am

I was already annoyed when I accidentally discovered this temporary solution for laptop HP 248 G1...
Keep pressing Alt and left arrow keys, then Esc key when prompted by the black login screen (I don' know what to call it :D)

Haven't tested with other arrow keys :D
HP 248 G1
LinuxMint 13 (Maya) 64-bit
Kernel Linux 3.2.0-23
GNOME 3.4.2
oliver_me03
Level 1
Level 1
 
Posts: 4
Joined: Sun May 04, 2014 11:30 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 3 guests