[COMPLETELY SOLVED]... Scanner not working in LMDE

Questions about hardware and drivers
Forum rules
Before you post please read this

[COMPLETELY SOLVED]... Scanner not working in LMDE

Postby f2x on Sat Dec 14, 2013 12:45 pm

I have a Canon MG3122 where Linux Mint DEBIAN EDITION doesn't seem to be recognizing the scanner. Simple Scan says "No scanners detected. Please check your scanner is connected and powered on." I know it's connected and powered on, because the printer half is working just fine.

I went to Canon-Asia site: http://support-asia.canon-asia.com/P/search?model=PIXMA+MG3170&menu=download&filter=0&tagname=g_os&g_os=Linux, and installed the ScanGear MP DEBIAN software, but even that doesn't see the scanner, and of course no change in the status of Simple Scan.

I'm at a loss for where to go next to get this scanner working.

EDIT: 9th of February, 2014: The Cannon scanner works just fine using simple scan or any other scanning software as of Update Pack 8. Thank you, Clem and the whole LMDE Team!
Last edited by f2x on Sun Feb 09, 2014 2:33 am, edited 3 times in total.
f2x
Level 1
Level 1
 
Posts: 2
Joined: Sun Mar 17, 2013 3:24 pm

Linux Mint is funded by ads and donations.
 

Re: Scanner not working in LMDE

Postby cwsnyder on Sun Dec 15, 2013 3:21 pm

Did you follow the instructions? (Did you even read far enough to see that there were instructions?)
Setup instruction
Install the downloaded package archive file as an Administrator following the manual.
For how to install and use this software, refer to the instruction manual.
Quoted from http://support-asia.canon-asia.com/contents/ASIA/EN/0100394102.html

Canon is not known for its extensive support for Linux machines, and the Canon MG3122, even the MG3100 series, isn't even LISTED, in the OpenPrinting.org scanner/printer database.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Scanner not working in LMDE

Postby f2x on Mon Dec 16, 2013 3:06 am

cwsnyder wrote:Did you follow the instructions? (Did you even read far enough to see that there were instructions?)
Setup instruction
Install the downloaded package archive file as an Administrator following the manual.
For how to install and use this software, refer to the instruction manual.
Quoted from http://support-asia.canon-asia.com/contents/ASIA/EN/0100394102.html

Canon is not known for its extensive support for Linux machines, and the Canon MG3122, even the MG3100 series, isn't even LISTED, in the OpenPrinting.org scanner/printer database.


Yes, I downloaded and read the instructions. How hard is sudo ./install.sh anyway? :?

Now there's a different problem... Just on a whim, I decided to "sudo scangearmp" (the aforementioned software from Canon) and lo... It found the scanner! Not only that, but it actually scans great! So why am I still complaining? Because I'm essentially running as root, and all the files it creates belong to root. If your software advice is as good as your hardware advice, I should have this fixed in no time. :wink:

And because I like to get experimental, I ran "sudo simple-scan". Still no scanner detected. :|

BTW: This scanner works without installing any additional software in Maya, Nadia, and Olivia. You just plug it in and watch as it clairvoyantly adds the printer. Simple-scan nails it every time, so it's not as if it's been completely unsupported.

What about Petra? (*shudders*) . I had a bad experience with Petra... So let's not go there. :cry:

One more thing that's kind of stuck in my craw... Regardless of whether or not it's officially supported by openprinting.org, the printer works fine after update 7. The scanner, however, is officially supported under the sane-project.org, and that's the part I'm trying to get running right. Or did you even bother to read that far?
f2x
Level 1
Level 1
 
Posts: 2
Joined: Sun Mar 17, 2013 3:24 pm

Re: [SOLVED] /sort of... Scanner not working in LMDE

Postby cwsnyder on Mon Dec 16, 2013 7:48 pm

My experience is with Brother documentation on my DCP-7060D multi-function printer/fax/copier/scanner, and I had to go through several rounds to finally get my printer working under Ubuntu. I haven't even TRIED to get it working under my LMDE or Debian because of my problems getting it working under the supported Ubuntu distro. Your driver for the scanner doesn't seem to have been updated since 2007, according to http://home.arcor.de/wittawat/pixma/
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 3 guests