LMDE - What video drivers should I use?

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

LMDE - What video drivers should I use?

Postby Feldrok on Tue Apr 22, 2014 8:25 pm

Hello everyone, so I just updated to LMDE from Linux Mint 16 xfce... I want to know what video drivers I should install now, because I installed fglrx drivers one time and it got me Xorg problem. So I did a fresh install now and im not sure what drivers I should use, because my computer fans are running really fast and its really hot =(

In 16 xfce I had installed the non-free drivers and this helped a lot, but I dont want to get the Xorg problem again, because even though I tried lots of fixs I could not do it.
Feldrok
Level 1
Level 1
 
Posts: 37
Joined: Tue Dec 03, 2013 9:41 am

Linux Mint is funded by ads and donations.
 

Re: LMDE - What video drivers should I use?

Postby austin.texas on Wed Apr 23, 2014 7:55 am

Please post the results of this command in a terminal, so that we know what sort of system you have -
Code: Select all
inxi -Fx
Mint 17 v2 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 11
Level 11
 
Posts: 3786
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: LMDE - What video drivers should I use?

Postby Feldrok on Thu Apr 24, 2014 7:14 pm

Here it is...

Code: Select all
feldrok@matias-pc ~ $ inxi -fx
CPU:       Quad core AMD A10-4600M APU with Radeon HD Graphics (-MCP-) cache: 8192 KB bmips: 18364.4
           Clock Speeds: 1: 1400.00 MHz 2: 1400.00 MHz 3: 1400.00 MHz 4: 1400.00 MHz
           CPU Flags: 3dnowprefetch abm aes aperfmperf apic arat avx bmi1 clflush cmov cmp_legacy
           constant_tsc cpb cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid
           fma fma4 fpu fxsr fxsr_opt ht hw_pstate ibs lahf_lm lbrv lm lwp mca mce misalignsse mmx
           mmxext monitor msr mtrr nodeid_msr nonstop_tsc nopl npt nrip_save nx osvw pae pat pausefilter
           pclmulqdq pdpe1gb perfctr_core perfctr_nb pfthreshold pge pni popcnt pse pse36 rdtscp
           rep_good sep skinit sse sse2 sse4_1 sse4_2 sse4a ssse3 svm svm_lock syscall tbm tce topoext
           tsc tsc_scale vmcb_clean vme wdt xop xsave
Feldrok
Level 1
Level 1
 
Posts: 37
Joined: Tue Dec 03, 2013 9:41 am

Re: LMDE - What video drivers should I use?

Postby austin.texas on Fri Apr 25, 2014 6:34 am

The correct command is inxi -Fx
not inxi -fx
Mint 17 v2 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 11
Level 11
 
Posts: 3786
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: LMDE - What video drivers should I use?

Postby moorsb on Fri Apr 25, 2014 7:39 am

My system has been locking up actually 2 PC that I have installed Mint AMD 64 on. I changed my browser to chrome and it seems more stable on one of the PCs. The video goes nuts and the system locks up. On the PC that has been stable I ran the above command and it locks up shortly after the command. The other system just seems to be non responsive or take forever to load a program
moorsb
Level 1
Level 1
 
Posts: 1
Joined: Fri Apr 25, 2014 7:32 am

Re: LMDE - What video drivers should I use?

Postby Feldrok on Sun Apr 27, 2014 7:25 pm

austin.texas wrote:The correct command is inxi -Fx
not inxi -fx


Oh sorry, and sorry for the late response... here it is:
Code: Select all
feldrok@matias-pc ~ $ inxi -Fx
System:    Host: matias-pc Kernel: 3.11-2-amd64 x86_64 (64 bit, gcc: 4.8.1)
           Desktop: Cinnamon 2.0.14  Distro: LinuxMint 1 debian
Machine:   System: Hewlett-Packard product: HP Pavilion g4 Notebook PC version: 088B120000305910000610100
           Mobo: Hewlett-Packard model: 1848 version: 57.35 Bios: Insyde version: F.27 date: 04/12/2013
CPU:       Quad core AMD A10-4600M APU with Radeon HD Graphics (-MCP-) cache: 8192 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 18366.2
           Clock Speeds: 1: 1400.00 MHz 2: 1400.00 MHz 3: 1400.00 MHz 4: 1400.00 MHz
Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] Device 9900 bus-ID: 00:01.0
           Card-2: Advanced Micro Devices [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] bus-ID: 01:00.0
           X.Org: 1.14.3 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1366x768@60.1hz
           GLX Renderer: Gallium 0.4 on AMD ARUBA GLX Version: 3.0 Mesa 9.2.2 Direct Rendering: Yes
Audio:     Card-1: Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel bus-ID: 00:14.2
           Card-2: Advanced Micro Devices [AMD/ATI] Trinity HDMI Audio Controller driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture ver: k3.11-2-amd64
Network:   Card-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe driver: rt2800pci ver: 2.3.0 bus-ID: 02:00.0
           IF: wlan0 state: up mac: 1c:3e:84:6b:c7:49
           Card-2: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller
           driver: r8169 ver: 2.3LK-NAPI port: 2000 bus-ID: 05:00.0
           IF: eth0 state: down mac: d4:c9:ef:64:a5:f5
Drives:    HDD Total Size: 1000.2GB (8.0% used) 1: id: /dev/sda model: HGST_HTS541010A9 size: 1000.2GB
Partition: ID: / size: 93G used: 4.2G (5%) fs: ext4 ID: /home size: 810G used: 71G (10%) fs: ext4
           ID: swap-1 size: 16.54GB used: 0.00GB (0%) fs: swap
Sensors:   System Temperatures: cpu: 38.8C mobo: N/A gpu: 38.0,34.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 150 Uptime: 1 min Memory: 349.4/7405.3MB Runlevel: 2 Gcc sys: 4.8.2
           Client: Shell (bash 4.2.45) inxi: 1.9.14
Feldrok
Level 1
Level 1
 
Posts: 37
Joined: Tue Dec 03, 2013 9:41 am

Re: LMDE - What video drivers should I use?

Postby Previous1 on Sun Apr 27, 2014 8:42 pm

radeon if you don't need 3D and have no crashes/freezes. fglrx otherwise - preferably from AMD.com or Debian Sid to get the latest version. As to xorg, you've probably forgot to

Code: Select all
sudo aticonfig --initial -v
Image
Tutorials | cynicaltux
Arch Linux i3wm, 64bit
User avatar
Previous1
Level 4
Level 4
 
Posts: 367
Joined: Sun Dec 01, 2013 11:48 am

Re: LMDE - What video drivers should I use?

Postby austin.texas on Mon Apr 28, 2014 6:14 am

moorsb wrote:My system has been locking up actually 2 PC that I have installed Mint AMD 64 on. I changed my browser to chrome and it seems more stable on one of the PCs. The video goes nuts and the system locks up. On the PC that has been stable I ran the above command and it locks up shortly after the command. The other system just seems to be non responsive or take forever to load a program

You will probably get some help if you create a new thread. Be sure to include info on your hardware.
Mint 17 v2 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 11
Level 11
 
Posts: 3786
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: LMDE - What video drivers should I use?

Postby Feldrok on Mon Apr 28, 2014 8:34 am

Previous1 wrote:radeon if you don't need 3D and have no crashes/freezes. fglrx otherwise - preferably from AMD.com or Debian Sid to get the latest version. As to xorg, you've probably forgot to

Code: Select all
sudo aticonfig --initial -v


I think I did this, I really dont want to get this error again =(... Anyway I'll try again :?
Feldrok
Level 1
Level 1
 
Posts: 37
Joined: Tue Dec 03, 2013 9:41 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 5 guests