Blacklist pcspkr

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

Blacklist pcspkr

Postby Nicki on Tue Sep 21, 2010 4:46 pm

I have installed Mint Debian and I have that "beep" when I shut down the computer.
Tried to use "blacklist pcspkr" in /etc/modprobe.d/blacklist.conf as in earlier Mint but it didn't work.

Is this a bug in LMD?
Nicki
Level 3
Level 3
 
Posts: 164
Joined: Wed May 27, 2009 3:15 pm
Location: Sweden

Linux Mint is funded by ads and donations.
 

Re: Blacklist pcspkr

Postby DrHu on Tue Sep 21, 2010 5:17 pm

Try a Debian approach
http://forums.debian.net/viewtopic.php?t=30744
Julian67 post..
User avatar
DrHu
Level 17
Level 17
 
Posts: 7098
Joined: Wed Jun 17, 2009 8:20 pm

Re: Blacklist pcspkr

Postby Nicki on Wed Sep 22, 2010 2:08 am

Sorry, but nothing of that worked for me.

1. I used "blacklist snd_pcsp" instead of "blacklist pcspkr" in /etc/modprobe.d/blacklist.conf

2. Also made a file with the text:

#disable pcspkr
install pcspkr /bin/true

as root and saved it as /etc/modprobe.d/00local

3. blacklist snd_pcsp in /etc/modprobe.d/fbdev-blacklist.conf

4. "lsmod | grep spkr" gave no output

:cry:
Nicki
Level 3
Level 3
 
Posts: 164
Joined: Wed May 27, 2009 3:15 pm
Location: Sweden

Re: Blacklist pcspkr

Postby mikhou on Wed Sep 22, 2010 7:53 am

I had the exact same problem, and I tried all of the fixes that you mentioned. The one that worked for me was SO simple. I installed Gnome Alsa Mixer, and there's a fader and a Mute button for the PC Beep. Just mute it. I'm sure that it's different problems on different hardware, but for reference, I did this on a Dell Inspiron 1420. I just did this last night, and I haven't had a beep since. Good luck!

mikhou
mikhou
Level 4
Level 4
 
Posts: 234
Joined: Sat Sep 05, 2009 8:55 am

Re: Blacklist pcspkr

Postby Nicki on Wed Sep 22, 2010 8:08 am

Thanks mikhou,
But that was the first thing I looked upon. But so strange because the toggel was already at the bottom so there should not be any beep, but sadly there was.
Nicki
Level 3
Level 3
 
Posts: 164
Joined: Wed May 27, 2009 3:15 pm
Location: Sweden

Re: Blacklist pcspkr

Postby newfie on Wed Sep 22, 2010 8:15 am

Strange... I did "blacklist pcspkr" as well and it worked.
User avatar
newfie
Level 2
Level 2
 
Posts: 96
Joined: Fri Nov 20, 2009 2:47 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 5 guests