ATI and compiz

Questions about hardware and drivers
Forum rules
Before you post please read this

ATI and compiz

Postby Cobalt60 on Fri Jan 07, 2011 6:47 pm

Hello everyone. This is my first post on a Linux Mint forum. Ive been using solely Debian Stable for the past year, and before that dual booting Debian and Windows, using Debian fairly often. Well, after Mint came out with LMDE, I decided to finally give Mint (another) try, especially since I wanted to try a rolling distro. Gotta say, I am very impressed, compared to regular Debian, each has their strengths and weaknesses.

Anyway, just wanna try to get Compiz working. I see there are guides on getting it working with Intel and nVidia cards, but not ATI, so I dont know how useful those guides would be for me. I am currently using the fglrx driver, and Catalyst Control Center seems to be working flawlessly. The card I am using is a Radeon 4850/1GB.

Well, thanks for any help.

-Chris P
Cobalt60
Level 1
Level 1
 
Posts: 6
Joined: Fri Jan 07, 2011 6:36 pm

Linux Mint is funded by ads and donations.
 

Re: ATI and compiz

Postby conslie on Sat Jan 08, 2011 3:58 am

Not on LMDE now (I couldn't figure out how to get one proprietary must-have working), but when I tried it I recall a similar problem. Checked the same set of favored effects as are now checked in LM10, but nothing worked. The solution was to also check Effects/Animations and maybe Animations Add-On.

Try that, and if it doesn't help, at least this will kick up the question.
conslie
Level 4
Level 4
 
Posts: 369
Joined: Sun Oct 11, 2009 2:03 am

Re: ATI and compiz

Postby lepadatu.lucian on Sat Jan 08, 2011 4:27 am

Hy. Chris, did you start your compiz with "compiz --replace" ? if not, give it a go.
lepadatu.lucian
Level 1
Level 1
 
Posts: 10
Joined: Sat Jan 08, 2011 4:03 am
Location: Romania

Re: ATI and compiz

Postby Cobalt60 on Sat Jan 08, 2011 9:40 am

"compiz --replace" did it. Thanks much!

-Chris P
Cobalt60
Level 1
Level 1
 
Posts: 6
Joined: Fri Jan 07, 2011 6:36 pm

Re: ATI and compiz

Postby Cobalt60 on Sat Jan 08, 2011 11:48 am

OK I gotta ask, since Compiz seems to slow down my 3D games. How can I disable it after it is enabled? I notice it doesnt automatically start when the computer starts, which is fine.

Thanks

-Chris P
Cobalt60
Level 1
Level 1
 
Posts: 6
Joined: Fri Jan 07, 2011 6:36 pm

Re: ATI and compiz

Postby lepadatu.lucian on Sat Jan 08, 2011 3:54 pm

You can install fusion-icon and make it start at boot via Menu>Preferences>Startup Applications. This will only load the icon which will appear in the bottom right, on the panel. Then you can right click on it and choose Reload Window Manager in order to start compiz. You can disable compiz by selecting Metacity from Select Window Manager.
lepadatu.lucian
Level 1
Level 1
 
Posts: 10
Joined: Sat Jan 08, 2011 4:03 am
Location: Romania


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 5 guests