No 3D rendering for Intel 865g under LMDE (SOLVED)

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

Re: No 3D rendering for Intel 865g under LMDE (SOLVED)

Postby sumski on Sun May 22, 2011 3:31 am

You got no DRI , because shadow buffer option is on by default on i8xx hardware:
http://packages.debian.org/changelogs/pool/main/x/xserver-xorg-video-intel/xserver-xorg-video-intel_2.13.0-6/changelog#versionversion2:2.12.0_shadow-1
Shadow buffer is there because drivers/KMS is broken with (some) i8xx cards , and you get GPU hangs /lockups if you use DRI.
Here's upstream bug report for i855:
https://bugs.freedesktop.org/show_bug.cgi?id=27187
They fixed the problem for this card , with .38 kernel , i think , but other i8xx remain problematic.
Acer Extensa 5630G - Core2Duo T5800 2GHz , 4 GB ram, Ati Mobility 3650.
OpenSUSE 12.1 KDE 4.7.3
Debian Sid KDE 4.7.1/2
User avatar
sumski
Level 3
Level 3
 
Posts: 109
Joined: Fri Nov 26, 2010 6:36 am
Location: Zagreb, Croatia

Linux Mint is funded by ads and donations.
 

Re: No 3D rendering for Intel 865g under LMDE (SOLVED)

Postby Pranaone on Wed May 25, 2011 10:51 pm

@unico I'm so sorry, i was having my exams, so i was totally carried away with it.
Anyways the modified drivers are available in the latest mint (Katya) release, If your lucky it should work, haven't tried it in lmde but i think upgrading xorg-server might do the trick. Be careful though xorg has tendency to break your system, but i think you'd already known that.
User avatar
Pranaone
Level 3
Level 3
 
Posts: 149
Joined: Fri May 14, 2010 12:50 am
Location: Sri Lanka

Re: No 3D rendering for Intel 865g under LMDE (SOLVED)

Postby Pranaone on Wed May 25, 2011 11:04 pm

@ sumski thank you for sharing, I've already found that article you referred to and updated my kernel to 2.6.38, and my problems were solved. I didn't post it here since i thought my thread was dead. I believe your post will be helpful to others having the same problem.
User avatar
Pranaone
Level 3
Level 3
 
Posts: 149
Joined: Fri May 14, 2010 12:50 am
Location: Sri Lanka

Re: No 3D rendering for Intel 865g under LMDE (SOLVED)

Postby o_unico on Sat Jun 11, 2011 12:05 pm

Pranaone wrote:@unico I'm so sorry, i was having my exams, so i was totally carried away with it.
Anyways the modified drivers are available in the latest mint (Katya) release, If your lucky it should work, haven't tried it in lmde but i think upgrading xorg-server might do the trick. Be careful though xorg has tendency to break your system, but i think you'd already known that.

I'm always updating Xorg via update manager but nothing has changed since then.
o_unico
Level 1
Level 1
 
Posts: 19
Joined: Sun Dec 05, 2010 10:49 am

Previous

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 3 guests