LMDE and Nvidia Drivers

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

LMDE and Nvidia Drivers

Postby XidCat on Thu Jan 20, 2011 6:48 pm

After a year of Win7 (starting freezing constantly), I went back to LM10. I hate the reinstalls for new versions though (that drove me back to Windows). Finally, I wrote LMDE over my Windows partitions, and the only problem I had were the nouveau drivers. All my windows rolled over the right edge of the screen and same with the task bar clock. I dreaded installing the NVIDIA drivers (I read the horror stories), but I did it anyways. In 10 minutes I was done, no fuss, no hassle. I have a GeForce 6150 card, but it should work for similar cards.

1. Went to the NVIDIA website, plugged in my card/OS info into their driver download section. Downloaded and wrote down file name and location.
2. Rebooted into LMDE recovery, navigated by CLI to the folder and ran the NVIDIA driver bin; ./filename
3. It popped up and said nouveau was not compatible with NVIDIA, would I like to disable nouveau. Yes.
4. Reboot into recovery again.
5. Repeat step 2. Smooth sailing, gave me an incompatible GCC scare, ignored it... (feeling lucky) :mrgreen:
6. Rebooted when all was done, graphics work perfect. NVIDIA settings installed, running NVIDIA 260.19.29 (LM10 on my other HDD is running 173 via Jockey)

Other than the graphics, I've no issues with LMDE. Loving LMDE and glad I'm finally on a rolling release. Thanks all who made it happen...
"Contrariwise", continued Tweedledee, "if it was so, it might be; and if it were so, it would be; but as it isn't, it ain't. That's logic."

Lewis Carroll, Through the Looking-Glass, Chapter 4
XidCat
Level 3
Level 3
 
Posts: 148
Joined: Sun Oct 18, 2009 9:05 pm

Linux Mint is funded by ads and donations.
 

Re: LMDE and Nvidia Drivers

Postby dawgdoc on Thu Jan 20, 2011 10:48 pm

Same procedure worked for me back in September, so my driver was not quite as new. I haven't upgraded since.
Code: Select all
Graphics:  Card nVidia C51 [Geforce Go 6150] X.Org 1.7.7 Res: 1280x800@50.0hz
           GLX Renderer GeForce Go 6150/PCI/SSE2/3DNOW! GLX Version 2.1.2 NVIDIA 256.53
Image

SYSTEM: Compaq Presario CQ62 Dual-Boot: Mint 17 Cinnamon, LMDE
READING: Smoke Screen by Dick Francis
User avatar
dawgdoc
Level 9
Level 9
 
Posts: 2716
Joined: Mon Oct 05, 2009 12:53 am
Location: Kentucky, USA the land of Mint Juleps

Re: LMDE and Nvidia Drivers

Postby XidCat on Thu Jan 20, 2011 11:20 pm

dawgdoc wrote:Same procedure worked for me back in September, so my driver was not quite as new. I haven't upgraded since.


You're probably not missing much, I went back through the change logs, most of the upgrades are adding new hardware or unscrewing previous "fixes". I have no plans to upgrade mine either. Let sleeping dogs lie... :)
"Contrariwise", continued Tweedledee, "if it was so, it might be; and if it were so, it would be; but as it isn't, it ain't. That's logic."

Lewis Carroll, Through the Looking-Glass, Chapter 4
XidCat
Level 3
Level 3
 
Posts: 148
Joined: Sun Oct 18, 2009 9:05 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 4 guests