Nvidia GeForce2 and compiz

Questions about hardware and drivers
Forum rules
Before you post please read this

Nvidia GeForce2 and compiz

Postby k0mll on Wed Feb 09, 2011 4:22 pm

I have read the tutorials and installed the legacy driver/kernel per the tutorial. (http://community.linuxmint.com/tutorial/view/168)
For reference lspci reports by board as:
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)

I followed the tutorial using the 96xx legacy and it seems to have installed and is running now. Ran nvidia-xconfig which wrote a new file and then nvidia-settings.

compiz --replace fails and in terminal reports as:
michael@main ~ $ compiz --replace
Backend : gconf
Integration : true
Profile : default
Adding plugins
Initializing core options...done
Initializing move options...done
Initializing resize options...done
Initializing place options...done
Initializing decoration options...done
compiz (core) - Warn: No GLXFBConfig for depth 32

Launching fallback window manager

--at this point the terminal is "busy" and a control-c will remove my window frames and title bars, in which case I have to ctrl-alt-backspace to restart start x and it is back to normal.

No compiz. Any ideas what went wrong? Any help appreciated. I thank you in advance. Just a fyi, MINT 8 ran compiz perfectly.
k0mll
Level 1
Level 1
 
Posts: 21
Joined: Mon Nov 02, 2009 7:15 pm

Linux Mint is funded by ads and donations.
 

Re: Nvidia GeForce2 and compiz

Postby smika on Wed Feb 09, 2011 4:27 pm

Here the same issues with an Ati 4300 videocard.
smika
Level 1
Level 1
 
Posts: 8
Joined: Fri Aug 13, 2010 7:06 am

Re: Nvidia GeForce2 and compiz

Postby twa on Wed Feb 09, 2011 5:12 pm

k0mill,
I followed this procedure for my NVidia card and configure compiz:
Driver video open source

This is the driver pre-installed in the system and it works with every VGA used: ATI/AMD,nVIDIA and Intel.

It is recommended if you do not want to install the proprietary drivers or if these are not campatible.
If your AMD/ATI model is NOT in the "HD series" category or an Intel graphic card, you can use only this driver; if you use an AMD/ATI in the "HD series" or nVIDIA, you can use the proprietary driver which is
usually more stable and performing of the Open drivers.

The Open driver does not need to be installed, and is disabled by default.
To activate it open Synaptic and search the package named: libgl1-mesa-dri
Doble click to install the package, then click on Apply.
Close Synaptic and reboot the system.
After the system has rebooted open the terminal and type:
glxinfo | grep render
if the output is similar to the image, the driver is active and working.

Proprietary nVIDIA Video Driver
If we want the maximum from our nVIDIA video card we must install the proprietary driver.
Open the terminal and type:
su -> password
apt-get install module-assistant
apt-get install nvidia-kernel-common
apt-get install nvidia-glx
apt-get install nvdia-kernel-source
apt-get install nvidia-xconfig
after the installation need to activate the driver from the same terminal by typing:
m-a prepare
m-a a-i nvidia
modprobe nvidia
nvidia-xconfig
.
Shut-down and reboot the PC
Verify if the driver has been successfully installed by typing from the terminal:
glxinfo | grep render

Proprietary ATI/AMD video driver
are available only for the more recent models, those in the "HD series"

The models NOT in the "HD series" can use only the Open driver.

For the "HD series" this is the procedure:
download the correct driver from here: http://support.amd.com/us/gpudownload/Pages/index.aspx
put the downloaded file in your Home and rename it " driver.run "
open the terminal and type: cd /home/yourusername
make the file executable by typing: sudo chmod a+rwx driver.run
execute the file by typing : sudo ./driver.run
follow the on-screen instructions till the end of the installation
activate the driver from the same terminal by typing : sudo aticonfig --initial -f
shutdown and reboot the system open the terminal and verify if the driver has been successfully installed
by typing : glxinfo | grep render

When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread.
User avatar
twa
Level 4
Level 4
 
Posts: 231
Joined: Fri Sep 17, 2010 8:11 am
Location: Somewhere in the sky

Re: Nvidia GeForce2 and compiz

Postby k0mll on Thu Feb 10, 2011 1:28 pm

Thank you twa,
I installed my spare hard drive to do this one, because it looked similar or functionally like a Debian post, which ended up with the same results on my GeForce2 board... a black screen with a flashing cursor and no functionality. So it made it unusable, my thoughts are nvidia-glx is the responsible bit of code. I only think this because I had the other stuff installed per your list. Looks like I am without my compiz. I am currently running Nvidia drivers and get this w/ glxinfo:

michael@main ~ $ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: GeForce2 MX/AGP/SSE2

Thank you for the answer and try at this, if there is another idea, I'll try to fix the spare test drive LMDE and go for more trials. --mike
k0mll
Level 1
Level 1
 
Posts: 21
Joined: Mon Nov 02, 2009 7:15 pm

Re: Nvidia GeForce2 and compiz

Postby twa on Thu Feb 10, 2011 4:45 pm

k0mill,
NVidia driver is now installed... U need to activate compiz

viewtopic.php?f=141&t=64346
ciao
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread.
User avatar
twa
Level 4
Level 4
 
Posts: 231
Joined: Fri Sep 17, 2010 8:11 am
Location: Somewhere in the sky

Re: Nvidia GeForce2 and compiz

Postby k0mll on Thu Feb 10, 2011 6:03 pm

I guess I am confusing the issue. Using my original hard drive:
It does appear to be using the Nvidia driver and the Nvidia utilities even acknowledge it.
I have the setup using my main hard drive with this driver installed per the tutorial in the blog as stated in the first post. The compiz --replace command fails, and in a terminal gives the results above in the first post, closing that terminal makes an unusable desktop, so ctrl-alt-backspace has to be used.

Using a test hard drive replacing my original:
Installed is the same LMDE. Then used your method above to install Nvidia drivers and results in a black screen with flashing cursor. I have not attempted to recover it. Your method was similar to the method explained on the Debian forums, and had the same result.

Plugging back the Original hard drive I am convinced the Nvidia driver is in use, but compiz --replace fails. and the final lines in terminal are:
........
Initializing decoration options...done
compiz (core) - Warn: No GLXFBConfig for depth 32

Launching fallback window manager (closing the terminal at this point renders the desktop unusable)

So I suppose I need to know what GLXFBConfig is and how to fix it.
Are there more tests, for configuration or to find any missing components?
Thank you................Mike (k0mll)
k0mll
Level 1
Level 1
 
Posts: 21
Joined: Mon Nov 02, 2009 7:15 pm

Re: Nvidia GeForce2 and compiz

Postby k0mll on Sat Feb 19, 2011 9:51 am

No ideas came up to fix this or help me trouble shoot it. It did use Nvidia drivers and the games worked well because of it, but compiz was never good.
So I gave up and installed KDE Mint and it works perfect for the "eye candy" and the games work too. I really wanted the computer to have a rolling operating system, but the NEW KDE is full of eye candy and although a bit slower it works.
k0mll
Level 1
Level 1
 
Posts: 21
Joined: Mon Nov 02, 2009 7:15 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 3 guests