Can't Print with LMDE --Help

Questions about hardware and drivers
Forum rules
Before you post please read this

Can't Print with LMDE --Help

Postby malligt on Thu Feb 17, 2011 11:32 am

I can't print using LMDE 32 bit to my hp laserjet P1005 that is connected to a Win 7 64 bit machine.

I keep getting an error message:

/usr/lib/cups/filter/foomatic-rip failed (see screenshot)

What am I missing here? Please help!

Thanks.
Attachments
Screenshot.png
Screenshot.png (478.03 KiB) Viewed 2442 times
malligt
Level 4
Level 4
 
Posts: 254
Joined: Sat Sep 11, 2010 12:58 pm

Linux Mint is funded by ads and donations.
 

Re: Can't Print with LMDE --Help

Postby mads on Thu Feb 17, 2011 12:25 pm

Hi!

Check out this link.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: Can't Print with LMDE --Help

Postby MissileCop on Thu Feb 17, 2011 3:42 pm

Do you know if you even have foomatic-rip installed?

When installing my HP c310a printer recently, I had issues with the foomatic-rip filter. If you don't already have it, install hpijs-ppds which does have the foomatic-rip filter, and see if that clears up your problem. That's what did the trick for me. The hpijs-ppds can be found in the Package Manager.
MissileCop
Level 1
Level 1
 
Posts: 36
Joined: Thu Jul 17, 2008 12:21 pm

Re: Can't Print with LMDE --Help

Postby malligt on Fri Feb 18, 2011 5:55 am

Thanks to both for the reply:

@mads

I don't understand what that link is saying, so I'm at a loss of what to do.

@MissleCop

I followed your advice, went to package manager and installed the hpijs-ppds....however I'm still getting the foomatic rip error.

What should I do now?
malligt
Level 4
Level 4
 
Posts: 254
Joined: Sat Sep 11, 2010 12:58 pm

Re: Can't Print with LMDE --Help

Postby mads on Fri Feb 18, 2011 7:30 am

malligt wrote:@mads
I don't understand what that link is saying, so I'm at a loss of what to do.

Sorry, my mistake. That link is about the driver for Minolta printers.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: Can't Print with LMDE --Help

Postby MissileCop on Fri Feb 18, 2011 1:34 pm

All right, let's have another crack at this.

Where you're seeing the failure ( /usr/lib/cups/filter/foomatic-rip ) is actually a link to the foomatic-rip file in /usr/bin.

Navigate to /usr/lib/cups/filter. Double click the Computer icon on the Desktop, Click on File System, then follow the path laid out.

Once in the Filter folder, right click on foomatic-rip, then click on Properties. Under Permissions, see if the "Allow executing file as program" is X'd. If -not-, close out that box, then hit the back arrow once. Right click on the folder Filter, and open as Administrator. Right click on foomatic-rip, click on Properties, click on Permissions tab, and X the box allowing it to run as a program. Make sure that the permissions are set to Owner-root / read and write, and Group-root / read-only, then click Close.

Also may want to check that the foomatic-rip file in /usr/bin is X'd as allowing to execute as a program, with the same Permissions listed above.

Looking at my system, I have the following foomatic packages installed; foomatic-filters-ppds, foomatic-db-engine, foomatic-db, and foomatic-filters. If you do not have one or any of these, install, or reinstall those and see if it helps.

I'm by no means a Linux expert, and am probably closer to a half step above a newbie, but the male side of my family has a dominant Stubborn gene which sometimes comes in handy. :mrgreen: We'll find an answer one way or another.
MissileCop
Level 1
Level 1
 
Posts: 36
Joined: Thu Jul 17, 2008 12:21 pm

Re: Can't Print with LMDE --Help

Postby malligt on Sun Feb 20, 2011 8:25 pm

Thanks for your information....upon exam, everything looked just as you described, and I had all the foomatic packages you mentioned, already installed. Fun eh?
malligt
Level 4
Level 4
 
Posts: 254
Joined: Sat Sep 11, 2010 12:58 pm

Re: Can't Print with LMDE --Help

Postby jcoleman on Mon Feb 21, 2011 5:22 pm

This may not help and I haven't had to deal with this sort of thing for some time.

In general, I have the best success with printers, samba, file sharing, etc when using the "IP address" of the "host" (the piece of networked equipment or the computer doing the sharing) instead of "names";

ie:
smb://"ip address"/

or if using "CUPS"

ipp://"ip address":631/printers/"name of printer"
jcoleman
Level 1
Level 1
 
Posts: 18
Joined: Fri Dec 15, 2006 1:10 pm
Location: Dove Creeek, CO

Re: Can't Print with LMDE --Help

Postby David Brown on Wed Jun 08, 2011 9:47 pm

Hey Malligt

Did you ever manage to print? I have exactly the same problem getting LMDE to print to a Laserjet p1505 connected to a WinXP box. I'm dual booting LinuxMint 9 and it works perfectly when that's running. It worked on earlier versions of LinuxMint, too, but not on LM-11 or LMDE.

I did check the execute flag and permissions for foomatic-rip as MissileCop suggested, and they're as he said they should be.

David Brown
David Brown
Level 2
Level 2
 
Posts: 56
Joined: Sat Jun 28, 2008 5:55 pm

Re: Can't Print with LMDE --Help

Postby mikebravo on Wed Jun 08, 2011 11:13 pm

At the risk of being simplistic, may I ask if you have tried the route at
http://hplipopensource.com/hplip-web/downloads.html
mikebravo
Level 1
Level 1
 
Posts: 12
Joined: Sat May 28, 2011 10:07 pm

Re: Can't Print with LMDE --Help

Postby David Brown on Sun Jun 12, 2011 7:16 pm

Problem solved, in my case it least. The printer driver that works with my wife's Laserjet p1505 from my computer running LM9 is foo2xqx. I couldn't find this in Synaptic's listing. I Googled it, and found a hint that foo2xqx is included in a download of foo2zjs. I installed this, changed the printer driver (again), found foo2xqx in the list, selected it, and now it all "just works".

To mikebravo, yes I did explore HPs online help and downloads, but hplip didn't work any better than hpijs.

David Brown
David Brown
Level 2
Level 2
 
Posts: 56
Joined: Sat Jun 28, 2008 5:55 pm

Re: Can't Print with LMDE --Help

Postby David Brown on Wed Nov 09, 2011 7:11 pm

But with the 64-bit version of LMDE, when foo2zjs is installed, Synaptic helpfully uninstalls cups, cups-driver-gutenprint, cups-pdf, hplip and hplip-cups. Then nothing works!
David Brown
Level 2
Level 2
 
Posts: 56
Joined: Sat Jun 28, 2008 5:55 pm

Re: Can't Print with LMDE --Help

Postby faffmeister on Mon Nov 21, 2011 7:26 pm

Regarding foo2zjs wanting to uninstall CUPS, reverting to the Squeeze version may be of some help.

I used that approach to fix a similar problem in LMDE 64bit with a Minolta printer that uses foo2zjs:

viewtopic.php?f=198&t=82584&p=479005&hilit=foo2zjs#p479005
faffmeister
Level 1
Level 1
 
Posts: 16
Joined: Mon Dec 27, 2010 4:18 pm

Re: Can't Print with LMDE --Help

Postby Orbital_sFear on Wed Mar 14, 2012 2:57 pm

I had an issue getting my HP 2600n working. I had mild success installing the HP driver directly, however the color was icky. Also after about a dozen reboots, it stopped working randomly. I followed all the info in these posts, nothing worked.

Here is what I did which did end up working with my HP 2600n, running on LMDE, XFCE:

Goto: http://foo2hp.rkkda.com/

Follow the instructions on the website, OR if you have my extra printer, do this:
cd /tmp
wget -O foo2zjs.tar.gz http://foo2zjs.rkkda.com/foo2zjs.tar.gz
tar zxf foo2zjs.tar.gz
cd foo2zjs

make

./getweb 2600n # Get HP LaserJet 2600n .ICM files

sudo make install
sudo make cups

At this point, my permissions were "insecure"; the cups-insecure-filter flag was set. To fix this, I did the following:
cd /usr/lib/cups/filter
sudo chown root:root *
sudo chmod 755 *
cd ../backned
sudo chown root:root *
sudo chmod 755 *

Close system-config-printer if its running.
Start system-config-printer

Remove all printers except PDF
Add a new printer, select the 2600n
After clicking next next next next, you should be at the printer properties window.
Under Make and Modle: xxxx -> click change
Select HP -> 2600n -> foo2hp #This will ensure you are no longer using the hplip driver, and actually using foo2hp

After all this, print a test page and you should be seeing wonderful color. I know it sucks not using apt-get for everything, however I simply couldn't get foo2xxx working with apt-get and cups.

-Orbital
Orbital_sFear
Level 1
Level 1
 
Posts: 7
Joined: Thu Mar 01, 2012 6:11 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 4 guests