can not use built in bluetooth , hcitool dev empty

Questions about hardware and drivers
Forum rules
Before you post please read this

can not use built in bluetooth , hcitool dev empty

Postby indosupremacy on Mon Mar 21, 2011 8:54 am

The first time i installed LMDE , my bluetooth works fine,bluetooth hotkey (laptop ) works fine , LMDE can detect it and i can use it.
The problem is , a week ago , i have made some sort of change through start up application and services , i have been disabling bluetooth start up application and services for bluetooth . And now , after enabling it again (via service and startup application) , after restart the bluetooth hotkey are pointing to brightness hotkey . bluetooth still not working .And , after doing some googling , i have done hcitool dev which is empty .
This is the data that might be usefull
$ sudo lsmod | grep bluetooth
bluetooth 41827 6 rfcomm,sco,bnep,l2cap
rfkill 13044 5 bluetooth,cfg80211,acer_wmi
$ sudo lsmod | grep hci
sdhci_pci 5581 0
sdhci 13966 1 sdhci_pci
ahci 32374 1
firewire_ohci 19676 0
firewire_core 36848 1 firewire_ohci
mmc_core 45686 1 sdhci
led_class 2433 4 iwl3945,iwlcore,acer_wmi,sdhci
libata 133632 3 ata_generic,ata_piix,ahci
uhci_hcd 18521 0
ehci_hcd 32081 0
usbcore 122386 7 sierra,usbserial,usbhid,usb_storage,uhci_hcd,ehci_hcd


looks like the module are loaded right, hardware are detected ,but still i cant use it .
when doing bluetooth-applet , it say that applet are already running (but i can't see it )
doing 'hcitool dev ' give me empty , sudo hciconfig give me empty result too.

anybody know how to fix this ? thank you .
indosupremacy
Level 1
Level 1
 
Posts: 6
Joined: Thu Mar 03, 2011 7:48 am

Linux Mint is funded by ads and donations.
 

Re: can not use built in bluetooth , hcitool dev empty

Postby monkeytennis on Wed Mar 30, 2011 4:53 pm

I have the same issue. My applet is there but it says bluetooth disabled and no matter what I do it will not enable! Very annoying!
monkeytennis
Level 1
Level 1
 
Posts: 8
Joined: Thu Mar 17, 2011 3:11 am
Location: Glasgow

Re: can not use built in bluetooth , hcitool dev empty

Postby mandeep on Tue Jul 26, 2011 5:57 am

Did anyone find a solution to this? The applet shows bluetooth disabled though i can find devices in hcitool.
mandeep
Level 1
Level 1
 
Posts: 4
Joined: Sat Apr 16, 2011 1:38 am

Re: can not use built in bluetooth , hcitool dev empty

Postby lauren on Tue Jul 26, 2011 11:14 am

Hi!
Code: Select all
dmesg

is a protocol with a plenty of pages; if you want to know what happened concerning e.g. BT you can run:
Code: Select all
dmesg | grep bluetooth


Edit:
Code: Select all
usb-devices

shows my BT device (and others).
lauren
Level 5
Level 5
 
Posts: 588
Joined: Thu Nov 26, 2009 10:50 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 3 guests