No 3d after ati driver installation

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

No 3d after ati driver installation

Postby AlexanderPCT on Tue Apr 05, 2011 9:44 am

First I installed the repository --> 3d (kde efffects) worked, but no fan control.
After that downloaded the .run from amd itself --> installed it ---> finally fancontroal (jea :D) but no more 3d :((


heres my xorg log
Code: Select all
X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.37-trunk-amd64 x86_64 Debian
Current Operating System: Linux melchior 2.6.32-5-amd64 #1 SMP Thu Nov 25 18:02:11 UTC 2010 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-amd64 root=UUID=ca2c013e-99ce-4363-9319-3056367a2582 ro quiet
Build Date: 18 February 2011  08:27:24PM
xorg-server 2:1.7.7-13 (Cyril Brulebois <kibi@debian.org>)
Current version of pixman: 0.18.4
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Apr  5 15:24:19 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(==) ServerLayout "aticonfig Layout"
(**) |-->Screen "aticonfig-Screen[0]-0" (0)
(**) |   |-->Monitor "aticonfig-Monitor[0]-0"
(**) |   |-->Device "aticonfig-Device[0]-0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
   Entry deleted from font path.
(==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/Type1,
   /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
   built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
(II) Loader magic: 0x7c8aa0
(II) Module ABI versions:
   X.Org ANSI C Emulation: 0.4
   X.Org Video Driver: 6.0
   X.Org XInput driver : 7.0
   X.Org Server Extension : 2.0
(++) using VT number 7

(--) PCI:*(0:2:0:0) 1002:9553:1028:0413 ATI Technologies Inc M92 [Mobility Radeon HD 4500 Series] rev 0, Mem @ 0xd0000000/268435456, 0xcfef0000/65536, I/O @ 0x00002000/256, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) "extmod" will be loaded by default.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded by default.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/fglrx/libglx.so
(II) Module glx: vendor="FireGL - ATI Technologies Inc."
   compiled for 6.9.0, module version = 1.0.0
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.13.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.1.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
   compiled for 1.4.99.906, module version = 8.83.6
   Module class: X.Org Video Driver
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
   compiled for 1.4.99.906, module version = 8.83.6
(II) ATI Proprietary Linux Driver Version Identifier:8.83.6
(II) ATI Proprietary Linux Driver Release Identifier: 8.831.2                             
(II) ATI Proprietary Linux Driver Build Date: Mar  8 2011 22:53:31
(II) Primary Device is: PCI 02@00:00:0
(WW) Falling back to old probe method for fglrx
(II) Loading PCS database from /etc/ati/amdpcsdb
(--) Chipset Supported AMD Graphics Processor (0x9553) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:1) found
(II) AMD Video driver is running on a device belonging to a group targeted for this release
(II) AMD Video driver is signed
(II) fglrx(0): pEnt->device->identifier=0xaefb10
(II) fglrx(0): === [xdl_x750_atiddxPreInit] === begin
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/lib/xorg/modules/libvgahw.so
(II) Module vgahw: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 0.1.0
   ABI class: X.Org Video Driver, version 6.0
(**) fglrx(0): Depth 24, (--) framebuffer bpp 32
(II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
(==) fglrx(0): Default visual is TrueColor
(**) fglrx(0): Option "DPMS" "true"
(==) fglrx(0): RGB weight 888
(II) fglrx(0): Using 8 bits per RGB
(==) fglrx(0): Buffer Tiling is ON
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Reloading /usr/lib/xorg/modules/linux/libfglrxdrm.so
ukiDynamicMajor: found major device number 251
ukiDynamicMajor: found major device number 251
ukiOpenByBusid: Searching for BusID PCI:2:0:0
ukiOpenDevice: node name is /dev/ati/card0
ukiOpenDevice: open result is 11, (OK)
ukiOpenByBusid: ukiOpenMinor returns 11
ukiOpenByBusid: ukiGetBusid reports PCI:2:0:0
(==) fglrx(0): NoAccel = NO
(==) fglrx(0): ATI 2D Acceleration Architecture enabled
(--) fglrx(0): Chipset: "ATI Mobility Radeon HD 4500 Series" (Chipset = 0x9553)
(--) fglrx(0): (PciSubVendor = 0x1028, PciSubDevice = 0x0413)
(==) fglrx(0): board vendor info: third party graphics adapter - NOT original ATI
(--) fglrx(0): Linear framebuffer (phys) at 0xd0000000
(--) fglrx(0): MMIO registers at 0xcfef0000
(--) fglrx(0): I/O port at 0x00002000
(==) fglrx(0): ROM-BIOS at 0x000c0000
(II) fglrx(0): ATIF platform detected
(II) fglrx(0): AC Adapter is used
(II) fglrx(0): Primary V_BIOS segment is: 0xc000
(II) Loading sub module "vbe"
(II) LoadModule: "vbe"
(II) Loading /usr/lib/xorg/modules/libvbe.so
(II) Module vbe: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.1.0
   ABI class: X.Org Video Driver, version 6.0
(II) fglrx(0): VESA BIOS detected
(II) fglrx(0): VESA VBE Version 3.0
(II) fglrx(0): VESA VBE Total Mem: 16384 kB
(II) fglrx(0): VESA VBE OEM: ATI ATOMBIOS
(II) fglrx(0): VESA VBE OEM Software Rev: 11.22
(II) fglrx(0): VESA VBE OEM Vendor: (C) 1988-2005, ATI Technologies Inc.
(II) fglrx(0): VESA VBE OEM Product: M92
(II) fglrx(0): VESA VBE OEM Product Rev: 01.00
(II) fglrx(0): ATI Video BIOS revision 9 or later detected
(--) fglrx(0): Video RAM: 524288 kByte, Type: DDR3
(II) fglrx(0): PCIE card detected
(--) fglrx(0): Using per-process page tables (PPPT) as GART.
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(II) fglrx(0): Using adapter: 2:0.0.
(II) fglrx(0): [FB] MC range(MCFBBase = 0xf00000000, MCFBSize = 0x20000000)
(II) fglrx(0): Interrupt handler installed at IRQ 35.
(II) fglrx(0): RandR 1.2 support is enabled!
(II) fglrx(0): RandR 1.2 rotation support is enabled!
(==) fglrx(0): Center Mode is disabled
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Module "ddc" already built-in
(II) fglrx(0): Finished Initialize PPLIB!
(II) fglrx(0): Output LVDS using monitor section aticonfig-Monitor[0]-0
(II) fglrx(0): Output DFP1 has no monitor section
(II) fglrx(0): Output CRT2 has no monitor section
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Module "ddc" already built-in
(II) fglrx(0): Connected Display0: LVDS
(II) fglrx(0): Display0 EDID data ---------------------------
(II) fglrx(0): Manufacturer: LGD  Model: 20b  Serial#: 0
(II) fglrx(0): Year: 2009  Week: 0
(II) fglrx(0): EDID Version: 1.3
(II) fglrx(0): Digital Display Input
(II) fglrx(0): Max Image Size [cm]: horiz.: 35  vert.: 19
(II) fglrx(0): Gamma: 2.20
(II) fglrx(0): No DPMS capabilities specified
(II) fglrx(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
(II) fglrx(0): First detailed timing is preferred mode
(II) fglrx(0): redX: 0.617 redY: 0.349   greenX: 0.313 greenY: 0.595
(II) fglrx(0): blueX: 0.151 blueY: 0.056   whiteX: 0.313 whiteY: 0.329
(II) fglrx(0): Manufacturer's mask: 0
(II) fglrx(0): Supported detailed timing:
(II) fglrx(0): clock: 138.5 MHz   Image Size:  345 x 194 mm
(II) fglrx(0): h_active: 1920  h_sync: 1968  h_sync_end 2000 h_blank_end 2080 h_border: 0
(II) fglrx(0): v_active: 1080  v_sync: 1083  v_sync_end 1088 v_blanking: 1111 v_border: 0
(II) fglrx(0): Supported detailed timing:
(II) fglrx(0): clock: 138.5 MHz   Image Size:  345 x 194 mm
(II) fglrx(0): h_active: 1920  h_sync: 1968  h_sync_end 2000 h_blank_end 2080 h_border: 0
(II) fglrx(0): v_active: 1080  v_sync: 1083  v_sync_end 1088 v_blanking: 1111 v_border: 0
(II) fglrx(0):  H162K�156WF1
(II) fglrx(0): Unknown vendor-specific block 0
(II) fglrx(0): EDID (in hex):
(II) fglrx(0):    00ffffffffffff0030e40b0200000000
(II) fglrx(0):    00130103902313780a15d59e59509826
(II) fglrx(0):    0e505400000001010101010101010101
(II) fglrx(0):    0101010101011a3680a070381f403020
(II) fglrx(0):    350059c21000001b1a3680a070381f40
(II) fglrx(0):    3020350059c21000001b000000fe0048
(II) fglrx(0):    3136324b803135365746310a00000000
(II) fglrx(0):    00000000000000000002010a202000e6
(II) fglrx(0): End of Display0 EDID data --------------------
(II) fglrx(0): EDID for output LVDS
(II) fglrx(0): Manufacturer: LGD  Model: 20b  Serial#: 0
(II) fglrx(0): Year: 2009  Week: 0
(II) fglrx(0): EDID Version: 1.3
(II) fglrx(0): Digital Display Input
(II) fglrx(0): Max Image Size [cm]: horiz.: 35  vert.: 19
(II) fglrx(0): Gamma: 2.20
(II) fglrx(0): No DPMS capabilities specified
(II) fglrx(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
(II) fglrx(0): First detailed timing is preferred mode
(II) fglrx(0): redX: 0.617 redY: 0.349   greenX: 0.313 greenY: 0.595
(II) fglrx(0): blueX: 0.151 blueY: 0.056   whiteX: 0.313 whiteY: 0.329
(II) fglrx(0): Manufacturer's mask: 0
(II) fglrx(0): Supported detailed timing:
(II) fglrx(0): clock: 138.5 MHz   Image Size:  345 x 194 mm
(II) fglrx(0): h_active: 1920  h_sync: 1968  h_sync_end 2000 h_blank_end 2080 h_border: 0
(II) fglrx(0): v_active: 1080  v_sync: 1083  v_sync_end 1088 v_blanking: 1111 v_border: 0
(II) fglrx(0): Supported detailed timing:
(II) fglrx(0): clock: 138.5 MHz   Image Size:  345 x 194 mm
(II) fglrx(0): h_active: 1920  h_sync: 1968  h_sync_end 2000 h_blank_end 2080 h_border: 0
(II) fglrx(0): v_active: 1080  v_sync: 1083  v_sync_end 1088 v_blanking: 1111 v_border: 0
(II) fglrx(0):  H162K�156WF1
(II) fglrx(0): Unknown vendor-specific block 0
(II) fglrx(0): EDID (in hex):
(II) fglrx(0):    00000000000000003a20466972737420
(II) fglrx(0):    64657461696c65642074696d696e6720
(II) fglrx(0):    697320707265666572726564206d6f64
(II) fglrx(0):    650a000a00011a3680a070381f403020
(II) fglrx(0):    350059c21000001b4100000000000000
(II) fglrx(0):    00000000000000003a20556e6b6e6f77
(II) fglrx(0):    6e2076656e646f722d73706563696669
(II) fglrx(0):    6320626c6f636b202568780a002000e6
(II) fglrx(0): EDID vendor "LGD", prod id 523
(II) fglrx(0): Printing DDC gathered Modelines:
(II) fglrx(0): Modeline "1920x1080"x0.0  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.6 kHz)
(II) fglrx(0): Printing probed modes for output LVDS
(II) fglrx(0): Modeline "1920x1080"x60.0  138.50  1920 1968 2000 2080  1080 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "1680x1050"x60.0  138.50  1680 1968 2000 2080  1050 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "1400x1050"x60.0  138.50  1400 1968 2000 2080  1050 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "1280x1024"x60.0  138.50  1280 1968 2000 2080  1024 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "1440x900"x60.0  138.50  1440 1968 2000 2080  900 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "1280x960"x60.0  138.50  1280 1968 2000 2080  960 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "1280x800"x60.0  138.50  1280 1968 2000 2080  800 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "1152x864"x60.0  138.50  1152 1968 2000 2080  864 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "1280x768"x60.0  138.50  1280 1968 2000 2080  768 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "1280x720"x60.0  138.50  1280 1968 2000 2080  720 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "1024x768"x60.0  138.50  1024 1968 2000 2080  768 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "1024x600"x60.0  138.50  1024 1968 2000 2080  600 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "800x600"x60.0  138.50  800 1968 2000 2080  600 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "800x480"x60.0  138.50  800 1968 2000 2080  480 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "720x480"x60.0  138.50  720 1968 2000 2080  480 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): Modeline "640x480"x60.0  138.50  640 1968 2000 2080  480 1083 1088 1111 -hsync +vsync (66.6 kHz)
(II) fglrx(0): EDID for output DFP1
(II) fglrx(0): EDID for output CRT2
(II) fglrx(0): Output LVDS connected
(II) fglrx(0): Output DFP1 disconnected
(II) fglrx(0): Output CRT2 disconnected
(II) fglrx(0): Using exact sizes for initial modes
(II) fglrx(0): Output LVDS using initial mode 1920x1080
(II) fglrx(0): Display dimensions: (350, 190) mm
(II) fglrx(0): DPI set to (139, 144)
(II) fglrx(0): Adapter ATI Mobility Radeon HD 4500 Series has 2 configurable heads and 1 displays connected.
(==) fglrx(0):  PseudoColor visuals disabled
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(==) fglrx(0): NoDRI = NO
(==) fglrx(0): Capabilities: 0x00000000
(==) fglrx(0): CapabilitiesEx: 0x00000000
(==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
(==) fglrx(0): UseFastTLS=0
(==) fglrx(0): BlockSignalsOnLock=1
(--) Depth 24 pixmap format is 32 bpp
(II) Loading extension ATIFGLRXDRI
(II) fglrx(0): doing swlDriScreenInit
(II) fglrx(0): swlDriScreenInit for fglrx driver
ukiDynamicMajor: found major device number 251
ukiDynamicMajor: found major device number 251
ukiDynamicMajor: found major device number 251
ukiOpenByBusid: Searching for BusID PCI:2:0:0
ukiOpenDevice: node name is /dev/ati/card0
ukiOpenDevice: open result is 16, (OK)
ukiOpenByBusid: ukiOpenMinor returns 16
ukiOpenByBusid: ukiGetBusid reports PCI:2:0:0
(II) fglrx(0): [uki] DRM interface version 1.0
(II) fglrx(0): [uki] created "fglrx" driver at busid "PCI:2:0:0"
(II) fglrx(0): [uki] added 8192 byte SAREA at 0x2000
(II) fglrx(0): [uki] mapped SAREA 0x2000 to 0x7f650dd90000
(II) fglrx(0): [uki] framebuffer handle = 0x3000
(II) fglrx(0): [uki] added 1 reserved context for kernel
(II) fglrx(0): swlDriScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0):     Name: fglrx
(II) fglrx(0):     Version: 8.83.6
(II) fglrx(0):     Date: Mar  8 2011
(II) fglrx(0):     Desc: ATI FireGL DRM kernel module
(II) fglrx(0): Kernel Module version matches driver.
(II) fglrx(0): Kernel Module Build Time Information:
(II) fglrx(0):     Build-Kernel UTS_RELEASE:        2.6.32-5-amd64
(II) fglrx(0):     Build-Kernel MODVERSIONS:        yes
(II) fglrx(0):     Build-Kernel __SMP__:            yes
(II) fglrx(0):     Build-Kernel PAGE_SIZE:          0x1000
(II) fglrx(0): [uki] register handle = 0x00004000
(II) fglrx(0): DRI initialization successfull
(II) fglrx(0): FBADPhys: 0xf00000000 FBMappedSize: 0x0100e000
(==) fglrx(0): Backing store disabled
(II) Loading extension FGLRXEXTENSION
(**) fglrx(0): DPMS enabled
(II) fglrx(0): Initialized in-driver Xinerama extension
(**) fglrx(0): Textured Video is enabled.
(II) LoadModule: "glesx"
(II) Loading /usr/lib/xorg/modules/glesx.so
(II) Module glesx: vendor="X.Org Foundation"
   compiled for 1.4.99.906, module version = 1.0.0
(II) Loading extension GLESX
(II) fglrx(0): GLESX enableFlags = 528
(II) fglrx(0): GLESX is enabled
(II) LoadModule: "amdxmm"
(II) Loading /usr/lib/xorg/modules/amdxmm.so
(II) Module amdxmm: vendor="X.Org Foundation"
   compiled for 1.4.99.906, module version = 2.0.0
(II) Loading extension AMDXVOPL
(II) Loading extension AMDXVBA
(II) fglrx(0): UVD feature is enabled(II) fglrx(0):
(II) fglrx(0): Enable composite support successfully
(WW) fglrx(0): Option "VendorName" is not used
(WW) fglrx(0): Option "ModelName" is not used
(II) fglrx(0): X context handle = 0x1
(II) fglrx(0): [DRI] installation complete
(==) fglrx(0): Silken mouse enabled
(==) fglrx(0): Using HW cursor of display infrastructure!
(II) fglrx(0): Disabling in-server RandR and enabling in-driver RandR 1.2.
(II) fglrx(0): 'LVDS LCD' ConnectorType, abstracted as 'Panel'
(II) fglrx(0): 'eDP LCD' ConnectorType, abstracted as 'Panel'
(--) RandR disabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
SELinux: Disabled on system, not enabling in X server
ukiDynamicMajor: found major device number 251
ukiDynamicMajor: found major device number 251
ukiOpenByBusid: Searching for BusID PCI:2:0:0
ukiOpenDevice: node name is /dev/ati/card0
ukiOpenDevice: open result is 17, (OK)
ukiOpenByBusid: ukiOpenMinor returns 17
ukiOpenByBusid: ukiGetBusid reports PCI:2:0:0
(II) AIGLX: Loaded and initialized OpenGL driver(II) GLX: Initialized DRI GL provider for screen 0
(II) fglrx(0): Enable the clock gating!
(II) fglrx(0): Setting screen physical size to 508 x 285
(II) config/udev: Adding input device Power Button (/dev/input/event5)
(**) Power Button: Applying InputClass "evdev keyboard catchall"
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
   compiled for 1.7.6.901, module version = 2.3.2
   Module class: X.Org XInput Driver
   ABI class: X.Org XInput driver, version 7.0
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event5"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "inspiron"
(**) Option "xkb_layout" "de"
(II) config/udev: Adding input device Video Bus (/dev/input/event7)
(**) Video Bus: Applying InputClass "evdev keyboard catchall"
(**) Video Bus: always reports core events
(**) Video Bus: Device: "/dev/input/event7"
(II) Video Bus: Found keys
(II) Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "inspiron"
(**) Option "xkb_layout" "de"
(II) config/udev: Adding input device Power Button (/dev/input/event2)
(**) Power Button: Applying InputClass "evdev keyboard catchall"
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event2"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "inspiron"
(**) Option "xkb_layout" "de"
(II) config/udev: Adding input device Lid Switch (/dev/input/event4)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device Sleep Button (/dev/input/event3)
(**) Sleep Button: Applying InputClass "evdev keyboard catchall"
(**) Sleep Button: always reports core events
(**) Sleep Button: Device: "/dev/input/event3"
(II) Sleep Button: Found keys
(II) Sleep Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "inspiron"
(**) Option "xkb_layout" "de"
(II) config/udev: Adding input device Laptop_Integrated_Webcam_2M (/dev/input/event8)
(**) Laptop_Integrated_Webcam_2M: Applying InputClass "evdev keyboard catchall"
(**) Laptop_Integrated_Webcam_2M: always reports core events
(**) Laptop_Integrated_Webcam_2M: Device: "/dev/input/event8"
(II) Laptop_Integrated_Webcam_2M: Found keys
(II) Laptop_Integrated_Webcam_2M: Configuring as keyboard
(II) XINPUT: Adding extended input device "Laptop_Integrated_Webcam_2M" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "inspiron"
(**) Option "xkb_layout" "de"
(II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event10)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device HDA Intel Mic at Ext Left Jack (/dev/input/event11)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device HDA Intel HP Out at Ext Left Jack (/dev/input/event12)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device HDA Intel HP Out at Ext Left Jack (/dev/input/event13)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event1)
(**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event1"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "inspiron"
(**) Option "xkb_layout" "de"
(II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event9)
(**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
(**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
   compiled for 1.7.6.901, module version = 1.2.2
   Module class: X.Org XInput Driver
   ABI class: X.Org XInput driver, version 7.0
(II) Synaptics touchpad driver version 1.2.2
(**) Option "Device" "/dev/input/event9"
(II) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
(II) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
(II) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
(II) SynPS/2 Synaptics TouchPad: finger width range 0 - 0
(II) SynPS/2 Synaptics TouchPad: buttons: left right middle
(--) SynPS/2 Synaptics TouchPad: touchpad found
(**) SynPS/2 Synaptics TouchPad: always reports core events
(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
(**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
(**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 0
(**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
(**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
(--) SynPS/2 Synaptics TouchPad: touchpad found
(II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse1)
(**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
(II) Synaptics touchpad driver version 1.2.2
SynPS/2 Synaptics TouchPad no synaptics event device found
(**) Option "Device" "/dev/input/mouse1"
Query no Synaptics: 6003C8
(--) SynPS/2 Synaptics TouchPad: no supported touchpad found
(EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "SynPS/2 Synaptics TouchPad"
(II) UnloadModule: "synaptics"
(II) config/udev: Adding input device PC Speaker (/dev/input/event6)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device Macintosh mouse button emulation (/dev/input/event0)
(**) Macintosh mouse button emulation: Applying InputClass "evdev pointer catchall"
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event0"
(II) Macintosh mouse button emulation: Found 3 mouse buttons
(II) Macintosh mouse button emulation: Found relative axes
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(II) Macintosh mouse button emulation: initialized for relative axes.
(II) config/udev: Adding input device Macintosh mouse button emulation (/dev/input/mouse0)
(II) No input driver/identifier specified (ignoring)
(II) fglrx(0): Restoring Recent Mode via PCS is not supported in RANDR 1.2 capable environments
(II) fglrx(0): EDID vendor "LGD", prod id 523
(II) fglrx(0): Printing DDC gathered Modelines:
(II) fglrx(0): Modeline "1920x1080"x0.0  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.6 kHz)
(II) fglrx(0): EDID vendor "LGD", prod id 523
(II) fglrx(0): Printing DDC gathered Modelines:
(II) fglrx(0): Modeline "1920x1080"x0.0  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.6 kHz)
(II) fglrx(0): EDID vendor "LGD", prod id 523
(II) fglrx(0): Printing DDC gathered Modelines:
(II) fglrx(0): Modeline "1920x1080"x0.0  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.6 kHz)
AlexanderPCT
Level 1
Level 1
 
Posts: 2
Joined: Tue Apr 05, 2011 9:34 am

Linux Mint is funded by ads and donations.
 

Re: No 3d after ati driver installation

Postby mads on Tue Apr 05, 2011 10:00 am

Have you tried to run 'ATI Catalyst Control Center (Administrative)'?
Code: Select all
gksu amdcccle
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: No 3d after ati driver installation

Postby xircon on Tue Apr 05, 2011 3:40 pm

Also check /etc/X11/xorg.conf

Should have a section like:
Code: Select all
Section "Extensions"
   Option      "Composite"   "enable"
#   Option      "RENDER"   "disable"
EndSection


Composite on mine said disabled, changing to enable worked for me.
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: No 3d after ati driver installation

Postby AlexanderPCT on Tue Apr 05, 2011 6:23 pm

ATI Catalyst Control Center runs as it sould ;)


after i've added

Code: Select all
Section "Extensions"
   Option      "Composite"   "enable"
#   Option      "RENDER"   "disable"
EndSection


the xserver crashed till i removed it ^^
AlexanderPCT
Level 1
Level 1
 
Posts: 2
Joined: Tue Apr 05, 2011 9:34 am

Re: No 3d after ati driver installation

Postby mads on Tue Apr 05, 2011 6:35 pm

AlexanderPCT wrote:ATI Catalyst Control Center runs as it sould ;)


I didn't ask if it runs as it should, but good luck anyway. :D
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: No 3d after ati driver installation

Postby Jaime Frontero on Wed Apr 06, 2011 11:28 pm

no guarantees, but it looks like the fglrx stuff that was installed with your system (and the generic radeon drivers) is horked by the new ATI Catalyst CC.

try this:

sudo apt-get remove --purge fglrx*

sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon

sudo apt-get install --reinstall libgl1-mesa-dri xserver-xorg-core (just in case)

sudo dpkg-reconfigure xserver-xorg (this will delete your xorg.conf - you might want to back it up first...)

download the latest 11.3 CCC (you've got a HD4500, right?) here:

http://support.amd.com/us/gpudownload/l ... linux.aspx

stick the file somewhere and make it executable. then execute it. take the defaults - no need to build a kernel.

after it's installed create a new xorg.conf, thusly:

sudo aticonfig --initial --adapter=all

if that doesn't create it you may need to reboot first and then issue that command.

reboot after the new xorg.conf is created, in either case.

oughtta work. but no guarantees, like i said... :lol:
Jaime Frontero
Level 1
Level 1
 
Posts: 23
Joined: Sat Feb 19, 2011 4:44 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 7 guests