Mount my camera

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

Important information

Mount my camera

Postby LAN on Sun May 22, 2011 12:48 pm

Hi

When I plug in the camera with USB the camera doesnt mount. It did in the past where a dialog came up and asked what I wanted to do. Can anyone help?
LAN
Level 1
Level 1
 
Posts: 17
Joined: Tue Jan 25, 2011 1:51 pm

Linux Mint is funded by ads and donations.
 

Re: Mount my camera

Postby btqy on Tue May 24, 2011 4:26 pm

Hi,
I had the same problem with my USB Archos 43 Vision.
The problem is the new Debian testing Linux kernel : 2.6.38
I tried with the Liquorix kernel (a 2.6.38 !) and it didn't work too.

I found two solutions (merci Google !) :
1- upgrade to kernel 2.6.39, it means using part of Sid packages instead Testing
2 - to fix the problem directly in the kernel 2.6.38 sources with usb-storage and recompile it...

I choosed the second solution.
Following http://marc.info/?l=linux-scsi&m=130089710431684&w=2 , I have to patch the file /drivers/scsi/sd.c in Linux kernel sources

Now it works perfectly, it was a long time ago I haven't to recompile a linux kernel !

Hope I help you
Bruno
btqy
Level 1
Level 1
 
Posts: 2
Joined: Tue May 24, 2011 4:04 pm

Re: Mount my camera

Postby btqy on Thu May 26, 2011 2:08 pm

Hi,
Today I've just installed the new Liquorix kernel (2.6.38-7.dmz.1-liquorix-686) and I found that the usb-storage regression is fixed !

http://liquorix.net/

Bruno
btqy
Level 1
Level 1
 
Posts: 2
Joined: Tue May 24, 2011 4:04 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 1 guest