HDMI on Radeon HD6300

Questions about hardware and drivers
Forum rules
Before you post please read this

HDMI on Radeon HD6300

Postby ich.farbstift on Tue Jul 05, 2011 8:31 am

Hi,
I am relatively new to LMDE, I have been using it only for 2 months now, but I am extremely pleased with it, although there are still some features that I am not able to make to work.

One of these is my HDMI connector on my HP laptop.
To put it simple, LMDE does not recognize the connector, so I am not able to get any video from it.
I have tried with the Gnome monitor tool, and xrandr, but with no success.
This is the output I get when running xrandr from a terminal

Code: Select all
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 293mm x 164mm
   1366x768       60.0*+
   1360x768       59.8     60.0 
   1024x768       60.0 
   800x600        60.3     56.2 
   640x480        59.9 
VGA1 disconnected (normal left inverted right x axis y axis)


I believe it is a problem with the oss ati drivers for my video card, that is a Radeon HD 6300, maybe it is still too new to have a feature like HDMI support.

Still, in case I have missed something, or maybe someone has my same problem, I am posting here hoping to get a solution.

Thank you anyway for your help,
S.
User avatar
ich.farbstift
Level 1
Level 1
 
Posts: 2
Joined: Thu Jun 02, 2011 11:04 am

Linux Mint is funded by ads and donations.
 

Re: HDMI on Radeon HD6300

Postby xenopeek on Wed Jul 06, 2011 11:39 am

Have you tried with the proprietary "Catalyst" driver from AMD? http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14995
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: HDMI on Radeon HD6300

Postby AlbertP on Wed Jul 06, 2011 11:40 am

Please use the 'Additional Drivers' program to install the ATI/AMD Catalyst driver for your card.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6519
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: HDMI on Radeon HD6300

Postby ich.farbstift on Fri Jul 08, 2011 4:55 pm

Hi,
sorry for my late response, I have spent some time trying to figure out a solution to this problem, without much success.

Indeed, it seems that I am not able at all to load the drivers for my radeon HD6300 card, neither free nor non-free.
My system is working because I am using the integrated intel card. I would really like to use my ATI one, although.

Here's the output from lspci and lspci -vvnn, if someone could help me I would appreciate it very much
lspci:
Code: Select all
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
01:00.0 VGA compatible controller: ATI Technologies Inc Robson CE [AMD Radeon HD 6300 Series]
01:00.1 Audio device: ATI Technologies Inc Manhattan HDMI Audio [Mobility Radeon HD 5000 Series]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
03:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 05)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 05)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 05)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 05)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 05)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 05)


lspci -vvnn:
Code: Select all
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:162c]
   Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
   Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 0
   Interrupt: pin A routed to IRQ 43
   Region 0: Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
   Region 2: Memory at b0000000 (64-bit, prefetchable) [size=256M]
   Region 4: I/O ports at 4050 [size=8]
   Expansion ROM at <unassigned> [disabled]
   Capabilities: <access denied>
   Kernel driver in use: i915

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Robson CE [AMD Radeon HD 6300 Series] [1002:68e4] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:162c]
   Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Interrupt: pin A routed to IRQ 16
   Region 0: Memory at a0000000 (64-bit, prefetchable) [size=256M]
   Region 2: Memory at c4400000 (64-bit, non-prefetchable) [size=128K]
   Region 4: I/O ports at 3000 [size=256]
   Expansion ROM at c4440000 [size=128K]
   Capabilities: <access denied>


I honestly don't know how to solve this problem, it's driving me crazy!
Thank you in advance for your help, I extremely appreaciate it.

@AlbertP: I cannot use the 'additional driver' tool because I am on LMDE, that is a program available only on the Ubuntu based Mint
User avatar
ich.farbstift
Level 1
Level 1
 
Posts: 2
Joined: Thu Jun 02, 2011 11:04 am

Re: HDMI on Radeon HD6300

Postby AlbertP on Sat Jul 09, 2011 4:07 am

This is a hybrid graphics system. The Intel card is active by default - and the HDMI is not connected to the Intel card.

If you want the ATI card to become active, you need to connect a screen to it at boot time, for example your HDMI one. There's also some boot argument that switches the laptop screen to the ATI card so that you can get rid of all hybrid issues.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6519
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 2 guests