How to turn off pcspeaker?

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

How to turn off pcspeaker?

Postby trenthawkins on Wed Jul 27, 2011 3:33 am

As per: viewtopic.php?f=141&t=76010

i have done:

Code: Select all
echo "blacklist pcspkr" | sudo tee -a  /etc/modprobe.d/blacklist.conf
sudo rmmod pcspkr


But everytime i use Evince and press backspace in the "find" tool i get this massively load beep, which is excruciating when i am listening to music on my head phones. What's going on here?

My specs - HP dv6
Processor : 8x Intel(R) Core(TM) i7 CPU Q 720 @ 1.60GHz
Memory : 6064MB (1218MB used)
Operating System : Linux Mint Debian Edition
User Name : trenty (Trent Hawkins)
Date/Time : Wed 27 Jul 2011 17:30:11 EST
-Display-
Resolution : 1366x768 pixels
OpenGL Renderer : AMD Radeon HD 6500M/5600/5700 Series
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : HDA-Intel - HDA Intel
Audio Adapter : HDA-Intel - HD-Audio Generic
-Input Devices-
AT Translated Set 2 keyboard
Logitech Trackball
Microsoft Natural® Ergonomic Keyboard 4000
Microsoft Natural® Ergonomic Keyboard 4000
Power Button
Lid Switch
Power Button
Video Bus
ST LIS3LV02DL Accelerometer
HP WMI hotkeys
HP Webcam
SynPS/2 Synaptics TouchPad
HDA Digital PCBeep
HDA Intel Mic at Ext Front Jack
HDA Intel HP Out at Ext Front Jack
-Printers (CUPS)-
HP-LaserJet-3015 : <i>Default</i>
Print_to_PDF

Im guessing the culprit is: HDA Digital PCBeep

Hardinfo says:
Name:
HDA Digital PCBeep
Type
Keyboard
Bus
0x1
Vendor
111d
Product
0x7605
Version
0x1
Connected to
card0/codec#0/beep0

How do it blacklist this?
trenthawkins
Level 1
Level 1
 
Posts: 6
Joined: Tue Jul 19, 2011 12:58 am

Linux Mint is funded by ads and donations.
 

Re: How to turn off pcspeaker?

Postby cecar on Wed Jul 27, 2011 3:47 am

cecar
Level 4
Level 4
 
Posts: 365
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden

Re: How to turn off pcspeaker?

Postby secipolla on Wed Jul 27, 2011 7:53 am

I'm using Debian with GNOME 3. But if you install the proper sound packages for GNOME (I think they involve canberra and in my case I also installed freedesktop-sound-themes - or something like that) the pcspeaker beep will be replaced by the default alert sound in GNOME (the one you can choose in the sound preferences dialog).
secipolla
Level 4
Level 4
 
Posts: 356
Joined: Sun Sep 05, 2010 5:19 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 1 guest