nvidia 173xx drivers can't be found!

Questions about hardware and drivers
Forum rules
Before you post please read this

nvidia 173xx drivers can't be found!

Postby Dervman2 on Sun Aug 21, 2011 2:16 pm

Hi all,

I have a Nvidia Quadro NVS 280 graphics card installed in my PC which I've recently installled LMDE (RC) on.

In order to get compiz working I want to install the Nvidia 173 legacy driver.

I'm following a guide in this thread http://forums.linuxmint.com/viewtopic.php?f=141&t=62953

But no matter why I try apt-get or synaptic package manager cannot find any of the Nvidia legacy packages.

So far I've installed these
nvidia-kernel-common
nvidia-vdpau-driver
nvidia-settings
nvidia-xconfig

But these fail
nvidia-kernel-legacy-173xx-source
nvidia-kernel-legacy-173xx-dkms
nvidia-glx-legacy-173xx

Code: Select all
sg steve # apt-get install nvidia-kernel-legacy-173xx-source nvidia-kernel-legacy-173xx-dkms nvidia-glx-legacy-173xx
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package nvidia-glx-legacy-173xx is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package nvidia-kernel-legacy-173xx-source
E: Unable to locate package nvidia-kernel-legacy-173xx-dkms
E: Package 'nvidia-glx-legacy-173xx' has no installation candidate
sg steve #


Code: Select all
sg steve # more /etc/apt/sources.list
deb http://packages.linuxmint.com/ debian main upstream import backport
deb-src http://packages.linuxmint.com/ debian main upstream import backport #Added by software-properties
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free


It must be something so simple but I can't figure it out :-(

Thanks
Dervman2
Level 1
Level 1
 
Posts: 6
Joined: Sat Aug 13, 2011 5:53 pm

Linux Mint is funded by ads and donations.
 

Re: nvidia 173xx drivers can't be found!

Postby mads on Sun Aug 21, 2011 2:53 pm

Hi!

Download the package here. Go to the bottom of the page and select your architecture (amd64 for 64-bit, i386 for 32-bit).
Right click the folder where you have downloaded the package in > Open in Terminal. Now run one of these commands:

If you have 64-bit:
Code: Select all
sudo dpkg -i nvidia-glx-legacy-173xx_173.14.30-3_amd64.deb

If you have 32-bit:
Code: Select all
sudo dpkg -i nvidia-glx-legacy-173xx_173.14.30-3_i386.deb

Now, try to continue what you were doing before and see if it works.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: nvidia 173xx drivers can't be found!

Postby Dervman2 on Sun Aug 21, 2011 5:28 pm

Thanks for the help mads but I seem to be getter in more and more dependancy hell!

As suggested I manually downloaded the (32bit) dpkg

But that depends on a series of other legacy nvidia packages.

I downloaded the missing packages manually but they depend on a range of others.

Code: Select all
sg graphics-driver # sudo dpkg -i nvidia-glx-legacy-173xx_173.14.30-3_i386.deb
(Reading database ... 138490 files and directories currently installed.)
Preparing to replace nvidia-glx-legacy-173xx 173.14.30-3 (using nvidia-glx-legacy-173xx_173.14.30-3_i386.deb) ...
Unpacking replacement nvidia-glx-legacy-173xx ...
dpkg: dependency problems prevent configuration of nvidia-glx-legacy-173xx:
 nvidia-glx-legacy-173xx depends on libgl1-nvidia-legacy-173xx-glx (= 173.14.30-3); however:
  Package libgl1-nvidia-legacy-173xx-glx is not installed.
 nvidia-glx-legacy-173xx depends on xserver-xorg-video-nvidia-legacy-173xx (= 173.14.30-3); however:
  Package xserver-xorg-video-nvidia-legacy-173xx is not installed.
 nvidia-glx-legacy-173xx depends on nvidia-alternative-legacy-173xx (= 173.14.30-3); however:
  Package nvidia-alternative-legacy-173xx is not installed.
 nvidia-glx-legacy-173xx depends on nvidia-kernel-173.14.30; however:
  Package nvidia-kernel-173.14.30 is not installed.
dpkg: error processing nvidia-glx-legacy-173xx (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 nvidia-glx-legacy-173xx


I also added the local mirror to my sources.lst hoping the dependencies would be automatically resolved but not such luck

Code: Select all
deb http://ftp.uk.debian.org/debian squeeze main non-free


I don't understand why these aren't being found in the repo's. I've never had problems like this in Linux Mint (Ubuntu).

Any other suggestions?
Dervman2
Level 1
Level 1
 
Posts: 6
Joined: Sat Aug 13, 2011 5:53 pm

Re: nvidia 173xx drivers can't be found!

Postby mads on Sun Aug 21, 2011 5:51 pm

The link I sent in my previous post shows all the packages you need. I did the job, so go ahead and download them all. :)

Other Packages Related to nvidia-glx-legacy-173xx

depends: dpkg (>= 1.15.7.2)
Debian package management system

depends: nvidia-installer-cleanup
Cleanup after driver installation with the nvidia-installer

depends: libgl1-nvidia-legacy-173xx-glx (= 173.14.30-3)
NVIDIA binary OpenGL libraries (173xx legacy version)

depends: nvidia-alternative-legacy-173xx (= 173.14.30-3)
allows the selection of NVIDIA as GLX provider

depends: nvidia-kernel-173.14.30
virtual package provided by nvidia-kernel-legacy-173xx-dkms

depends: nvidia-support
NVIDIA binary graphics driver support files

depends: xserver-xorg-video-nvidia-legacy-173xx (= 173.14.30-3)
NVIDIA binary Xorg driver (173xx legacy version)

suggests: nvidia-kernel-legacy-173xx-dkms (>= 173.14.30)
NVIDIA binary kernel module DKMS source (173xx legacy version)
or
nvidia-kernel-legacy-173xx-source (>= 173.14.30)
NVIDIA binary kernel module source (173xx legacy version)

suggests: nvidia-settings
Tool for configuring the NVIDIA graphics driver
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: nvidia 173xx drivers can't be found!

Postby Dervman2 on Sun Aug 21, 2011 6:01 pm

Downloaded all the other missing packages then tried again.

Now getting conflicting package version errors.

Code: Select all
sg graphics-driver # dpkg -i *.deb
(Reading database ... 138539 files and directories currently installed.)
Preparing to replace libgl1-nvidia-legacy-173xx-glx 173.14.30-3 (using libgl1-nvidia-legacy-173xx-glx_173.14.30-3_i386.deb) ...
Unpacking replacement libgl1-nvidia-legacy-173xx-glx ...
Preparing to replace nvidia-alternative-legacy-173xx 173.14.30-3 (using nvidia-alternative-legacy-173xx_173.14.30-3_i386.deb) ...
Unpacking replacement nvidia-alternative-legacy-173xx ...
Preparing to replace nvidia-glx-legacy-173xx 173.14.30-3 (using nvidia-glx-legacy-173xx_173.14.30-3_i386.deb) ...
Unpacking replacement nvidia-glx-legacy-173xx ...
dpkg: regarding nvidia-kernel-legacy-173xx-dkms_173.14.30-3_i386.deb containing nvidia-kernel-legacy-173xx-dkms:
 nvidia-kernel-legacy-173xx-dkms conflicts with nvidia-kernel-dkms
  nvidia-kernel-dkms (version 275.09.07-5) is present and installed.
  nvidia-kernel-dkms provides nvidia-kernel-dkms and is present and installed.
dpkg: error processing nvidia-kernel-legacy-173xx-dkms_173.14.30-3_i386.deb (--install):
 conflicting packages - not installing nvidia-kernel-legacy-173xx-dkms
Preparing to replace nvidia-kernel-legacy-173xx-source 173.14.30-3 (using nvidia-kernel-legacy-173xx-source_173.14.30-3_i386.deb) ...
Unpacking replacement nvidia-kernel-legacy-173xx-source ...
Preparing to replace xserver-xorg-video-nvidia-legacy-173xx 173.14.30-3 (using xserver-xorg-video-nvidia-legacy-173xx_173.14.30-3_i386.deb) ...
Unpacking replacement xserver-xorg-video-nvidia-legacy-173xx ...
dpkg: dependency problems prevent configuration of nvidia-alternative-legacy-173xx:
 nvidia-alternative-legacy-173xx depends on glx-alternative-nvidia (>= 0.1.90); however:
  Version of glx-alternative-nvidia on system is 0.1.4.
dpkg: error processing nvidia-alternative-legacy-173xx (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-glx-legacy-173xx:
 nvidia-glx-legacy-173xx depends on nvidia-alternative-legacy-173xx (= 173.14.30-3); however:
  Package nvidia-alternative-legacy-173xx is not configured yet.
 nvidia-glx-legacy-173xx depends on nvidia-kernel-173.14.30; however:
  Package nvidia-kernel-173.14.30 is not installed.
dpkg: error processing nvidia-glx-legacy-173xx (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-kernel-legacy-173xx-source:
 nvidia-kernel-legacy-173xx-source depends on debhelper (>= 8); however:
  Package debhelper is not installed.
 nvidia-kernel-legacy-173xx-source depends on quilt (>= 0.46-7~); however:
  Package quilt is not installed.
dpkg: error processing nvidia-kernel-legacy-173xx-source (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-video-nvidia-legacy-173xx:
 xserver-xorg-video-nvidia-legacy-173xx depends on nvidia-alternative-legacy-173xx (= 173.14.30-3); however:
  Package nvidia-alternative-legacy-173xx is not configured yet.
dpkg: error processing xserver-xorg-video-nvidia-legacy-173xx (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgl1-nvidia-legacy-173xx-glx:
 libgl1-nvidia-legacy-173xx-glx depends on nvidia-alternative-legacy-173xx; however:
  Package nvidia-alternative-legacy-173xx is not configured yet.
dpkg: error processing libgl1-nvidia-legacy-173xx-glx (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 nvidia-kernel-legacy-173xx-dkms_173.14.30-3_i386.deb
 nvidia-alternative-legacy-173xx
 nvidia-glx-legacy-173xx
 nvidia-kernel-legacy-173xx-source
 xserver-xorg-video-nvidia-legacy-173xx
 libgl1-nvidia-legacy-173xx-glx
sg graphics-driver #
Dervman2
Level 1
Level 1
 
Posts: 6
Joined: Sat Aug 13, 2011 5:53 pm

Re: nvidia 173xx drivers can't be found!

Postby mads on Sun Aug 21, 2011 6:24 pm

Ok, we are getting close.
Package debhelper is not installed.
Package quilt is not installed.
1) Install these two packages:
Code: Select all
sudo apt-get install debhelper quilt


nvidia-alternative-legacy-173xx depends on glx-alternative-nvidia (>= 0.1.90); however: Version of glx-alternative-nvidia on system is 0.1.4.
2) Download this package: glx-alternative-nvidia (0.1.91)

3) Run 'dpkg -i *.deb' once more

@ Edit:

Suggests: nvidia-kernel-legacy-173xx-dkms (>= 173.14.30)
NVIDIA binary kernel module DKMS source (173xx legacy version)
or
nvidia-kernel-legacy-173xx-source (>= 173.14.30)
NVIDIA binary kernel module source (173xx legacy version)

Don't install the first one. The second one is enough.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: nvidia 173xx drivers can't be found!

Postby standards on Sun Aug 21, 2011 6:55 pm

mads had the right idea in the first reply but you have to add the 'contrib' to that weezy repo

add this: http://ftp.de.debian.org/debian wheezy main non-free contrib

then

sudo apt-get install nvidia-kernel-legacy-173xx-dkms nvidia-glx-legacy-173xx build-essential nvidia-settings nvidia-xconfig

then

sudo nvidia-xconfig

i can't tell you how many hours i have spent over the last year or so dealing with problems relating to the nivida legacy drivers. i wish at least one dev had an old card so they'd start catching these things sooner!
standards
Level 1
Level 1
 
Posts: 4
Joined: Sun Aug 21, 2011 4:33 pm

Re: nvidia 173xx drivers can't be found!

Postby Dervman2 on Tue Aug 23, 2011 6:24 am

I re-installed as the system was in a pickle with all the fiddling!

Added the wheezy line to sources.list and included the wheezy line.

This enabled me to install all the relevant legacy 173 drivers :-)

However I'm still getting the flashing cursor in the top left and my Xorg.log tells me I'm running the 280 driver.

Any thoughts.

Code: Select all
[    20.557] (II) NVIDIA dlloader X Driver  280.13  Wed Jul 27 16:57:12 PDT 2011
[    20.577] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    20.578] (++) using VT number 7

[    20.588] (II) Loading sub module "fb"
[    20.588] (II) LoadModule: "fb"
[    20.588] (II) Loading /usr/lib/xorg/modules/libfb.so
[    20.631] (II) Module fb: vendor="X.Org Foundation"
[    20.631]    compiled for 1.10.2.902, module version = 1.0.0
[    20.631]    ABI class: X.Org ANSI C Emulation, version 0.4
[    20.631] (II) Loading sub module "wfb"
[    20.631] (II) LoadModule: "wfb"
[    20.632] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    20.639] (II) Module wfb: vendor="X.Org Foundation"
[    20.639]    compiled for 1.10.2.902, module version = 1.0.0
[    20.639]    ABI class: X.Org ANSI C Emulation, version 0.4
[    20.639] (II) Loading sub module "ramdac"
[    20.639] (II) LoadModule: "ramdac"
[    20.639] (II) Module "ramdac" already built-in
[    20.672] (WW) NVIDIA(0): The NVIDIA Quadro NVS 55/280 PCI GPU installed in this system
[    20.672] (WW) NVIDIA(0):     is supported through the NVIDIA 173.14.xx Legacy drivers.
[    20.672] (WW) NVIDIA(0):     Please visit http://www.nvidia.com/object/unix.html for
[    20.672] (WW) NVIDIA(0):     more information.  The 280.13 NVIDIA driver will ignore
[    20.672] (WW) NVIDIA(0):     this GPU.  Continuing probe...
[    20.672] (EE) No devices detected.
[    20.672]
Fatal server error:
[    20.672] no screens found
[    20.672]
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[    20.672] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    20.672]
Dervman2
Level 1
Level 1
 
Posts: 6
Joined: Sat Aug 13, 2011 5:53 pm

Re: nvidia 173xx drivers can't be found!

Postby mads on Tue Aug 23, 2011 6:29 am

standards wrote:...then
sudo nvidia-xconfig

Did you do this? And a reboot.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: nvidia 173xx drivers can't be found!

Postby Dervman2 on Tue Aug 23, 2011 6:36 am

Yes ran nvidia-xconfig which created the /etc/X11/xorg.conf

Then rebooted.
Dervman2
Level 1
Level 1
 
Posts: 6
Joined: Sat Aug 13, 2011 5:53 pm

Re: nvidia 173xx drivers can't be found!

Postby mads on Tue Aug 23, 2011 1:00 pm

Isn't Xorg.log just saying that it is made by "nvidia-xconfig" version 280?
dpkg --list | grep nvidia-xconfig
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: nvidia 173xx drivers can't be found!

Postby Dervman2 on Tue Aug 23, 2011 2:24 pm

I thought it was saying 'The 280 driver is installed but your card requires the 173 driver'

Hence the
Code: Select all
[    20.364] (EE) No devices detected.
[    20.364]
Fatal server error:
[    20.364] no screens found
[    20.364]


Anyhow here's the nvidia-xconfig package information.
Code: Select all
sg steve # dpkg --list | grep nvidia-xconfig
ii  nvidia-xconfig                                280.13-1                          X configuration tool for non-free NVIDIA drivers
sg steve # aptitude search nvidia-xconfig
i   nvidia-xconfig                                                         - X configuration tool for non-free NVIDIA drivers                                 
Dervman2
Level 1
Level 1
 
Posts: 6
Joined: Sat Aug 13, 2011 5:53 pm

Re: nvidia 173xx drivers can't be found!

Postby grimmer on Mon May 07, 2012 8:09 am

standards wrote:mads had the right idea in the first reply but you have to add the 'contrib' to that weezy repo

add this: http://ftp.de.debian.org/debian wheezy main non-free contrib

then

sudo apt-get install nvidia-kernel-legacy-173xx-dkms nvidia-glx-legacy-173xx build-essential nvidia-settings nvidia-xconfig

then

sudo nvidia-xconfig

i can't tell you how many hours i have spent over the last year or so dealing with problems relating to the nivida legacy drivers. i wish at least one dev had an old card so they'd start catching these things sooner!


Is it necessary to do a:
Code: Select all
sudo apt-get remove xserver-xorg-video-nouveau


Before running:
Code: Select all
sudo nvidia-xconfig


I'm wondering because I installed LMDE 201204 yesterday on a machine. But the graphics performance (the card is a GeForce FX5200) is painfully slow with the nouveau driver.
Right now I can only ssh to that computer for the time being, that's why I'm asking instead of testing it myself.
User avatar
grimmer
Level 1
Level 1
 
Posts: 3
Joined: Mon May 07, 2012 7:36 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 5 guests