Sound is good ... except last.fm in firefox!? How to fix?

Questions about hardware and drivers
Forum rules
Before you post please read this

Sound is good ... except last.fm in firefox!? How to fix?

Postby TomRoche on Sun Aug 21, 2011 7:49 pm

Sound is good ... except last.fm in firefox!? How to fix?

Mostly, the sound from my new LMDE box is good. Audio from DVD playback was excellent, OOTB, as was audio in YouTube video, and Pandora. Only one thing seems bad audio-wise: last.fm, and only on firefox! last.fm sounds fine on chromium, but on firefox there is a loud overlay of a few high-pitched beeps per second. Any suggestions on how to fix that? FWIW

  1. last.fm on firefox wasn't problematic on ubuntu natty on this box.
  2. I'd prefer to play last.fm on firefox rather than chromium, because on my LMDE currently, firefox is much more performant. (Which is the opposite of my ubuntu experience, but that's a subject for another post.)

Some hopefully-relevant data:

Code: Select all
me@it:~$ cat /etc/asound.conf
pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}
me@it:~$ cat /etc/apt/sources.list
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free
me@it:~$ inxi -Ax
Audio:     Card: Intel 82801I (ICH9 Family) HD Audio Controller driver: HDA Intel bus-ID: 00:1b.0 Sound: ALSA ver: 1.0.24
me@it:~$ flashplayer --version
Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64
10,1,102,64
me@it:~$ firefox --version
Mozilla Firefox 5.0
me@it:~$ chromium-browser --version
Chromium 12.0.742.112 Built on Debian unstable, running on Debian wheezy/sid


Also, FWIW, I get the following on startup of both chromium and firefox:

Code: Select all
sh: /usr/lib/nspluginwrapper/i386/linux/npviewer: not found
sh: /usr/lib/nspluginwrapper/i386/linux/npviewer: not found
TomRoche
Level 3
Level 3
 
Posts: 176
Joined: Thu Jan 13, 2011 2:52 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 1 guest