No Audio over Nvidia Geforce 210 HDMI

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

No Audio over Nvidia Geforce 210 HDMI

Postby Etch on Fri Sep 09, 2011 1:55 am

I cant seem to figure out how to get sound over HDMI on my NVIDIA Geforce 210. As a starting point, it works in windows 7, so I'm pretty sure ts not the card. I tried to install the NVIDIA proprietary drivers, but the install script kept failing. I read a bunch of posts, mostly ubuntu based, played around, and did more damage than good. I eventually just did a fresh install and update, and am going to try again. Since I consider myself a beginner, working on intermediate, linux user, some of the command line output is a bit foreign. I'm pretty sure the sound is recognized, but not configured properly. If someone could point me in the right direction to start, I think the feedback could become more constructive.

Thanks.
Etch
Level 1
Level 1
 
Posts: 4
Joined: Tue Sep 06, 2011 10:35 pm

Linux Mint is funded by ads and donations.
 

Re: No Audio over Nvidia Geforce 210 HDMI

Postby intelpiet on Thu Sep 15, 2011 4:32 pm

this worked for me on an Asrock 3D-ion.

first, in terminal, type alsamixer and unmute everything
or, if you don't want to use teminal, install gnome alsa mixer through synaptic

Then, edit the file /etc/asound.conf In my case, I had to create the file.
Code: Select all
sudo gedit /etc/asound.conf


and enter the following
Code: Select all
pcm.dmixer {
  type dmix
  ipc_key 2048
  slave {
    pcm "hw:1,7" # Always use pure hw. dmix will reformat/resample audio.
    period_size 512 # If you get stuttering/or non-working audio, fiddle around with these
    buffer_size 4096
    rate 48000 # HDMI, I'll assume 48kHz
    format S16_LE # Should be default for pretty much any soundcard.
  }
  bindings {
    0 0
    1 1
  }
}

pcm.!default {
  type plug
  slave.pcm dmixer
}


and reboot
intelpiet
Level 1
Level 1
 
Posts: 1
Joined: Thu Sep 15, 2011 4:10 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 2 guests