New spin and fglrx

Questions about hardware and drivers
Forum rules
Before you post please read this

New spin and fglrx

Postby Roken on Sat Sep 17, 2011 8:16 am

OK, following my recent problems with not being able to update since any attempts to update break fglrx, and whilst I accept that this may be something peculiar to my system, I'm thinking of reinstalling using the latest spin of LMDE (gnome edition). I'll keep my /home partition so that I can maintain my current customisations, and just install the additional packages (and my own kernel) that I need again after reinstallation.

Since this is still likely to involve a fair chunk of work on my part, can anyone first confirm for me that propriety fglrx works with full H/W acceleration on the latest respin, fully updated, before I go ahead?
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Linux Mint is funded by ads and donations.
 

Re: New spin and fglrx

Postby tdockery97 on Sat Sep 17, 2011 9:13 am

I can only confirm that it does not work for me. But then it never has on LMDE. Fortunately the new Gallium open-source driver gives me the acceleration/effects that the proprietary driver would have.
Image

HP Pavilion 17 Notebook, 8GB DDR3, 2.5GHZ A10-APU, Radeon HD 8650G
User avatar
tdockery97
Level 13
Level 13
 
Posts: 4886
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon

Re: New spin and fglrx

Postby Carl on Sat Sep 17, 2011 9:20 am

tdockery97 wrote:I can only confirm that it does not work for me. But then it never has on LMDE. Fortunately the new Gallium open-source driver gives me the acceleration/effects that the proprietary driver would have.


so it's not just me then? :evil:
[AMD Sempron 145 2.8GHz + Unlocked 2nd Core|ATI Radeon™ HD3000 Graphics|4GB DDR3|Biostar A780L3L]
Image
User avatar
Carl
Level 5
Level 5
 
Posts: 667
Joined: Wed Apr 15, 2009 5:20 pm
Location: West Sussex, UK

Re: New spin and fglrx

Postby Roken on Sat Sep 17, 2011 9:33 am

Whilst the Gallium driver provides for OpenGL, the speed is poor, and for some of the things I do I need full acceleration. Guess I'll just keep my system locked down for now, or maybe try a raw Debian install.
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: New spin and fglrx

Postby Beardedragon on Sat Sep 17, 2011 10:17 am

Well, I can confirm it does not work in LMDE Xfce. I had installed it yesterday and saw your post so I tried to install fglrx. I had the Galium Driver and now it shows "Unknown" And acceleration is still "None" Well, goodbye to LMDE and I'm going to stick with SalineOS which does support it and not only does it accelerate, it gives me 3D.
Robert Collard, Madison, WI
HP s5710f, 2x AMD Athlon II 260@3.2Ghz, 3GB RAM, 640GB HD
Debian 7.1 Wheezy 3,2,0-4 Xfce 4.10 AMD-64
LMDE 3.10.5-1 Xfce 4.10 AMD-64
SalineOS 2.0 3.2.0-4 Xfce 4.8 AMD64
User avatar
Beardedragon
Level 4
Level 4
 
Posts: 346
Joined: Sat Jan 29, 2011 3:37 am

Re: New spin and fglrx

Postby Roken on Sun Sep 18, 2011 9:41 pm

OK, it's definitely an LMDE problem. I wiped my system and /home partitions (after backing up, of course), and installed a naked (as in - boots to a console) Debian OS. Afterwards, I installed xorg and gnome, followed by fglrx drivers from the repository, and everything is working just fine. The downside is that I've got to spend a lot of time building my system up to what I want again, but at least it works properly again. Everything is up to date from testing, although I have several updates available after adding the multimedia repos, which I won't install until I have a backup to fall back on. If anything breaks after that, it's a step closer to the problem.

ATI's own propriety drivers are still failing, but not such an issue with fglrx from the repo working.

On the negative side, whilst I will continue to help people, I'll become less and less able to offer Mint specific help (though I should be able to continue with more general help for LMDE).
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 1 guest