Cannot find the "xorg.conf" file after installation ...

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

Cannot find the "xorg.conf" file after installation ...

Postby rollingLover on Wed Sep 21, 2011 8:17 am

Hi All,

I've been using Ubuntu for more than 3 years now and wanted to try out a rolling distribution as such. Came across LMDE and wanted to give it a try.

I installed LMDE (XFce version RC (201108)) and nearly everything seems to be working out of the box. One thing that I was not able to understand was that the system does not seem to have a xorg.conf file anywhere including under /etc/X11!

Now, I am fine using the open source drivers for my ATI card (5850) since it does not have the tearing issue like the proprietary ones from AMD. But still I am unable to understand where this file is that was a centerplace to configure Xwindows. I see that some ATI driver is loaded upon boot and that my xserver is running, but I am not able to understand where it gets the configuration from. Moreover, when I click on the "Monitors" application under "Preferences" it does nothing. I suspect that its unable to locate the conf file which has monitor related info.

I've checked various posts here and elsewhere but most of them refer to nich configurations for intel or nvidia graphic cards. Could someone direct me to the right post or help me out here? Should I be generating the file myself? If so, how will I get my Xserver to use the config file I created?

Thank you ...
rollingLover
Level 1
Level 1
 
Posts: 2
Joined: Wed Sep 21, 2011 8:03 am

Linux Mint is funded by ads and donations.
 

Re: Cannot find the "xorg.conf" file after installation ...

Postby proxima_centauri on Wed Sep 21, 2011 8:25 am

There hasn't been a default /etc/X11/xorg.conf file in quite a few releases. You only need to create one should you absolutely need one.

https://help.ubuntu.com/community/Radeo ... _for_X.org

EDIT: Sorry, I see you are running the Debian version - I'm going to assume the reasoning above is the same.
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3976
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Cannot find the "xorg.conf" file after installation ...

Postby rollingLover on Wed Sep 21, 2011 9:26 am

Thank you for the link. It show that a conf file is not required as in the past. But why could it be that the "Monitors" application used for customising resolution amongst other things not functioning?

If, lets say, I were to move to the proprietary ATI driver, would I need to create a conf file manually, or would it be created automatically by the package? Is there a guide anywhere that shows how to enable compiz on xfce in debian or LMDE?

Thank you again
rollingLover
Level 1
Level 1
 
Posts: 2
Joined: Wed Sep 21, 2011 8:03 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 5 guests