ATI Radeon: blur in KDE broken, slow FPS, artifacts

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

ATI Radeon: blur in KDE broken, slow FPS, artifacts

Postby HTD on Tue Oct 11, 2011 10:20 am

Configuration: LMDE (x64), all installable updates installed, ATI Radeon 4870 with FGLRX driver, KDE.

It happened suddenly.
I had KDE installed, everything looked good, including blur under yakuake and now it doesn't work.
Transparency is OK, but no blur.
All desktop effects are on and using OpenGL. My current window manager is kwin.
Transparency plugin is on.

glxinfo returns:
Code: Select all
direct rendering: Yes
server glx vendor string: ATI
server glx version string: 1.4
...


So it works. In GNOME blur works.
I removed ~/.kde - it didn't help.

What happened? BTW, KDE works very slow. Animations are choppy. In current state KDE seems unusable for me. First ugly (I see visual artifacts every time I open a new window), then slow, then it doesn't have the blur effect GNOME does. It's annoying, because right after installation it worked as expected and looked perfect.

Synaptic shows xorg-server is upgradable, but when I try to forcibly make an update first it tells me fglrx driver is to be removed, then, packages have broken dependencies.
I would try to disable fglrx driver, but it has no reinstall option, so when I'll remove it, I'll loose possibility to install it again, am I right?
And what will happen with X after uninstalling fglrx-driver ? Will it start with open driver, or will it break?

What can be wrong with my configuration?
HTD
Level 1
Level 1
 
Posts: 46
Joined: Sun May 22, 2011 7:31 pm

Linux Mint is funded by ads and donations.
 

Re: ATI Radeon: blur in KDE broken, slow FPS, artifacts

Postby sumski on Wed Oct 12, 2011 4:09 am

fglrx + direct rendering + kwin is a no-go , at least for me, using indirect rendering i have pretty good performance (blur enabled). You can also try wit raster graphicssystem it also helps performance. Regarding artifacts - it started happening for me with xserver 1.10 on both Debian and Arch.
Open drivers are working better with KDE than fglrx, so if there's no specific reason for using catalyst , try with them. You will be able to go back to proprietary drivers, but will need to downgrade xserver
Acer Extensa 5630G - Core2Duo T5800 2GHz , 4 GB ram, Ati Mobility 3650.
OpenSUSE 12.1 KDE 4.7.3
Debian Sid KDE 4.7.1/2
User avatar
sumski
Level 3
Level 3
 
Posts: 109
Joined: Fri Nov 26, 2010 6:36 am
Location: Zagreb, Croatia

Re: ATI Radeon: blur in KDE broken, slow FPS, artifacts

Postby HTD on Wed Oct 12, 2011 8:20 am

Thanks.

First - one important thing. Blur effect works for some of KDE elements, like Plasma widgets. Everything under them are blurred, as in Windows Aero. The wallpaper under taskbar seems blurred too. But one thing not blurred is terminal background, which makes its transparency useless, because text is hardly readable, when there's another clear readable text under the console window.
In GNOME it works. Both with guake and yakuake. The interesting thing is I've tried to use fusion-icon to switch window manager to compiz. My compiz is incompatible with KDE window decorator, but I only wanted to see if the blur works. It doesn't work even with compiz window manager instead of kwin. But interesting finding here is KDE worked way faster with compiz. I got more FPS, but well... no decorations, so unusable anyway. Besides compiz is very unstable and buggy, I think kwin is more mature project and if I'm to use KDE, kwin is the way to go. But blur problem - it's not kwin. It's broken on compiz too. (It works good in GNOME).

I've tried turning direct rendering off. It didn't help with blur. I'm not sure if it helped for performance. No. No difference.

What is raster graphicssystem? Is it something I can install? I couldn't find package named raster*.

X 1.10 - right, same for me. Tested on Ubuntu. Is there any workaround for this?

I have a specific reason for using catalyst, it's tear-free feature. I couldn't make movie players to play video without major tearing until I've checked option "tear free" in catalyst. But I only tested this in GNOME, maybe in KDE standard vsync options will work as expected. In GNOME they were randomly ignored. I've changed a compiz option. Cool, no tearing. Reboot - tearing again. Different settings - no joy. Worekd once, doesn't work again. A few reboots and suddenly it starts to work. This one was a major PITA for me. So ever since - I use fglrx and "tear free" option. This just works (but also use some of my video memory, which is not so good).

Ok, fglrx always sucked, so... How do I switch to open? Just uninstall fglrx packages? Should I install something else instead? Do I have to manualy modify xorg.conf?
How to downgrade xserver? I've tried downgrading things on Ubuntu, it NEVER worked and I always ended up formatting and installing everything from the start. If there is a safe way, I'll definitely want to try it.

Reinstalling is not an option. I don't have enough time to configure all of my stuff again and rediscover all LMDE hacks applied :)

Wait, how did you disable direct rendering? In KDE settings, or somewhere else?
HTD
Level 1
Level 1
 
Posts: 46
Joined: Sun May 22, 2011 7:31 pm

Re: ATI Radeon: blur in KDE broken, slow FPS, artifacts

Postby sumski on Wed Oct 12, 2011 1:44 pm

HTD wrote:Thanks.

First - one important thing. Blur effect works for some of KDE elements, like Plasma widgets. Everything under them are blurred, as in Windows Aero. The wallpaper under taskbar seems blurred too. But one thing not blurred is terminal background, which makes its transparency useless, because text is hardly readable, when there's another clear readable text under the console window.
In GNOME it works. Both with guake and yakuake. The interesting thing is I've tried to use fusion-icon to switch window manager to compiz. My compiz is incompatible with KDE window decorator, but I only wanted to see if the blur works. It doesn't work even with compiz window manager instead of kwin. But interesting finding here is KDE worked way faster with compiz. I got more FPS, but well... no decorations, so unusable anyway. Besides compiz is very unstable and buggy, I think kwin is more mature project and if I'm to use KDE, kwin is the way to go. But blur problem - it's not kwin. It's broken on compiz too. (It works good in GNOME).

Not really sure konsole can have blurred background:
https://svn.reviewboard.kde.org/r/4292/
http://forum.kde.org/viewtopic.php?f=111&t=88816
https://bugs.kde.org/show_bug.cgi?id=198175
HTD wrote:What is raster graphicssystem? Is it something I can install? I couldn't find package named raster*.

http://doc.qt.nokia.com/4.7-snapshot/qapplication.html#setGraphicsSystem
http://kde-apps.org/content/show.php?content=129817


HTD wrote:X 1.10 - right, same for me. Tested on Ubuntu. Is there any workaround for this?

I have a specific reason for using catalyst, it's tear-free feature. I couldn't make movie players to play video without major tearing until I've checked option "tear free" in catalyst. But I only tested this in GNOME, maybe in KDE standard vsync options will work as expected. In GNOME they were randomly ignored. I've changed a compiz option. Cool, no tearing. Reboot - tearing again. Different settings - no joy. Worekd once, doesn't work again. A few reboots and suddenly it starts to work. This one was a major PITA for me. So ever since - I use fglrx and "tear free" option. This just works (but also use some of my video memory, which is not so good).

Ok, fglrx always sucked, so... How do I switch to open? Just uninstall fglrx packages? Should I install something else instead? Do I have to manualy modify xorg.conf?
How to downgrade xserver? I've tried downgrading things on Ubuntu, it NEVER worked and I always ended up formatting and installing everything from the start. If there is a safe way, I'll definitely want to try it.

Reinstalling is not an option. I don't have enough time to configure all of my stuff again and rediscover all LMDE hacks applied :)

You could try downgrading xserver with the help of debian snapshots
Reverting to open drivers is simple - remove fglrx packages , update your system , and remove xorg.conf

HTD wrote:Wait, how did you disable direct rendering? In KDE settings, or somewhere else?


Systemsettings --> Desktop Effects --> Advanced --> Remove the direct rendering checkbox
Acer Extensa 5630G - Core2Duo T5800 2GHz , 4 GB ram, Ati Mobility 3650.
OpenSUSE 12.1 KDE 4.7.3
Debian Sid KDE 4.7.1/2
User avatar
sumski
Level 3
Level 3
 
Posts: 109
Joined: Fri Nov 26, 2010 6:36 am
Location: Zagreb, Croatia

Re: ATI Radeon: blur in KDE broken, slow FPS, artifacts

Postby HTD on Wed Oct 12, 2011 2:09 pm

I've removed fglrx. Switched back to software glx. And I regret it. Now I don't have blur effect at all. My emerald has gone to hell. System works even slower and looks worse. The real problem is fglrx is no longer installable since there are no fglrx packages in current debian/LMDE repo. I tried sgfxi - that's the one which removed my fglrx. Well, it started to install latest fglrx driver, but it failed, leaving me with nothing. It failed, because ati installer complains I have a previous installation which should be uninstalled. No, I don't. I even manually removed all files and directories named ati* or fglrx*. It didn't help. I don't have any fglrx package installed, yet still damn installer says it won't install because I have previous installation. I'm pretty fed up with this. Of course I tried to use --force. Installed successfully, with missing libraries. Aticonfig didn't run. So, what now?
HTD
Level 1
Level 1
 
Posts: 46
Joined: Sun May 22, 2011 7:31 pm

Re: ATI Radeon: blur in KDE broken, slow FPS, artifacts

Postby sumski on Wed Oct 12, 2011 2:21 pm

What about fglrx from repo's?
What xserver version do you have now?
Acer Extensa 5630G - Core2Duo T5800 2GHz , 4 GB ram, Ati Mobility 3650.
OpenSUSE 12.1 KDE 4.7.3
Debian Sid KDE 4.7.1/2
User avatar
sumski
Level 3
Level 3
 
Posts: 109
Joined: Fri Nov 26, 2010 6:36 am
Location: Zagreb, Croatia

Re: ATI Radeon: blur in KDE broken, slow FPS, artifacts

Postby HTD on Wed Oct 12, 2011 3:17 pm

Code: Select all
# apt-cache search fglrx
glx-alternative-fglrx - allows the selection of FGLRX as GLX provider
xserver-xorg-video-radeon

And that's all, no other packages are available.

My xserver version is 1.10.4.

So - first I managed to kill "previous installation" - using info from log. Removed one file and...
New driver installed "successfully" :P
At least what the message said. I tried aticonfig, and it said it can't find libGL.so.1. Well,
Code: Select all
ln -s /usr/lib64/libGL.so.1 /usr/lib

and voila, works.

Ok, let's check if we have fglrx kernel module with modprobe. Yes we have. So startx. No joy:
'failed to load module "fglrx" (module does not exist, 0)'

What now?
BTW, my kernel version is 3.0.0-1-amd64 (and it's default for current LMDE)
HTD
Level 1
Level 1
 
Posts: 46
Joined: Sun May 22, 2011 7:31 pm

Re: ATI Radeon: blur in KDE broken, slow FPS, artifacts

Postby sumski on Wed Oct 12, 2011 3:32 pm

Acer Extensa 5630G - Core2Duo T5800 2GHz , 4 GB ram, Ati Mobility 3650.
OpenSUSE 12.1 KDE 4.7.3
Debian Sid KDE 4.7.1/2
User avatar
sumski
Level 3
Level 3
 
Posts: 109
Joined: Fri Nov 26, 2010 6:36 am
Location: Zagreb, Croatia

Re: ATI Radeon: blur in KDE broken, slow FPS, artifacts

Postby HTD on Wed Oct 12, 2011 3:43 pm

OK, guys, I've solved it all by myself, but it's a bug either in ati driver, or in LMDE itself:
I had to make symlinks of all files in /usr/lib64 to /usr/lib.
I mean if directory existed, I symlinked all files inside to coresponding /usr/lib path. Rebooted (first try of starting X failed with frozen black screen) and voila, works as charm!
confused is /usr/lib64 for?

---
Update: I've forcibly installed xserver-xorg 1.11 and... damn, fglrx died horribly :) Black screen, no console. Removing xorg.conf helped, but now I have plain old slow open driver. No artifacts though. Yes, no artifacting makes it worth trying, but sgfxi says catalyst 11.9 won't work with xorg 1.11, but I can try anyway. So I tried, but no surprises. Dead and cold.

So, is there a way to downgrade X11 on LMDE? Some sort of tutorial somewhere? I've googled for one, but without any luck.
HTD
Level 1
Level 1
 
Posts: 46
Joined: Sun May 22, 2011 7:31 pm

Re: ATI Radeon: blur in KDE broken, slow FPS, artifacts

Postby sumski on Wed Oct 12, 2011 7:10 pm

http://snapshot.debian.org/

The snapshot archive is a wayback machine that allows access to old packages based on dates and version numbers. It consists of all past and current packages the Debian archive provides.

The ability to install packages and view source code from any given date can be very helpful to developers and users. It provides a valuable resource for tracking down when regressions were introduced, or for providing a specific environment that a particular application may require to run. The snapshot archive is accessible like any normal apt repository, allowing it to be easily used by all.
Acer Extensa 5630G - Core2Duo T5800 2GHz , 4 GB ram, Ati Mobility 3650.
OpenSUSE 12.1 KDE 4.7.3
Debian Sid KDE 4.7.1/2
User avatar
sumski
Level 3
Level 3
 
Posts: 109
Joined: Fri Nov 26, 2010 6:36 am
Location: Zagreb, Croatia


Re: ATI Radeon: blur in KDE broken, slow FPS, artifacts

Postby HTD on Fri Oct 14, 2011 12:21 pm

And it won't break my system? Will synaptic show those packages after installing?
HTD
Level 1
Level 1
 
Posts: 46
Joined: Sun May 22, 2011 7:31 pm

Re: ATI Radeon: blur in KDE broken, slow FPS, artifacts

Postby sumski on Sat Oct 15, 2011 6:12 am

Apologies, you shouldn't use those packages from squeeze-backports , they aren't multiarch-enabled - try with debian snapshots. Also i suggest you to remove the symlink you made for libGl, that should be done via update-alternatives
Acer Extensa 5630G - Core2Duo T5800 2GHz , 4 GB ram, Ati Mobility 3650.
OpenSUSE 12.1 KDE 4.7.3
Debian Sid KDE 4.7.1/2
User avatar
sumski
Level 3
Level 3
 
Posts: 109
Joined: Fri Nov 26, 2010 6:36 am
Location: Zagreb, Croatia

Re: ATI Radeon: blur in KDE broken, slow FPS, artifacts

Postby HTD on Sat Oct 15, 2011 7:06 am

Well, I was affraid after I broke my LMDE so much, so after downgrading xserver-xorg-base (which caused first problems) i upgraded it back. I also removed all symlinks I've made for catalyst.
BTW, do you know why does catalyst install all driver files in /usr/lib64 instead of /usr/lib? Is it possible to set up LMDE to make it search for *.so files in /usr/lib64 too? When I made catalyst work in x 1.10 - I had to create a symlink in /usr/lib for each file in /usr/lib64. So it was like about 20 files. If the driver developers made it install in /var/lib64 - they made it for a reason, I wish I understood it. I could fix many issues with my LMDE (like sound, skype, flash).
HTD
Level 1
Level 1
 
Posts: 46
Joined: Sun May 22, 2011 7:31 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 5 guests