/etc/modprobe.d/options.conf seem to be ignored

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

/etc/modprobe.d/options.conf seem to be ignored

Postby wb666greene on Wed Oct 12, 2011 10:52 am

I've a pair of video capture cards that lack the EEPROM so they need a card=<NR> insmod option to work.

I created the /etc/modeprobe.d/options.conf and added the line:
options saa1734 card=42,42

and rebooted. Unfortunately it appears to be ignored and the driver still complains:

[ 21.024298] saa7130[0]: Huh, no eeprom present (err=-5)?
[ 21.024400] saa7130[0]: registered device video0 [v4l2]
[ 21.024432] saa7130[0]: registered device vbi0
[ 21.130770] saa7134 0000:01:08.0: PCI INT A -> Link[APC3] -> GSI 18 (level, low) -> IRQ 18
[ 21.130776] saa7130[1]: found at 0000:01:08.0, rev: 1, irq: 18, latency: 32, mmio: 0xfdefd000
[ 21.130782] saa7134: Board is currently unknown. You might try to use the card=<nr>
[ 21.130784] saa7134: insmod option to specify which board do you have, but this is
[ 21.130785] saa7134: somewhat risky, as might damage your card. It is better to ask
[ 21.130786] saa7134: for support at linux-media@vger.kernel.org.
[ 21.130788] saa7134: The supported cards are:


Any idea how to fix? This is a showstopper for me!

Both /dev/video0 & /dev/video1 entries are created but nothing works because the inputs can't be changed.
wb666greene
Level 1
Level 1
 
Posts: 27
Joined: Tue Oct 04, 2011 3:05 pm

Linux Mint is funded by ads and donations.
 

Re: /etc/modprobe.d/options.conf seem to be ignored

Postby AlbertP on Wed Oct 12, 2011 10:53 am

Perhaps you have to specify card=42 instead of card=42,42

Are you sure your cards are Sabrent SBT-TVFM cards? The subsystem 1131:0000 is not only used on those cards but also on many other TV cards with Philips SAA713x chip.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: /etc/modprobe.d/options.conf seem to be ignored

Postby wb666greene on Wed Oct 12, 2011 11:21 am

I need card=42,42 because there are two cards in the system and I need both to work. But its easy enough to try, I'll report back after a reboot if it fixes both cards -- but this would be a bug as I've another system wtih two SAA723x cards that need different numbers for each card.

Yes I'm sure they are Sabrent SBT-TVFM cards and I use the same options line in Ubuntu 10.04 to get them to work there.
wb666greene
Level 1
Level 1
 
Posts: 27
Joined: Tue Oct 04, 2011 3:05 pm

Re: /etc/modprobe.d/options.conf seem to be ignored

Postby AlbertP on Wed Oct 12, 2011 11:37 am

Please install the 2.6.38-11 kernel update from Package Manager.
Ubuntu has this one included in the update manager, but Mint does not. Perhaps this solves the problem.

You can also take a look at this page: http://linuxtv.org/wiki/index.php/Sabrent_SBT-TVFM

The problem with this card is that it does not identify itself as being a Sabrent SBT-TVFM. It identifies itself as a generic Philips SAA713x-based card.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: /etc/modprobe.d/options.conf seem to be ignored

Postby wb666greene on Wed Oct 12, 2011 12:02 pm

AlbertP wrote:Please install the 2.6.38-11 kernel update from Package Manager.
Ubuntu has this one included in the update manager, but Mint does not. Perhaps this solves the problem.


Looks like this would be a kernel downgrade:
Code: Select all
uname -a
Linux mint 2.6.39-2-amd64 #1 SMP Tue Jul 5 02:51:22 UTC 2011 x86_64 GNU/Linux


Ubuntu 10.04 is kernel 2.6.32
wb666greene
Level 1
Level 1
 
Posts: 27
Joined: Tue Oct 04, 2011 3:05 pm

Re: /etc/modprobe.d/options.conf seem to be ignored

Postby AlbertP on Wed Oct 12, 2011 12:38 pm

Oh you're using Debian?

Please try tuner= options as well as described on the link I gave. The card exists with different tuners.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: /etc/modprobe.d/options.conf seem to be ignored

Postby wb666greene on Wed Oct 12, 2011 2:51 pm

AlbertP wrote:Oh you're using Debian?

Please try tuner= options as well as described on the link I gave. The card exists with different tuners.


This is the LMDE fourm, is it not?

You are wasting my time, it doesn't matter what tuner it uses as I've never used the tuner and since over the air NTSC is history, it has no use beyond uisng a VCR or cable box via the legacy RF modulator

The problem is selecting the proper driver logic to select the input, only one of which is connected to the tuner. That is what the card=<NR> option does. Trouble is LMDE is ignoring the option.
wb666greene
Level 1
Level 1
 
Posts: 27
Joined: Tue Oct 04, 2011 3:05 pm

Re: /etc/modprobe.d/options.conf seem to be ignored

Postby wb666greene on Wed Oct 12, 2011 3:00 pm

rmmod saa7134 followed by modprobe saa7134 card=42,42 works.

Clearly this is an issue with the LMDE boot scripts not using the /etc/modprobe.d/options.conf file.
wb666greene
Level 1
Level 1
 
Posts: 27
Joined: Tue Oct 04, 2011 3:05 pm

Re: /etc/modprobe.d/options.conf seem to be ignored

Postby wb666greene on Thu Oct 13, 2011 10:56 am

wb666greene wrote:rmmod saa7134 followed by modprobe saa7134 card=42,42 works.

Clearly this is an issue with the LMDE boot scripts not using the /etc/modprobe.d/options.conf file.



Where is the proper place to file a bug report on this? It needs to be fixed.
wb666greene
Level 1
Level 1
 
Posts: 27
Joined: Tue Oct 04, 2011 3:05 pm

Re: /etc/modprobe.d/options.conf seem to be ignored

Postby AlbertP on Thu Oct 13, 2011 11:21 am

Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: /etc/modprobe.d/options.conf seem to be ignored

Postby wb666greene on Thu Oct 13, 2011 11:40 am

Thanks, I'll file one on this.

I've found a work around:
sudo crontab -e

and add this line to the crontab file:
@reboot /sbin/rmmod saa7134 && /sbin/modprobe saa7134 card=42,42
wb666greene
Level 1
Level 1
 
Posts: 27
Joined: Tue Oct 04, 2011 3:05 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 2 guests