Logitech, Inc. QuickCam Messanger poor video quality

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

Logitech, Inc. QuickCam Messanger poor video quality

Postby madwoollything on Mon Oct 24, 2011 6:47 am

I've been successfully using the Logitech webcam in Ubuntu 10.04 with no issues.
Having just installed LMDE the webcam will work using Cheese but the picture quality is very poor.

I've been looking for a solution with no success so far.
Anyone any ideas?
madwoollything
Level 3
Level 3
 
Posts: 158
Joined: Sun Jul 20, 2008 8:46 am

Linux Mint is funded by ads and donations.
 

Re: Logitech, Inc. QuickCam Messanger poor video quality

Postby Roken on Mon Oct 24, 2011 7:52 am

It depends on what you mean by "Poor quality", though there is a known problem with cheese right now. See here: viewtopic.php?f=47&t=83826&p=486959#p486959
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: Logitech, Inc. QuickCam Messanger poor video quality

Postby madwoollything on Mon Oct 24, 2011 1:36 pm

This works nicely using camorama instead of cheese. The problems is clearly the upgrade to v3.0.1 of cheese.

The question is now how to get Skype video working again on 32 bit LMDE. I have no output - a black screen where the video should be.

I was using the fix below BUT it does not seem to work. Any ideas how to fix this? Maybe some tweak to the code in the config file?

(I've found other posts but nothing that seems to relate to a black screen??)

---------------------------------------------------------------
1. Rename skype in /usr/bin to skype.real:
Code:
sudo mv /usr/bin/skype /usr/bin/skype.real

2. Create a new skype file in /usr/bin:
Code:
sudo gedit /usr/bin/skype

3. Paste inside the opened file these lines:
Code:
#!/bin/bash
export XLIB_SKIP_ARGB_VISUALS=1
env LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype.real

4. Save the file and make it executable:
Code:
sudo chmod +x /usr/bin/skype
madwoollything
Level 3
Level 3
 
Posts: 158
Joined: Sun Jul 20, 2008 8:46 am

Re: Logitech, Inc. QuickCam Messanger poor video quality

Postby Roken on Mon Oct 24, 2011 6:59 pm

I'm not sure with 32 Bit - but in a terminal:

Code: Select all
locate v4l1compat.so


Certainly on 64 bit there are 3 versions of the file in lib, lib32 and lib64. For each location that you find it, try changing:
Code: Select all
env LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype.real


to substitute /usr/lib for the alternatives offered. I had to cycle through them to get skype working.
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: Logitech, Inc. QuickCam Messanger poor video quality

Postby madwoollything on Tue Oct 25, 2011 4:09 am

Roken wrote:I'm not sure with 32 Bit - but in a terminal:

Code: Select all
locate v4l1compat.so


Certainly on 64 bit there are 3 versions of the file in lib, lib32 and lib64. For each location that you find it, try changing:
Code: Select all
env LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype.real


to substitute /usr/lib for the alternatives offered. I had to cycle through them to get skype working.


Thanks .... I've found a v4l1compat.so file in /usr/lib/i386-linux-gnu/libv4l but am unable to open the file to make any changes.

Some more hints on what to do would be great.

When I launch skype from the command line I get the following message:
ERROR: ld.so: object '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.
madwoollything
Level 3
Level 3
 
Posts: 158
Joined: Sun Jul 20, 2008 8:46 am

Re: Logitech, Inc. QuickCam Messanger poor video quality

Postby Roken on Tue Oct 25, 2011 4:28 am

Ahh, you misunderstood. I meant in your skype launch script modify the launch line:

Code: Select all
sudo gedit /usr/bin/skype


and replace the line beginning with env LD_PRELOAD with:

Code: Select all
env LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype.real


then save and try launcinh skype again (in a terminal so that you can check for error messages)
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: Logitech, Inc. QuickCam Messanger poor video quality

Postby madwoollything on Tue Oct 25, 2011 4:37 am

Roken wrote:Ahh, you misunderstood. I meant in your skype launch script modify the launch line:

Code: Select all
sudo gedit /usr/bin/skype


and replace the line beginning with env LD_PRELOAD with:

Code: Select all
env LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype.real


then save and try launcinh skype again (in a terminal so that you can check for error messages)


Excellent ...... video now works ...... thanks.

PS Video quality is poor - similar to cheese problem (see start of this post). Camorama works nicely, so is it possible to use the configuration from camorama for Skype to improve the video quality?
madwoollything
Level 3
Level 3
 
Posts: 158
Joined: Sun Jul 20, 2008 8:46 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 4 guests