Can't install fglrx [SOLVED]

Questions about hardware and drivers
Forum rules
Before you post please read this

Can't install fglrx [SOLVED]

Postby tapp on Sun Oct 30, 2011 1:08 pm

Hi!

I'm trying to install ATI propietary drivers for a Radeon HD 6300 graphics card. I've downloaded and installed the Ati drivers from AMD site, and now I need to install flxgr. I enter the following command:

Code: Select all
sudo apt-get install fglrx-driver


but it fails with the following error (It's in spanish; Imposible obtener stands for can't get):

Code: Select all
Imposible obtener http://mirrors.kernel.org/debian/pool/non-free/f/fglrx-driver/fglrx-glx_10-9-3_amd64.deb  404  Not Found
Imposible obtener http://mirrors.kernel.org/debian/pool/non-free/f/fglrx-driver/fglrx-driver_10-9-3_amd64.deb  404  Not Found
Imposible obtener http://mirrors.kernel.org/debian/pool/non-free/f/fglrx-driver/fglrx-glx-ia32_10-9-3_amd64.deb  404  Not Found
Imposible obtener http://mirrors.kernel.org/debian/pool/non-free/f/fglrx-driver/fglrx-atieventsd_10-9-3_amd64.deb  404  Not Found
Imposible obtener http://mirrors.kernel.org/debian/pool/non-free/f/fglrx-driver/fglrx-control_10-9-3_amd64.deb  404  Not Found
Imposible obtener http://mirrors.kernel.org/debian/pool/non-free/f/fglrx-driver/fglrx-modules-dkms_10-9-3_amd64.deb  404  Not Found
E: No se pudieron obtener algunos archivos, ¿quizás deba ejecutar «apt-get update» o deba intentarlo de nuevo con --fix-missing?


I receive similar errors with other software packages (i.e. java), so I think that I have a problem with my apt sources. They're:

Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import
deb http://ftp.es.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free
deb http://mirrors.kernel.org/debian/ squeeze main contrib non-free
deb http://linux.dropbox.com/ubuntu maverick main
deb http://liquorix.net/debian/ sid main


They've have been modified by smxi, although previously I had similar problems.

Any suggestions.

Thanks for your help.
Last edited by tapp on Sun Oct 30, 2011 5:15 pm, edited 1 time in total.
tapp
Level 1
Level 1
 
Posts: 4
Joined: Mon Mar 28, 2011 8:09 am

Linux Mint is funded by ads and donations.
 

Re: Can't install flxgr

Postby proxima_centauri on Sun Oct 30, 2011 2:04 pm

* Moved to LMDE forum

Before you think about installing the ATI driver, you should properly update LMDE to update pack 3 with the correct repos.
viewtopic.php?f=185&t=82346
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3968
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Can't install fglrx

Postby tapp on Sun Oct 30, 2011 5:14 pm

Thanks!!!

You guided me to the solution. minupdate-debian was not installed (or was uninstalled) :-m I don't know why.

Once I installed it, the pack 3 could be applied without problems.

Best regards.
tapp
Level 1
Level 1
 
Posts: 4
Joined: Mon Mar 28, 2011 8:09 am

Re: Can't install fglrx [SOLVED]

Postby h2-1 on Sun Oct 30, 2011 11:24 pm

mirrors.kernel.org has been offline for quite a while, you have to replace that with another repo.

This is because of the kernel.org hacking. Not sure when the mirrors will be back online.
smxi/sgfxi site (manuals, how-to's, faqs) :: script forums :: Check out inxi sys info script!
h2-1
Level 3
Level 3
 
Posts: 118
Joined: Sat Oct 16, 2010 4:02 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 3 guests