Printer communication broken with 3.0 upgrade

Questions about hardware and drivers
Forum rules
Before you post please read this

Printer communication broken with 3.0 upgrade

Postby jsonder on Sun Nov 20, 2011 6:18 pm

I have an HP LaserJet 5MP (usb connection to computer) that has worked well with linux for about 10 years.

It still works with Mint 11, but both Debian (squeeze) and LMDE (after the 3.0 upgrade) have a new problem. The printer doesn't communicate with the computer. See the screen shot, LMDE is waiting for the printer to become available, and the print queue is empty.

Image

I should add that the computer is a Dell XPS15 (with USB 3.0 ports) which still prints using Mint 11; below is the hardinfo printer data showing that the computer thinks that the printer is busy printing a job. {it isn't}. The uri used is the one that works with Mint 11.

Image

Any suggestions for an approach to fix this would be appreciated.
jsonder
Level 1
Level 1
 
Posts: 7
Joined: Sun Nov 07, 2010 1:33 am

Linux Mint is funded by ads and donations.
 

Re: Printer communication broken with 3.0 upgrade

Postby olle on Mon Nov 21, 2011 3:07 pm

Have you tried rebooting the printer ? (when using Debian )
olle
Level 3
Level 3
 
Posts: 128
Joined: Thu Oct 08, 2009 12:03 pm
Location: Helsinki, Finland

Re: Printer communication broken with 3.0 upgrade

Postby jsonder on Fri Dec 09, 2011 5:36 pm

Yes, I've rebooted the printer, which didn't work (self test of the printer works fine), and then rebooted the the computer (printer left on) with the same results except that the job queue shows the test print job as "pending". The time increments on the pending message, but, no data are transferred to the printer (currently at 5 minutes). And for giggles, I tried all 3 of the drivers, none of which sends an iota of data to the printer (das blinken light does not blink to indicate data transfer).

Image
jsonder
Level 1
Level 1
 
Posts: 7
Joined: Sun Nov 07, 2010 1:33 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 2 guests