[Solved] How to disable vblank to sync for i915 graphics?

Questions about hardware and drivers
Forum rules
Before you post please read this

[Solved] How to disable vblank to sync for i915 graphics?

Postby trenthawkins on Thu Nov 24, 2011 8:05 pm

This might be a newbie question, but i would really love it if someone could explain how i disable vblank to sync for my i915 graphics card.

I know that i need to set the option "SwapbuffersWait" to false in X, but given that X11 doesn't require a xorg.conf file to be created anymore, where do i change this option so that when the xorg setup is automatically created it parses this command?

The only helpful information i have found on this topic comes from the Arch Wiki here - https://wiki.archlinux.org/index.php/In ... ce_results

This says:
To disable VSync just add in your /etc/X11/xorg.conf.d/20-intel.conf in Section "Device" string Option "SwapbuffersWait" "false"


At the moment I can't use LMDE on my machine because when it runs off battery power it flickers uncontrollably and i have spent some time searching for a solution and the only thing i can think of trying is to stop it from synchronising the rendering to the vertical refresh (which is enabled by default).
Last edited by trenthawkins on Tue Nov 29, 2011 2:30 am, edited 1 time in total.
trenthawkins
Level 1
Level 1
 
Posts: 6
Joined: Tue Jul 19, 2011 12:58 am

Linux Mint is funded by ads and donations.
 

Re: How to disable vblank to sync for i915 graphics?

Postby Roken on Thu Nov 24, 2011 10:39 pm

I can't answer your specific question, but I can say that the latest RC of the 3.2 kernel (rc3) includes a lot of changes for i915 (I noticed when I looked through the changelog before building) so maybe it will get easier before too long.
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: How to disable vblank to sync for i915 graphics?

Postby ej64 on Sun Nov 27, 2011 4:01 pm

trenthawkins wrote:
This says:
To disable VSync just add in your /etc/X11/xorg.conf.d/20-intel.conf in Section "Device" string Option "SwapbuffersWait" "false"

At the moment I can't use LMDE on my machine because when it runs off battery power it flickers uncontrollably and i have spent some time searching for a solution and the only thing i can think of trying is to stop it from synchronising the rendering to the vertical refresh (which is enabled by default).

1. Boot your system in maintainance mode (usually 2nd grub line), X must not run to do the following
2. login as root for maintainance (usual password for su)
3. run: "Xorg -configure"
4. You'll find an xorg.conf.new in /root
5. copy this file to /etc/X11/xorg.conf or copy and rename
6. insert "SwapbuffersWait" false into the first device section, it will look like this
Code: Select all
Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "DRI"                   # [<bool>]
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "Shadow"                # [<bool>]
        Option     "SwapbuffersWait"       false
        #Option     "TripleBuffer"          # [<bool>]
        #Option     "XvMC"                  # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "DebugFlushBatches"     # [<bool>]
        #Option     "DebugFlushCaches"      # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "RelaxedFencing"        # [<bool>]
   Identifier  "Card0"
   Driver      "intel"
   BusID       "PCI:0:2:0"
EndSection

7. reboot and have fun :D
Thinkpad X220 with Samsung SSD running Xubuntu 13.04
I'm getting old gladly -- I don't like to die young ...
ej64
Level 4
Level 4
 
Posts: 326
Joined: Tue Nov 24, 2009 7:43 am
Location: somewhere in Germany

Re: How to disable vblank to sync for i915 graphics?

Postby trenthawkins on Tue Nov 29, 2011 2:30 am

Thanks for the help ej64 and Roken, but i decided to take a different route and have an interesting result as a consequence.

For anyone that is interested i will quickly elaborate, and i will post this on the Linux Hybrid Graphics list too.

I have a Dell Vostro 3350 Laptop with a hybrid AMD/i915 graphics set up. I won't go into the details, but suffice to say most Linux OSs boot with the intel driver running the graphics and the AMD stays on causing a fan to spin constantly and my battery life to be pathetic (3 hrs max - should be 8+).

The solution to the problem i initially used was vga_switcheroo which is already in the kernel. This is fairly straight forward to set up and looked like a good solution. Except that every time i turned off the discrete card my graphics would flicker constantly, especially on batter power.

I have been playing around with Chakra for a bit and after i found i couldn't use vga_switcheroo i have been using acpi_call. Here is the forum thread on this topic: http://chakra-project.org/bbs/viewtopic.php?id=5995 and here is the method for installing: http://hybrid-graphics-linux.tuxfamily. ... =Acpi_call

Now i just went through this method and successfully turned off the graphics card using the script /usr/src/acpi_call-0.0.1/test_off.sh

What happened?

Well the flickering went away and my machine works perfectly!!!!!!!

This may indicate that there is a problem with the specific calls that vga_switcheroo uses for my machine.

Anyway hopefully someone out there sees this thread and solves their problem.
trenthawkins
Level 1
Level 1
 
Posts: 6
Joined: Tue Jul 19, 2011 12:58 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 1 guest