Old Toshiba Satellite A100, ATI Radeon X600

Questions about hardware and drivers
Forum rules
Before you post please read this

Old Toshiba Satellite A100, ATI Radeon X600

Postby betacentauri on Mon Dec 26, 2011 9:24 pm

It was time to replace my old distro on my even older notebook, and I'm insanely pleased with LMDE 201109!

Regarding ATI video accel however, I suspect to be screwed... Please let me confirm it is so in order not to spend any more time with it. To make a long story short, some facts:

1) Radeon free driver works - I can see glxgears moving but at a fairly low speed, and Google Earth admits to be working on hardware acceleration but is a pain nevertheless.

2) ATI proprietary driver used to work beautifully on Former Distro --long ago. However, running any (9.2, 9.3, 9.5) ati-driver-installer now gives me on Mint:

Code: Select all
Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:3.0.0-1-486; make sure that the version is being
correctly set by --iscurrentdistro


3) Later I discovered sgfxi, who spits this:
Code: Select all
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
 graphics card information:
   series: ATI M24 [Radeon Mobility X600]
   vendor: Toshiba America Info Systems
   ram:    128M (note: not accurate for built in graphics)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
The graphics installer will be installing the fglrx driver: 11-12
Hit <enter> to continue, or  x + <enter> to exit now if there is an error.

ERROR: (221) AMD/ATI had dropped fglrx non-free driver support for your card type as of driver release 9-4
Only cards x2000 or newer are now supported by AMD/ATI for this driver.
If you know your card is supported, please let the sgfxi maintainer know.
You can override this test with -! 6 option. If install works, let maintainer know.

Log file is located here: /var/log/sgfxi/sgfxi.log
Exiting script now.



So, if the driver should be earlier than 9.4 (as per sgfxi) but 9.2 or 9.3 won't work... looks like I am stuck forever with the radeon free driver, but I wanted to check it up with any knowledgeable user. Now, my questions:

1) What's with the ati-driver-installer error message? Does the problem have a cure?

2) Let's say I manage to stumble upon an older driver from my Older Distro era. Do I have a chance that it may work with today's Mint?

Any light gladly accepted. Thank you very much for your support!
betacentauri
Level 1
Level 1
 
Posts: 18
Joined: Sun Oct 17, 2010 3:42 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 4 guests