Canon 7D won't mount

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

Canon 7D won't mount

Postby weezy on Sat Feb 25, 2012 9:59 pm

this is the first time i've had trouble mounting a usb device (i'm running LMDE). my nikon D50 mounts fine but for some reason the Canon isn't mounting.
here's a look at the /var/log/messages..

Feb 25 18:34:50 weezy mtp-probe: bus: 1, device: 5 was not an MTP device
Feb 25 18:34:53 weezy kernel: [15590.017223] usb 1-1: USB disconnect, device number 5
Feb 25 18:34:55 weezy kernel: [15592.268036] usb 1-1: new high speed USB device number 6 using ehci_hcd
Feb 25 18:34:55 weezy mtp-probe: checking bus 1, device 6: "/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-1"
Feb 25 18:34:55 weezy kernel: [15592.401738] usb 1-1: New USB device found, idVendor=04a9, idProduct=319a
Feb 25 18:34:55 weezy kernel: [15592.401743] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Feb 25 18:34:55 weezy kernel: [15592.401747] usb 1-1: Product: Canon Digital Camera
Feb 25 18:34:55 weezy kernel: [15592.401750] usb 1-1: Manufacturer: Canon Inc.
Feb 25 18:34:56 weezy mtp-probe: bus: 1, device: 6 was not an MTP device
Feb 25 18:35:59 weezy kernel: [15655.683772] usb 1-1: USB disconnect, device number 6

doesn't show up when i fdisk

there is no way in the menu on the 7D to change it to an MTP device which usually solves the problem.

halp?.. cheers
weezy
Level 1
Level 1
 
Posts: 8
Joined: Sat Jan 28, 2012 11:06 am

Linux Mint is funded by ads and donations.
 

Re: Canon 7D won't mount

Postby weezy on Mon Feb 27, 2012 3:29 am

update: i'm using gtkam to get photos from my camera to my hard drive, works great.
weezy
Level 1
Level 1
 
Posts: 8
Joined: Sat Jan 28, 2012 11:06 am

Re: Canon 7D won't mount

Postby Oscar799 on Mon Feb 27, 2012 5:27 am

Moved here by moderator
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8968
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Canon 7D won't mount

Postby DataMan on Mon Feb 27, 2012 11:52 am

Just a wild guess - try installing mtp-tools .

-DataMan
Linux'd since 2005 Linux ID 422356 Ubuntu ID 15015
User avatar
DataMan
Level 6
Level 6
 
Posts: 1226
Joined: Thu Dec 04, 2008 6:47 am
Location: Carmel, Indiana USA at /var/www

Re: Canon 7D won't mount

Postby ej64 on Mon Feb 27, 2012 12:22 pm

Feb 25 18:34:56 weezy mtp-probe: bus: 1, device: 6 was not an MTP device

Change the usb connector to MTP (camera menu)
Thinkpad X220 with Samsung SSD running Xubuntu 13.04
I'm getting old gladly -- I don't like to die young ...
ej64
Level 4
Level 4
 
Posts: 326
Joined: Tue Nov 24, 2009 7:43 am
Location: somewhere in Germany


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 6 guests