Bluetooth not working on LMDE

Questions about hardware and drivers
Forum rules
Before you post please read this

Bluetooth not working on LMDE

Postby negatory on Sun Mar 11, 2012 5:54 am

I have a bluetooth dongle that has been working for the past 5 years on another linux distro but when I installed LMDE it stopped working with a strange error.

After a "sudo /etc/init.d/bluetooth restart" syslog shows the following:
Code: Select all
Mar 11 09:30:35 zion bluetoothd[3219]: Stopping hci0 event socket
Mar 11 09:30:35 zion bluetoothd[3219]: Stopping SDP server
Mar 11 09:30:35 zion bluetoothd[3219]: Exit
Mar 11 09:30:36 zion dbus[1512]: [system] Reloaded configuration
Mar 11 09:31:46 zion dbus[1512]: [system] Reloaded configuration
Mar 11 09:31:46 zion dbus[1512]: [system] Reloaded configuration
Mar 11 09:31:56 zion dbus[1512]: [system] Reloaded configuration
^KMar 11 09:31:56 zion dbus[1512]: [system] Reloaded configuration
Mar 11 09:31:57 zion bluetoothd[4615]: Bluetooth daemon 4.94
Mar 11 09:31:57 zion bluetoothd[4615]: Starting SDP server
Mar 11 09:31:57 zion bluetoothd[4615]: Listening for HCI events on hci0
Mar 11 09:31:57 zion NetworkManager[1557]: <warn> bluez error getting default adapter: No such adapter
Mar 11 09:32:07 zion bluetoothd[4619]: Can't init device hci0: Connection timed out (110)


sudo hciconfig -a shows:
Code: Select all
hci0:   Type: BR/EDR  Bus: USB
   BD Address: 00:0B:0D:33:0E:E1  ACL MTU: 120:20  SCO MTU: 0:0
   DOWN
   RX bytes:3258 acl:0 sco:0 events:117 errors:0
   TX bytes:513 acl:0 sco:0 commands:117 errors:0
   Features: 0xff 0xff 0x05 0x38 0x18 0x18 0x00 0x00
   Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
   Link policy:
   Link mode: SLAVE ACCEPT


lsusb shows:
Code: Select all
Bus 004 Device 002: ID 1310:0001 Roper Class 1 Bluetooth Dongle


lsmod | grep bluetooth
Code: Select all
bluetooth             114376  13 rfcomm,bnep,btusb
rfkill                 19080  2 bluetooth
crc16                  12343  2 bluetooth,ext4


dpkg -l | grep blue
Code: Select all
ii  bluetooth                                4.94-3                            Bluetooth support
ii  bluez                                    4.94-3                            Bluetooth tools and daemons
ii  bluez-alsa                               4.94-3                            Bluetooth ALSA support
ii  bluez-cups                               4.94-3                            Bluetooth printer driver for CUPS
ii  bluez-gstreamer                          4.94-3                            Bluetooth GStreamer support
ii  bluez-tools                              0.1.38+git662e-2                  A set of tools to manage Bluetooth devices for linux
ii  gnome-bluetooth                          2.30.0-3                          GNOME Bluetooth tools
ii  libbluetooth3                            4.94-3                            Library to use the BlueZ Linux Bluetooth stack
ii  libgnome-bluetooth7                      2.30.0-3                          GNOME Bluetooth tools - support library
ii  mplayer-skin-blue                        1.6-2                             blue skin for mplayer


Any ideas on how I can solve this?
negatory
Level 1
Level 1
 
Posts: 6
Joined: Sun Mar 11, 2012 5:42 am

Linux Mint is funded by ads and donations.
 

Re: Bluetooth not working on LMDE

Postby negatory on Sun Mar 11, 2012 8:22 pm

I think this may be related to this http://lists.alioth.debian.org/pipermail/pkg-bluetooth-maintainers/2011-September/003050.html

Not sure if I should patch the kernel myself or install the Debian Squeeze version and try to go from there.
negatory
Level 1
Level 1
 
Posts: 6
Joined: Sun Mar 11, 2012 5:42 am

Re: Bluetooth not working on LMDE

Postby negatory on Thu Mar 15, 2012 10:01 am

I updated to the 4th update pack and the problem is still there.

I tried this bluetooth dongle in a mac and in windows and it works perfectly, I'm running out of options at the moment.
negatory
Level 1
Level 1
 
Posts: 6
Joined: Sun Mar 11, 2012 5:42 am

Re: Bluetooth not working on LMDE

Postby I_can_see_the_light on Thu Mar 29, 2012 5:57 am

Does the bluetooth dongle not even show up as a device or is the problem related to connecting to the dongle? I've had problems with bluetooth in CrunchBang (based on Debian Squeeze) but somehow I manged to solve it - I searched through Synaptic and installed a lot of packages related to bluetooth, obex etc.
Fujitsu Siemens Lifebook E8020D (triple booting Ubuntu, CrunchBang & Win 7)

----------
"Don't fix it if it ain't broken,don't break it if you can't fix it" - R.I.P. Husse
I_can_see_the_light
Level 3
Level 3
 
Posts: 100
Joined: Mon Jun 01, 2009 4:08 pm
Location: Luleå, Sweden

Re: Bluetooth not working on LMDE

Postby negatory on Sun Apr 01, 2012 9:38 am

The bluetooth dongle shows up as a device and lists itself as a "Bus 006 Device 002: ID 1310:0001 Roper Class 1 Bluetooth Dongle".

I've been browsing the net and I see some reports that older bluetooth dongles might not work anymore with the newer kernels (https://bugs.launchpad.net/ubuntu/+bug/289836 and https://bugs.launchpad.net/ubuntu/+sour ... bug/268502).

I've had this bluetooth dongle for close to 7 years now...
negatory
Level 1
Level 1
 
Posts: 6
Joined: Sun Mar 11, 2012 5:42 am

Re: Bluetooth not working on LMDE

Postby negatory on Sun Apr 01, 2012 10:07 am

rfkill list showed the device as soft blocked but I managed to unblock it but I still have the same behaviour...

Restarting bluetooth via "sudo /etc/init.d/bluetooth restart" still shows on the syslog:
Code: Select all
Apr  1 15:04:10 zion bluetoothd[5121]: Terminating
Apr  1 15:04:10 zion bluetoothd[5121]: Stopping hci0 event socket
Apr  1 15:04:10 zion bluetoothd[5121]: Stopping SDP server
Apr  1 15:04:10 zion bluetoothd[5121]: Exit
Apr  1 15:04:11 zion bluetoothd[5941]: Bluetooth daemon 4.99
Apr  1 15:04:11 zion bluetoothd[5941]: Starting SDP server
Apr  1 15:04:11 zion bluetoothd[5941]: Failed to init alert plugin
Apr  1 15:04:11 zion bluetoothd[5941]: Failed to init time plugin
Apr  1 15:04:11 zion bluetoothd[5941]: Failed to init gatt_example plugin
Apr  1 15:04:11 zion bluetoothd[5941]: Listening for HCI events on hci0
Apr  1 15:04:11 zion NetworkManager[1833]: <warn> bluez error getting default adapter: No such adapter
Apr  1 15:04:21 zion bluetoothd[5945]: Can't init device hci0: Connection timed out (110)
negatory
Level 1
Level 1
 
Posts: 6
Joined: Sun Mar 11, 2012 5:42 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 5 guests