Atherous AR9001U (Fritz! Wlan N) - detected but no interface

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Atherous AR9001U (Fritz! Wlan N) - detected but no interface

Postby rgx521 on Sat Sep 14, 2013 4:40 pm

Hi everyone,

I am trying to get my wifi stick to work, but can't get the interface to show up in network settings.

Here are some outputs:

Code: Select all
 $ sudo inxi -Fx
System:    Host raindrop Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
CPU:       Quad core Intel Core i5-3570K (-MCP-) cache 6144 KB flags (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips 27230.8
           Clock Speeds: (1) 1600.00 MHz (2) 1600.00 MHz (3) 1600.00 MHz (4) 1600.00 MHz
Graphics:  Card NVIDIA GK104 [GeForce GTX 670] X.org 1.12.4 Res: 213x36 Gfx Data: N/A for root
Audio:     Card-1 NVIDIA GK104 HDMI Audio Controller driver snd_hda_intel BusID: 01:00.1
           Card-2 Intel 7 Series/C210 Series Chipset Family High Definition Audio Controller driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
Network:   Card Atheros AR8151 v2.0 Gigabit Ethernet driver atl1c v: 1.0.1.0-NAPI at port d000 BusID: 05:00.0
Disks:     HDD Total Size: 4128.8GB (0.0% used) 1: /dev/sda SAMSUNG_SSD_830 128.0GB 0C
           2: /dev/sdb SAMSUNG_HD103SI 1000.2GB 37C 3: /dev/sdc ST3000DM001 3000.6GB 49C
Partition: ID:/ size: 289G used: 4.6G (2%) fs: rootfs ID:/ size: 289G used: 4.6G (2%) fs: ext4
           ID:/boot size: 194M used: 28M (15%) fs: ext4 ID:/home size: 606G used: 241M (1%) fs: ext4
           ID:swap-1 size: 25.16GB used: 0.00GB (0%) fs: swap
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:33C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes 147 Uptime 19 min Memory 586.1/12008.8MB Runlevel 2 Client Shell inxi 1.4.23


Code: Select all
$ sudo iwconfig
lo        no wireless extensions.

eth1      no wireless extensions.


Code: Select all
$ sudo iwconfig
$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 046d:c245 Logitech, Inc.
Bus 004 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 006 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 003: ID 05e3:0607 Genesys Logic, Inc. Logitech G110 Hub
Bus 006 Device 003: ID 057c:8401 AVM GmbH Fritz!WLAN N [Atheros AR9001U]
Bus 006 Device 004: ID 058f:6362 Alcor Micro Corp. Flash Card Reader/Writer
Bus 006 Device 005: ID 1781:0898 Multiple Vendors
Bus 004 Device 004: ID 046d:c228 Logitech, Inc.
Bus 004 Device 005: ID 046d:c229 Logitech, Inc.


carl9170 and firmware-atheros both were already installed ootb. The stick immediately works with the mint mainline edition.
What can I do to get it functional?
rgx521
Level 1
Level 1
 
Posts: 1
Joined: Tue Feb 01, 2011 9:05 am

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: No registered users and 3 guests