Slow wireless

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Slow wireless

Postby Zavulon on Thu Jan 23, 2014 4:29 pm

Hello,

I'm a dualbooter, and my wireless is 50% faster on windows than on LMDE (UP7) (did multiple speed tests).

I'm not accepting that! Linux must be equal or better.

I have a intel wireless N1000 and my router is g/n enabled.

What steps can I do to speed up my wireless? The wifi-card can, but Linux isn't using it, what can I do?

I googled but didn't found any solutions. Any guidance, or even an answer is wanted.

Thanks!
Zavulon
Level 1
Level 1
 
Posts: 29
Joined: Fri Jul 22, 2011 1:38 pm

Linux Mint is funded by ads and donations.
 

Re: Slow wireless

Postby killer de bug on Fri Jan 24, 2014 5:02 am

If your wifi connexion is still faster than your internet connexion, I don't see any problem to be honest.

Maybe this problem will be solved with the next kernel update. You will maybe have better drivers...
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1612
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Postby Lingula on Fri Jan 24, 2014 10:08 am

What type of speed tests did you do? What connection speed is your router showing? What's your application level throughput? Channel selection (should be 1, 6,or 11)? Channel width (should be 20MHz unless you are in a rural area)?

Intel wireless is notorious for poor or erratic performance depending on both the driver in the wireless card and the driver on the router. It's sometimes the combination that matters. What driver are you using on the Intel card? What router model and firmware version on the router?

If it's a laptop then you also need to disable any power saving features on the Intel wireless card.
Lingula
Level 4
Level 4
 
Posts: 285
Joined: Tue Apr 23, 2013 12:47 pm

Re: Slow wireless

Postby kurotsugi on Fri Jan 24, 2014 10:58 am

internet on linux is usually faster compared in windows. I'm not sure if will help but this tweak have great impact on my system:
Code: Select all
kernel.sysrq = 1
kernel.random.read_wakeup_threshold=256
kernel.random.write_wakeup_threshold=512
kernel.sched_latency_ns=20000000
kernel.sched_min_granularity_ns = 10000000
kernel.sched_wakeup_granularity_ns = 15000000
# kernel.sched_shares_ratelimit=256000
# kernel.sched_sched_compat_yield=1
kernel.shmmax=268435456
kernel.shmmni=4096
kernel.shmall=2097152
kernel.msgmni=4096
kernel.msgmax=65536
kernel.randomize_va_space=1
#kernel.pid_max=65536
kernel.kptr_restrict=1
kernel.sem=250 32000 100 128
kernel.printk_ratelimit_burst = 10
kernel.printk_ratelimit=5
kernel.panic=30
kernel.panic_on_oops=30
kernel.maps_protect=1
kernel.msgmnb=65536

fs.inotify.max_queued_events=32000
fs.inotify.max_user_instances=256
fs.inotify.max_user_watches=10240
fs.protected_hardlinks=1
fs.protected_symlinks=1

vm.swappiness=10
vm.dirty_expire_centisecs=1000
vm.dirty_ratio=90
vm.dirty_background_ratio=75
vm.min_free_kbytes=10240
vm.dirty_writeback_centisecs=3000
vm.vfs_cache_pressure=50
vm.max map count=65535
vm.max-readahead=256
vm.min-readahead=128

# experimental stuff. not suitable for droids
#vm.dirty_background_bytes=4194304
#vm.dirty_bytes = 4194304
#vm.overcommit_ratio = 0
#vm.overcommit_memory = 0

net.ipv4.ip_local_port_range = 2000 65000
net.ipv4.ip_forward=0
net.ipv4.ip_dynaddr=0
net.ipv4.ip_no_pmtu_disc=0
net.ipv4.ipfrag_secret_interval=6000
net.ipv4.conf.lo.rp_filter = 1
net.ipv4.conf.lo.accept_redirects = 1
net.ipv4.conf.lo.accept_source_route = 1
net.ipv4.conf.all.rp_filter = 1
net.ipv4.conf.all.accept_redirects = 1
net.ipv4.conf.all.accept_source_route=1
net.ipv4.conf.all.secure_redirects=1
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.default.accept_source_route=1
net.ipv4.conf.default.accept_redirects=1
net.ipv4.conf.default.secure_redirects=1
net.ipv4.conf.all.log_martians = 0
net.ipv4.conf.lo.log_martians = 0
net.ipv4.icmp_echo_ignore_broadcasts = 1
net.ipv4.icmp_ignore_bogus_error_responses = 1
net.ipv4.icmp_echo_ignore_all=1
net.ipv4.tcp_mtu_probi=1
net.ipv4.tcp_keepalive_time = 1800
net.ipv4.tcp_keepalive_probes=5
net.ipv4.tcp_keepalive_intvl=30
net.ipv4.tcp_synack_retries=3
net.ipv4.tcp_syn_retries=3
net.ipv4.tcp_timestamps = 1
net.ipv4.tcp_syncookies = 1
net.ipv4.tcp_max_syn_backlog = 1024
net.ipv4.tcp_max_tw_buckets = 1440000
net.ipv4.tcp_orphan_retries = 1
net.ipv4.tcp_congestion_control=cubic
net.ipv4.tcp_rfc1337 = 1
net.ipv4.tcp_ecn = 0
net.ipv4.tcp_tw_reuse=1
net.ipv4.tcp_tw_recycle=1
net.ipv4.tcp_fack=1
net.ipv4.tcp_sack=1
net.ipv4.tcp_dsack=1
net.ipv4.tcp_window_scaling=1
net.ipv4.tcp_fin_timeout=20
net.ipv4.tcp_moderate_rcvbuf=1
net.ipv4.tcp_mem=524288 524288 524288
net.ipv4.tcp_wmem=10240 87380 16777216
net.ipv4.tcp_rmem=10240 87380 16777216
net.ipv4.tcp_no_metrics_save = 1
net.ipv4.tcp_moderate_rcvbuf = 1
net.ipv4.tcp_no_metrics_save=1
net.ipv4.tcp_workaround_signed_windows=1
net.ipv4.tcp_low_latency=1
net.ipv4.tcp_mtu_probing=1
net.ipv4.tcp_frto=2
net.ipv4.tcp_frto_response=2
net.ipv4.udp_rmem_min=6144
net.ipv4.udp_wmem_min=6144
net.core.rmem_max=16777216
net.core.wmem_max=16777216
net.core.rmem_default=16777216
net.core.wmem_default=16777216
net.core.optmem_max=20480
net.core.netdev_max_backlog=5000
net.core.somaxconn=65000
net.core.dev_weight=64
net.unix.max_dgram_qlen=50
net.ipv4.neigh.default.gc_thresh3=2048
net.ipv4.neigh.default.gc_thresh2=1024
net.ipv4.neigh.default.gc_thresh1=32
net.ipv4.neigh.default.gc_interval=30
net.ipv4.neigh.default.proxy_qlen=96
net.ipv4.neigh.default.unres_qlen=6
#sunrpc.tcp_slot_table_entries=32
#sunrpc.udp_slot_table_entries=32
copy the content to /etc/sysctl.conf then run 'sudo sysctl -p' to activate it.
kurotsugi
Level 5
Level 5
 
Posts: 890
Joined: Fri Jan 25, 2013 3:54 am

Postby Lingula on Fri Jan 24, 2014 11:05 am

Those settings are mostly default. Some of the others will improve bulk file transfer and speedtest.net performance but will increase latency under load. (bufferbloat.net has some good explanations of the issue) Some may be useful or harmful depending on the desired result. Before jumping into "TCP tuning", the basics should be reviewed.
Lingula
Level 4
Level 4
 
Posts: 285
Joined: Tue Apr 23, 2013 12:47 pm

Re: Slow wireless

Postby Zavulon on Fri Jan 24, 2014 1:22 pm

Thanks for the replies! I will investigate further.

Both in Windows (IE11) and in Linux (FF26), I use http://speedtest.telenet.be/ (my ISP)

Several tests on both platform, allways indicate the same thing, my connection in windows is 50% faster. Since Both use my intel wifi, I put the fault on my wifi-card not functioning properly under linux.

I jususe the standard wifi driver/config that came with LMDE UP7.

The suggestion to turn off power savings is great, allthough I can't find these settings.
I'll try the tip by kurotsugi asap.

Thanks!
Zavulon
Level 1
Level 1
 
Posts: 29
Joined: Fri Jul 22, 2011 1:38 pm

Postby Lingula on Fri Jan 24, 2014 3:54 pm

You can temporarily disable wireless power saving for testing purposes with:
sudo iwconfig wlan0 power off
This assumes your wifi card is wlan0. You can check with iwconfig

Some Intel drivers also misbehave in 802.11n mode, and run better in 802.11g. I can't remember the command, but you can temporarily disable n.
Lingula
Level 4
Level 4
 
Posts: 285
Joined: Tue Apr 23, 2013 12:47 pm

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: No registered users and 1 guest