Netgear A6200 wi-fi on Linux Mint (LMDE)

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Netgear A6200 wi-fi on Linux Mint (LMDE)

Postby jlgalley on Sat Feb 08, 2014 12:11 pm

I just converted an old PC to Linux Mint (LMDE), and I am trying to get my Netgear A6200 wi-fi adapter to work on it. I know that this device isn't natively supported in Linux, but I read that users have got it going for Ubuntu and Linux Mint 14. I tried to do the same steps, but haven't had success.

1) I ran the Windows driver CD via WINE and installed the drivers. After copying the driver files to my hard disk, the installer halted with an error about a DLL. "DLL function call crashed: Install.EnumerateDevice." I was expecting this, based on the info on the Netgear forum I linked to above.
2) I tried to use ndiswrapper to install the driver. I got an error that I can't find any information about: couldn't find section "common.prevista.reg"

Code: Select all
jacob@mintyfresh /proc/4924/fd/4/drive_c/Program Files/NETGEAR/A6200/Drivers $ sudo ndiswrapper -i bcmwlhigh5.inf
[sudo] password for jacob:
installing bcmwlhigh5 ...
couldn't find section "common.prevista.reg" -
installation may be incomplete
couldn't find install directive: -----------------------------------------------------------------
jacob@mintyfresh /proc/4924/fd/4/drive_c/Program Files/NETGEAR/A6200/Drivers $ sudo ndiswrapper -l
bcmwlhigh5 : driver installed
   device (0846:9050) present
jacob@mintyfresh ~/A6200_drivers $ sudo ls -l /etc/ndiswrapper/bcmwlhigh5/
total 1944
-rw-r--r-- 1 root root    1179 Feb  8 10:07 0846:9050.F.conf
-rw-r--r-- 1 root root   46028 Feb  8 10:07 bcmwlhigh5.inf
-rw-r--r-- 1 root root 1936128 Feb  8 10:07 bcmwlhigh5.sys


Below are my system specs:

Code: Select all
jacob@mintyfresh /proc/4924/fd/4/drive_c/Program Files/NETGEAR/A6200/Drivers $ inxi -Fx
System:    Host mintyfresh Kernel 3.10-2-486 i686 (32 bit) Distro LinuxMint 1 debian
CPU:       Single core AMD Duron (-UP-) cache 64 KB flags (sse) bmips 3597.13 clocked at 1798.567 MHz
Graphics:  Card-1 NVIDIA NV44A [GeForce 6200] Card-2 VIA KM400/KN400/P4M800 [S3 UniChrome] X.Org 1.12.4 Res: 1920x1080@60.0hz
           GLX Renderer Gallium 0.4 on NV4A GLX Version 2.1 Mesa 9.1.6 Direct Rendering Yes
Audio:     Card VIA VT8233/A/8235/8237 AC97 Audio Controller driver snd_via82xx at port e000 BusID: 00:11.5
           Sound: Advanced Linux Sound Architecture Version k3.10-2-486
Network:   Card VIA VT6102 [Rhine-II] driver via-rhine at port e400 BusID: 00:12.0
Disks:     HDD Total Size: 40.0GB (16.2% used) 1: /dev/sda ST340014A 40.0GB 30C
Partition: ID:/ size: 37G used: 6.1G (18%) fs: ext4
Sensors:   System Temperatures: cpu: 46.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes 132 Uptime 1:15 Memory 624.1/1232.2MB Runlevel 2 Client Shell inxi 1.4.23
jlgalley
Level 1
Level 1
 
Posts: 18
Joined: Sat Feb 08, 2014 11:31 am

Linux Mint is funded by ads and donations.
 

Re: Netgear A6200 wi-fi on Linux Mint (LMDE)

Postby jlgalley on Sun Feb 09, 2014 2:08 pm

This error still occurs after I upgraded to LMDE Update Pack 8.
jlgalley
Level 1
Level 1
 
Posts: 18
Joined: Sat Feb 08, 2014 11:31 am

Re: Netgear A6200 wi-fi on Linux Mint (LMDE)

Postby jlgalley on Sun Feb 16, 2014 11:17 am

I returned this Netgear card to Best Buy. Done with this inquiry.
jlgalley
Level 1
Level 1
 
Posts: 18
Joined: Sat Feb 08, 2014 11:31 am


Return to Wireless

Who is online

Users browsing this forum: No registered users and 2 guests