problem wireless: ralink RT2500

Questions about WIFI networks and devices
Forum rules
Before you post please read this

problem wireless: ralink RT2500

Postby macin on Fri Sep 02, 2011 11:35 am

Hi! I've got a problem with wireless. My wireless card is ralink RT2500. It seems all things work fine:
Code: Select all
camillo@benq-r23e ~ $ sudo lspci | grep Network
[sudo] password for camillo:
00:0a.0 Network controller: Ralink corp. RT2500 802.11g (rev 01)

camillo@benq-r23e ~ $ sudo iwconfig
lo        no wireless extensions.

eth1      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
         
camillo@benq-r23e ~ $ sudo ifconfig
eth1      Link encap:Ethernet  HWaddr 00:40:d0:8e:36:ae 
          inet addr:192.168.1.3  Bcast:192.168.1.63  Mask:255.255.255.192
          inet6 addr: fe80::240:d0ff:fe8e:36ae/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3692 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3032 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3784142 (3.6 MiB)  TX bytes:403741 (394.2 KiB)
          Interrupt:23 Base address:0xe200

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:10:60:65:5e:5b 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

camillo@benq-r23e ~ $ lsmod | grep rt2500
rt2500pci              17762  0
rt2x00pci              12683  1 rt2500pci
rt2x00lib              28600  2 rt2500pci,rt2x00pci
eeprom_93cx6           12423  1 rt2500pci

but when I attempt to connect with network manager applet, after a while, I receive the message that connection was interrupted. Here dmesg:
Code: Select all
[   76.634080] wlan0: direct probe to 00:24:89:13:d4:e5 (try 1/3)
[   76.832085] wlan0: direct probe to 00:24:89:13:d4:e5 (try 2/3)
[   76.835384] wlan0: direct probe responded
[   76.835408] wlan0: authenticate with 00:24:89:13:d4:e5 (try 1)
[   76.837304] wlan0: authenticated
[   76.838004] wlan0: associate with 00:24:89:13:d4:e5 (try 1)
[   76.840004] wlan0: RX AssocResp from 00:24:89:13:d4:e5 (capab=0x411 status=0 aid=2)
[   76.840060] wlan0: associated
[   76.841750] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   76.965778] Intel AES-NI instructions are not detected.
[   76.975097] padlock_aes: VIA PadLock not detected.
[   80.332074] ieee80211 phy0: wlan0: No probe response from AP 00:24:89:13:d4:e5 after 500ms, disconnecting.
[   80.333153] cfg80211: Calling CRDA to update world regulatory domain
[   81.570784] wlan0: authenticate with 00:24:89:13:d4:e5 (try 1)
[   81.572345] wlan0: authenticated
[   81.572407] wlan0: associate with 00:24:89:13:d4:e5 (try 1)
[   81.574616] wlan0: RX AssocResp from 00:24:89:13:d4:e5 (capab=0x411 status=0 aid=2)
[   81.574627] wlan0: associated
[   85.336089] ieee80211 phy0: wlan0: No probe response from AP 00:24:89:13:d4:e5 after 500ms, disconnecting.
[   85.337062] cfg80211: Calling CRDA to update world regulatory domain
[   86.582448] wlan0: authenticate with 00:24:89:13:d4:e5 (try 1)
[   86.583940] wlan0: authenticated
[   86.583994] wlan0: associate with 00:24:89:13:d4:e5 (try 1)
[   86.586321] wlan0: RX AssocResp from 00:24:89:13:d4:e5 (capab=0x411 status=0 aid=2)
[   86.586332] wlan0: associated
[   86.928049] wlan0: no IPv6 routers present
[   90.336073] ieee80211 phy0: wlan0: No probe response from AP 00:24:89:13:d4:e5 after 500ms, disconnecting.
[   90.337034] cfg80211: Calling CRDA to update world regulatory domain
[   91.582375] wlan0: authenticate with 00:24:89:13:d4:e5 (try 1)
[   91.584483] wlan0: authenticated
[   91.584552] wlan0: associate with 00:24:89:13:d4:e5 (try 1)
[   91.586909] wlan0: RX AssocResp from 00:24:89:13:d4:e5 (capab=0x411 status=0 aid=2)
[   91.586917] wlan0: associated
[   95.336140] ieee80211 phy0: wlan0: No probe response from AP 00:24:89:13:d4:e5 after 500ms, disconnecting.
[   95.337098] cfg80211: Calling CRDA to update world regulatory domain
[   96.574441] wlan0: authenticate with 00:24:89:13:d4:e5 (try 1)
[   96.576357] wlan0: authenticated
[   96.577055] wlan0: associate with 00:24:89:13:d4:e5 (try 1)
[   96.579059] wlan0: RX AssocResp from 00:24:89:13:d4:e5 (capab=0x411 status=0 aid=2)
[   96.579066] wlan0: associated
[  100.336078] ieee80211 phy0: wlan0: No probe response from AP 00:24:89:13:d4:e5 after 500ms, disconnecting.
[  100.337050] cfg80211: Calling CRDA to update world regulatory domain
[  101.582897] wlan0: authenticate with 00:24:89:13:d4:e5 (try 1)
[  101.585549] wlan0: authenticated
[  101.585637] wlan0: associate with 00:24:89:13:d4:e5 (try 1)
[  101.587667] wlan0: RX AssocResp from 00:24:89:13:d4:e5 (capab=0x411 status=0 aid=2)
[  101.587680] wlan0: associated
[  105.336083] ieee80211 phy0: wlan0: No probe response from AP 00:24:89:13:d4:e5 after 500ms, disconnecting.
[  105.337022] cfg80211: Calling CRDA to update world regulatory domain
[  106.585040] wlan0: authenticate with 00:24:89:13:d4:e5 (try 1)
[  106.586541] wlan0: authenticated
[  106.586611] wlan0: associate with 00:24:89:13:d4:e5 (try 1)
[  106.588861] wlan0: RX AssocResp from 00:24:89:13:d4:e5 (capab=0x411 status=0 aid=2)
[  106.588872] wlan0: associated
[  110.336098] ieee80211 phy0: wlan0: No probe response from AP 00:24:89:13:d4:e5 after 500ms, disconnecting.
[  110.337059] cfg80211: Calling CRDA to update world regulatory domain
[  111.582509] wlan0: authenticate with 00:24:89:13:d4:e5 (try 1)
[  111.583968] wlan0: authenticated
[  111.584367] wlan0: associate with 00:24:89:13:d4:e5 (try 1)
[  111.586393] wlan0: RX AssocResp from 00:24:89:13:d4:e5 (capab=0x411 status=0 aid=2)
[  111.586402] wlan0: associated
[  115.336475] ieee80211 phy0: wlan0: No probe response from AP 00:24:89:13:d4:e5 after 500ms, disconnecting.
[  115.337460] cfg80211: Calling CRDA to update world regulatory domain
[  116.585079] wlan0: authenticate with 00:24:89:13:d4:e5 (try 1)
[  116.586578] wlan0: authenticated
[  116.586649] wlan0: associate with 00:24:89:13:d4:e5 (try 1)
[  116.588902] wlan0: RX AssocResp from 00:24:89:13:d4:e5 (capab=0x411 status=0 aid=2)
[  116.588914] wlan0: associated
[  120.336092] ieee80211 phy0: wlan0: No probe response from AP 00:24:89:13:d4:e5 after 500ms, disconnecting.
[  120.337057] cfg80211: Calling CRDA to update world regulatory domain
[  121.584916] wlan0: authenticate with 00:24:89:13:d4:e5 (try 1)
[  121.586414] wlan0: authenticated
[  121.586486] wlan0: associate with 00:24:89:13:d4:e5 (try 1)
[  121.588892] wlan0: RX AssocResp from 00:24:89:13:d4:e5 (capab=0x411 status=0 aid=2)
[  121.588904] wlan0: associated
[  122.224392] wlan0: deauthenticating from 00:24:89:13:d4:e5 by local choice (reason=3)
[  122.272496] cfg80211: Calling CRDA to update world regulatory domain

With Ubuntu (same configuration) I've not got problems.
Thank you!
macin
Level 1
Level 1
 
Posts: 4
Joined: Fri Sep 02, 2011 11:12 am

Linux Mint is funded by ads and donations.
 

Re: problem wireless: ralink RT2500

Postby macin on Fri Sep 02, 2011 5:10 pm

It could be a bug?
macin
Level 1
Level 1
 
Posts: 4
Joined: Fri Sep 02, 2011 11:12 am


Return to Wireless

Who is online

Users browsing this forum: No registered users and 1 guest