[SOLVED]Cannot enable Wireless on Sony Vaio VPCEL15EN

Questions about WIFI networks and devices
Forum rules
Before you post please read this

[SOLVED]Cannot enable Wireless on Sony Vaio VPCEL15EN

Postby livram79 on Sat Nov 05, 2011 8:46 am

I have just installed LMDE 2011.09 on one of my friend's Sony Vaio VPCEL15EN. I cannot enable the wireless in the Network Manager.
this is the output of inxi -N:
Code: Select all
Network:   Card-1 Atheros AR9285 Wireless Network Adapter (PCI-Express) driver ath9k
           Card-2 Atheros AR8151 v2.0 Gigabit Ethernet driver atl1c

The package firmware-atheros is installed.
Output of iwconfig:
Code: Select all
lo        no wireless extensions.

eth1      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on

Output lsmod |grep ath9k:
ath9k 72843 0
mac80211 182631 1 ath9k
ath9k_common 12682 1 ath9k
ath9k_hw 261156 2 ath9k,ath9k_common
ath 21453 2 ath9k,ath9k_hw
cfg80211 132564 3 ath9k,mac80211,ath

Can somebody help my friend?
Last edited by livram79 on Sun Nov 06, 2011 5:35 am, edited 1 time in total.
livram79
Level 2
Level 2
 
Posts: 87
Joined: Sat Jun 06, 2009 7:26 am
Location: romania

Linux Mint is funded by ads and donations.
 

Re: Cannot enable Wireless on Sony Vaio VPCEL15EN

Postby lebigouden on Sat Nov 05, 2011 3:03 pm

Is there a physical switch or hotkey to enable the wifi , if yes is it working?
You could also try:
sudo rfkill unblock wifi
And see if that enable wireless then.
lebigouden
Level 1
Level 1
 
Posts: 12
Joined: Mon Oct 31, 2011 6:18 am

Re: Cannot enable Wireless on Sony Vaio VPCEL15EN

Postby livram79 on Sun Nov 06, 2011 4:31 am

lebigouden wrote:Is there a physical switch or hotkey to enable the wifi , if yes is it working?
You could also try:
sudo rfkill unblock wifi
And see if that enable wireless then.


Thank you for your reply.
The switch turns on/off the wireless but when the wireless is turned on I still cannot enable it in Network Manager. It looks as in the picture attached below (please see the picture). So, when I try to enable it with right-click on it nothing happens.
What can cause this problem?

Can it be because of the acer-wireless?
0: acer-wireless: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
2: sony-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
3: sony-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
4: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

What to do?
Attachments
Screenshot.png
Screenshot.png (42.66 KiB) Viewed 5846 times
livram79
Level 2
Level 2
 
Posts: 87
Joined: Sat Jun 06, 2009 7:26 am
Location: romania

Re: Cannot enable Wireless on Sony Vaio VPCEL15EN

Postby livram79 on Sun Nov 06, 2011 5:34 am

OK. The problem is SOLVED. There was a conflict between ath9k driver and acer_wmi.
The solution was to blacklist acer_wmi.
You need to edit /etc/modprobe.d./blacklist.conf, add blacklist acer_wmi in that file and restart computer.
livram79
Level 2
Level 2
 
Posts: 87
Joined: Sat Jun 06, 2009 7:26 am
Location: romania

Re: [SOLVED]Cannot enable Wireless on Sony Vaio VPCEL15EN

Postby lebigouden on Sun Nov 06, 2011 5:44 am

Nicely done Livram :) .

Hope your friend will enjoy lmde, on this type of netbook it is a far more suitable OS than windows 7.
lebigouden
Level 1
Level 1
 
Posts: 12
Joined: Mon Oct 31, 2011 6:18 am


Return to Wireless

Who is online

Users browsing this forum: No registered users and 2 guests