[SOLVED] Lenovo u160 wifi problem on LMDE 201109 Gnome

Questions about WIFI networks and devices
Forum rules
Before you post please read this

[SOLVED] Lenovo u160 wifi problem on LMDE 201109 Gnome

Postby zimmers on Sun Dec 04, 2011 3:49 pm

hi all,

i'm comming from ubuntu and have some truble to get my wifi up an running. hope to get some help here.
here are some outputs.

sudo /usr/lib/linuxmint/mintWifi/mintWifi.py
Code: Select all
-------------------------
* I. scanning WIFI PCI devices...
  -- Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
      ==> PCI ID = 14e4:4727 (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
lo        no wireless extensions.

eth1      no wireless extensions.

-------------------------
* IV. querying ifconfig...
eth1      Link encap:Ethernet  Hardware Adresse f0:de:f1:22:f1:9f 
          inet Adresse:192.168.178.30  Bcast:192.168.178.255  Maske:255.255.255.0
          inet6-Adresse: fe80::f2de:f1ff:fe22:f19f/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:39 errors:0 dropped:0 overruns:0 frame:0
          TX packets:93 errors:0 dropped:0 overruns:0 carrier:1
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:16922 (16.5 KiB)  TX bytes:13613 (13.2 KiB)
          Interrupt:43

lo        Link encap:Lokale Schleife 
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metrik:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)

-------------------------
* V. querying DHCP...
Reloading /etc/samba/smb.conf: smbd only.
RTNETLINK answers: File exists
Stopping NTP server: ntpd.
Starting NTP server: ntpd.
-------------------------
* VI. querying nslookup google.com...
Server:      192.168.178.1
Address:   192.168.178.1#53

Non-authoritative answer:
Name:   google.com
Address: 74.125.43.105
Name:   google.com
Address: 74.125.43.99
Name:   google.com
Address: 74.125.43.103
Name:   google.com
Address: 74.125.43.104
Name:   google.com
Address: 74.125.43.106
Name:   google.com
Address: 74.125.43.147


sudo rfkill list all
Code: Select all
 
0: ideapad_wlan: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: ideapad_bluetooth: Bluetooth
   Soft blocked: no
   Hard blocked: no
2: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no
3: acer-wireless: Wireless LAN
   Soft blocked: yes
   Hard blocked: no


sudo ifconfig
Code: Select all
eth1      Link encap:Ethernet  Hardware Adresse f0:de:f1:22:f1:9f 
          inet Adresse:192.168.178.30  Bcast:192.168.178.255  Maske:255.255.255.0
          inet6-Adresse: fe80::f2de:f1ff:fe22:f19f/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:3311 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3209 errors:0 dropped:0 overruns:0 carrier:1
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:2142608 (2.0 MiB)  TX bytes:375002 (366.2 KiB)
          Interrupt:43

lo        Link encap:Lokale Schleife 
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metrik:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)


sudo iwconfig
Code: Select all
lo        no wireless extensions.

eth1      no wireless extensions.


well, there is no wireless interface...

greetings
Last edited by zimmers on Mon Dec 05, 2011 4:34 am, edited 1 time in total.
zimmers
Level 1
Level 1
 
Posts: 5
Joined: Sun Dec 04, 2011 3:24 pm
Location: Potsdam/Germany

Linux Mint is funded by ads and donations.
 

Re: Lenovo u160 wifi problem on LMDE 201109 Gnome

Postby soccerz619 on Sun Dec 04, 2011 4:20 pm

Have you had a look here?
It suggests using the STA drivers for the 4313 card, so it says all you should have to do is type the following into a terminal:
Code: Select all
sudo apt-get update
sudo apt-get install bcmwl-kernel-source
And then look here: Under desktop menu System > Administration > Hardware/Additional Drivers, and the STA drivers can be activated for use. You may need to restart your computer after installing them for it to work. Let me know how it turns out
Everyone is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing it is stupid.
Image
User avatar
soccerz619
Level 4
Level 4
 
Posts: 228
Joined: Mon Sep 05, 2011 10:05 pm

Re: Lenovo u160 wifi problem on LMDE 201109 Gnome

Postby zimmers on Sun Dec 04, 2011 4:47 pm

hi soccerz619,

thx for your reply!

are there any aditional sources needed?
getting error: package not found!

also i can't find 'System > Administration > Hardware/Additional Drivers'!

please note that i'm using Linux Mint Debian Edition(LMDE).
zimmers
Level 1
Level 1
 
Posts: 5
Joined: Sun Dec 04, 2011 3:24 pm
Location: Potsdam/Germany

Re: Lenovo u160 wifi problem on LMDE 201109 Gnome

Postby Oscar799 on Sun Dec 04, 2011 5:57 pm

Moved here from the main forum
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8699
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Lenovo u160 wifi problem on LMDE 201109 Gnome

Postby soccerz619 on Sun Dec 04, 2011 6:02 pm

Ah it would help if I would read the main title, huh? Maybe try this link. Or try this one and scroll down to "Using the native linux driver (recommended)". I think that should get you going on LMDE. Sorry I didn't see that to begin with. See if those topics can help you out!
Everyone is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing it is stupid.
Image
User avatar
soccerz619
Level 4
Level 4
 
Posts: 228
Joined: Mon Sep 05, 2011 10:05 pm

Re: Lenovo u160 wifi problem on LMDE 201109 Gnome

Postby zimmers on Mon Dec 05, 2011 4:32 am

hi soccerz619,

dont know why i didnt found the articel on debian wiki.
i only had to install the brcm80211 driver http://wiki.debian.org/brcm80211

like on ubuntu, i have to unblock all & rmmod acer_wmi to get it work, but i can live with it.

Code: Select all
sudo rfkill unblock all
sudo rmmod acer_wmi
sudo rfkill unblock all


many thanks for your help soccerz619!

greetings
zimmers
Level 1
Level 1
 
Posts: 5
Joined: Sun Dec 04, 2011 3:24 pm
Location: Potsdam/Germany

Re: [SOLVED] Lenovo u160 wifi problem on LMDE 201109 Gnome

Postby soccerz619 on Mon Dec 05, 2011 6:13 am

It's ok, you got it figured out and that's the important thing. Do you have to do that every time you start up your computer? If so, you can make it a script and add it to your startup programs so that you don't manually have to do it all the time.
Everyone is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing it is stupid.
Image
User avatar
soccerz619
Level 4
Level 4
 
Posts: 228
Joined: Mon Sep 05, 2011 10:05 pm

Re: [SOLVED] Lenovo u160 wifi problem on LMDE 201109 Gnome

Postby zimmers on Mon Dec 05, 2011 6:58 am

yes, have to do it on every start up.
already tried to blacklist acer_wmi, but it seems to initialise something needed.
zimmers
Level 1
Level 1
 
Posts: 5
Joined: Sun Dec 04, 2011 3:24 pm
Location: Potsdam/Germany

Re: [SOLVED] Lenovo u160 wifi problem on LMDE 201109 Gnome

Postby zimmers on Mon Dec 05, 2011 7:05 am

ok, figuered out how to add a start up script, have not thought that it is that easy! :-)

Code: Select all
sudo touch /etc/init.d/my_wlan
sudo editor /etc/init.d/my_wlan


added the following code
Code: Select all
#! /bin/sh
# /etc/init.d/my_wlan
#

rfkill unblock all
rmmod acer_wmi
rfkill unblock all


Code: Select all
sudo chmod 755 /etc/init.d/my_wlan
sudo update-rc.d my_wlan defaults


now every thing works fine!

thanks for all the help!
zimmers
Level 1
Level 1
 
Posts: 5
Joined: Sun Dec 04, 2011 3:24 pm
Location: Potsdam/Germany

Re: [SOLVED] Lenovo u160 wifi problem on LMDE 201109 Gnome

Postby soccerz619 on Mon Dec 05, 2011 7:09 am

Perfect! Glad to hear. Sorry it's more of a work around than a solution. But it works!
Everyone is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing it is stupid.
Image
User avatar
soccerz619
Level 4
Level 4
 
Posts: 228
Joined: Mon Sep 05, 2011 10:05 pm

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: No registered users and 1 guest