[Solved] Broadcom Wireless Devices working in LMDE

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Important information

[Solved] Broadcom Wireless Devices working in LMDE

Postby simonz on Mon Dec 19, 2011 3:58 pm

I had a lot of trouble getting wireless (Dell 1390 a/g wifi adaptor [BCM 4311] ) running under Linux Mint Debian Edition 11 (LMDE) but after many hours of research and trial and error, I found a solution using ndiswrapper, that works on my installation. This problem with Dell (Broadcom) wireless drivers has given me headaches since 2008 when I first start using linux as a primary OS.

I tried another solution which called for using different repositories and it messed up my installation so bad that I had to reinstall LMDE.

Background information: the drivers for Broadcom wireless devices seem to have a conflict with the Broadcom B44 Module (for Ethernet) both which have a dependency on SSB module. So a work around, at boot time, is to unload (rmmod) the Broadcom modules add then add (modprobe) them back in an order that will allow all the Broadcom modules to work together. Another issue I discovered it that the module ndiswrapper.ko is not installed (in my version of LMDE) and needs to be recompiled and installed.

I used these procedures to get WiFi working on a newly installed LMDE system. These notes are from memory, so there may be some errors if you try my steps with copy and paste.

0. From software update app, make sure everything is up to date and reboot if changes are made.

1. From Synaptic, complete remove all ndiswrapper related package (may be optional?).

2. From Synaptic (or sudo apt-get install) , ndiswrapper, mintWifi, ndisgdk, ndiswrapper-source packages.

3. Recompile and install ndiswrapper (module) from source.
A. cd /usr/src/ndiswrapper-1.56+r2729 (varies with version) ## This is the top level directory for ndiswrapper source.
B. sudo make clean ## removes unneeded files
C. sudo make ## builds ndiswrapper in top level directory where source live
D. sudo make install ## correctly installs the ndiswrapper kernel module
E. sudo reboot
[note: it is possible the ndiswrapper.ko needs to be rebuilt with every update to linux kernel - unknown at this time]

4. cd /usr/lib/linuxmint/mintWifi/drivers/i386/Dell_bcmwl5 ## will be different for x64 systems.
sudo ndiswrapper -l ## List the ndiswrapper drivers previously installed.
sudo ndiswrapper -r <old driver> ## Remove previously installed ndiswrapper drivers.
sudo ndiswrapper -i bcmwl5.inf ## This should report no errors.
[note: The app at System-->Administration-->Windows WirelessDrivers supposedly does the same as this step]

5. Make modifications (add lines at bottom) to /etc/init.d/rc.local as below
[note: do not rename to old version of rc.local in the /etc/init.d directory as it could cause a duplicate service]

6. Reboot

7. Wireless and wired networks should now show in Network Manager.

19-Dec-2011: Worked on Dell Vostro 1700 Laptop, Running Linux Mint Debian Edition 11 (LMDE) with Linux 3.0.0-1-686-pae
with Dell 1390 a/g wireless (BCM 4311)

##### This is my /etc/init.d/rc.local file, just add my modifications from the bottom to your file.

#! /bin/sh
# Provides: rc.local
# Required-Start: $remote_fs $syslog $all
# Required-Stop:
# Default-Start: 2 3 4 5
# Default-Stop:
# Short-Description: Run /etc/rc.local if it exist


. /lib/init/vars.sh
. /lib/lsb/init-functions

do_start() {
if [ -x /etc/rc.local ]; then
[ "$VERBOSE" != no ] && log_begin_msg "Running local boot scripts (/etc/rc.local)"
[ "$VERBOSE" != no ] && log_end_msg $ES
return $ES

case "$1" in
echo "Error: argument '$1' not supported" >&2
exit 3
echo "Usage: $0 start|stop" >&2
exit 3

### Add these lines to end of /etc/init.d/rc.local
rmmod b43
rmmod b44
rmmod ssb
rmmod ndiswrapper

modprobe ndiswrapper
modprobe ssb
modprobe b44
Level 1
Level 1
Posts: 18
Joined: Fri Feb 06, 2009 5:48 pm

Linux Mint is funded by ads and donations.

Return to Wireless

Who is online

Users browsing this forum: No registered users and 1 guest