Networking issue: LMDE refuses to create share in home

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read this

Re: Networking issue: LMDE refuses to create share in home

Postby ckosloff on Tue Mar 22, 2011 11:00 pm

Thanks again for continuing support.
I appreciate that very much.
Sorry about confusion, I thought router could only add one reservation.
Added 192.168.0.116 successfully, but still no name for lmde10.
Firewall was disabled all the time, you told me to do that earlier in the thread.
Installed nmap and all necessary ports are open.
Here is output:
Code: Select all
ckosloff@lmde10 ~ $ sudo nmap -sS -sU -T4 192.168.0.116

Starting Nmap 5.00 ( http://nmap.org ) at 2011-03-22 22:44 EDT
Interesting ports on 192.168.0.116:
Not shown: 1990 closed ports
PORT     STATE         SERVICE
22/tcp   open          ssh
111/tcp  open          rpcbind
139/tcp  open          netbios-ssn
445/tcp  open          microsoft-ds
68/udp   open|filtered dhcpc
111/udp  open|filtered rpcbind
137/udp  open|filtered netbios-ns
138/udp  open|filtered netbios-dgm
631/udp  open|filtered ipp
5353/udp open|filtered zeroconf

Nmap done: 1 IP address (1 host up) scanned in 1.59 seconds


Regarding the computer with main edition (Julia-Pavilion), after disabling firewall it did show smbtree, correct workgroup, and (finally!) LMDE10 (in caps) lmde10 server.
With following error:
cli_start_connection: failed to connect to LMDE10<20> (0.0.0.0). Error NT_STATUS_UNSUCCESSFUL.
Eagerly awaiting further instructions.
ckosloff
Level 3
Level 3
 
Posts: 151
Joined: Tue Jul 21, 2009 8:54 pm

Linux Mint is funded by ads and donations.
 

Re: Networking issue: LMDE refuses to create share in home

Postby altair4 on Wed Mar 23, 2011 6:48 am

Make sure you can still connect to the LMDE10 machine from Juila-Pavilion by ip address:
Code: Select all
nautilus smb://192.168.0.116


Then do the same thing you did to the Debian machine on the Julia machine:
Edit smb.conf as root:
Code: Select all
gksu gedit /etc/samba/smb.conf

Add the following line to the [global] section:
Code: Select all
name resolve order = bcast host lmhost wins

Save the file and then restart samba:
Code: Select all
sudo service smbd restart


If you still can't browse to the LMDE machine from Juila then add a line to /etc/hosts that connects the ip address of lmde to lmde10:
edit /etc/hosts as root in Julia-Pavilion:
Code: Select all
gksu gedit /etc/hosts

At the very top will be two lines, for example:
127.0.0.1 localhost
127.0.1.1 altair

Add another line under the 127.0.1.1 line connecting the other machine to an ip address:
Code: Select all
192.168.0.116  lmde10
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5521
Joined: Tue Feb 03, 2009 10:27 am

Re: Networking issue: LMDE refuses to create share in home

Postby ckosloff on Thu Mar 24, 2011 12:21 am

I did not need to edit the hosts file.
Finally got to lmde10 by name, hooray!
But...router still does not give this computer a name and did not take reservation I made for its IP, it assigned it another IP, I made a reservation again with the new IP, let's see what gives.
Anyway, I don't care much about that because I can browse to it by name, the rest is router stuff.
Yes, the always broadcast button is checked, always was, I think it is default.
Also, I can see Windows shares and those machines can see Linux shares.
Except for Vista computers, which pester me with password, but that is Windoze stuff.
I still have some questions:
do I have to have firewall disabled for samba to work?
or should I set some rules there?
From the IRC channel I got this suggestion, enable location bar in Nautilus with:
gconftool-2 --type=Boolean --set /apps/nautilus/preferences/always_use_location_entry true
That way I do not need to use terminal, just type smb://etc. in location bar.
I am so happy with samba now, I will have to go more in depth into networking.
Thank you so much!
ckosloff
Level 3
Level 3
 
Posts: 151
Joined: Tue Jul 21, 2009 8:54 pm

Re: Networking issue: LMDE refuses to create share in home

Postby GregE on Thu Mar 24, 2011 2:08 am

I have a Billion router and Debain machines never have names in the DHCP table. I run a home network with an Ubuntu multimedia PC, two Android phones, one XP machine in wife's office, daughter's Ubuntu machine and an Xubuntu notebook. I also have a NAS attached that uses Samba for sharing. The all appear named in the router.

I have a Debian Testing computer I use for torturing with things I do not want to try on my main computer, and my main computer runs LMDE. Neither of these machines show names in the DHCP table, yet their network addresses are there with blank names. All my simple Samba shares work happily between the different OSs and the two Debian machines do show names when you access them from the other computers.

I have never tried to solve this as it is a non-issue. I guess the thing to note is that it is not your router at fault.
User avatar
GregE
Level 4
Level 4
 
Posts: 441
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: Networking issue: LMDE refuses to create share in home

Postby GregE on Thu Mar 24, 2011 2:16 am

I used this guide to configure UFW for Samba. It was written for Ubuntu but it seems to work for LMDE as well.

http://www.ghacks.net/2010/12/29/allow- ... -with-ufw/

cheers
User avatar
GregE
Level 4
Level 4
 
Posts: 441
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: Networking issue: LMDE refuses to create share in home

Postby altair4 on Thu Mar 24, 2011 8:05 am

I still have some questions:
do I have to have firewall disabled for samba to work?
or should I set some rules there?

I don't use a firewall on most of my machines because I'm behind a router and all of my assets except one are desktops. On the laptop I have enabled one and this is what I did to make it work. I don't know what firewall you are using but for the default ufw firewall this is the procedure I used. Please note I did this quite a while ago and this is from my notes, so ....

[1] Fix something in the default ufw configuration on all your Mint machines:

Edit the file as root:
Code: Select all
gksu gedit /etc/default/ufw

Look at the bottom for these lines:
# extra connection tracking modules to load
IPT_MODULES="nf_conntrack_ftp nf_nat_ftp nf_conntrack_irc nf_nat_irc"

And make the last line look like this:
# extra connection tracking modules to load
IPT_MODULES="nf_conntrack_ftp nf_nat_ftp nf_conntrack_irc nf_nat_irc nf_conntrack_netbios_ns"


[2] On the Julia machine:
Enable the firewall:
Code: Select all
sudo ufw enable

Enable Samba ports on firewall:
Code: Select all
sudo ufw allow Samba

While you're there you might as well enable CUPS - for printing - as well:
Code: Select all
sudo ufw allow CUPS


[3] On the LMDE machine the names are different because ... well .. it's Debian :wink:
Code: Select all
sudo ufw enable
sudo ufw allow CIFS
sudo ufw allow IPP
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5521
Joined: Tue Feb 03, 2009 10:27 am

Re: Networking issue: LMDE refuses to create share in home

Postby altair4 on Thu Mar 24, 2011 8:11 am

From the IRC channel I got this suggestion, enable location bar in Nautilus with:
gconftool-2 --type=Boolean --set /apps/nautilus/preferences/always_use_location_entry true
That way I do not need to use terminal, just type smb://etc. in location bar.

You can also do this:
Open a terminal like you have been doing:
Code: Select all
nautilus smb://xxx.xxx.xx.xxx

When Nautilus opens up Bookmark it: Bookmarks > Add Bookmark

It will show up under "Places" on the left side panel just like a "mapped drive" does In Windows. You can also rename it there is you wish.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5521
Joined: Tue Feb 03, 2009 10:27 am

Re: Networking issue: LMDE refuses to create share in home

Postby ckosloff on Thu Mar 24, 2011 9:44 pm

GregE wrote:I have never tried to solve this as it is a non-issue. I guess the thing to note is that it is not your router at fault.

Thanks for that, although it is intriguing why Debian machines act like that.
ckosloff
Level 3
Level 3
 
Posts: 151
Joined: Tue Jul 21, 2009 8:54 pm

Re: Networking issue: LMDE refuses to create share in home

Postby ckosloff on Thu Mar 24, 2011 9:56 pm

GregE wrote:I used this guide to configure UFW for Samba. It was written for Ubuntu but it seems to work for LMDE as well.
http://www.ghacks.net/2010/12/29/allow- ... -with-ufw/
cheers

Thanks for posting.
GUI instructions work like a charm in Ubuntu, but not at all in Debian, there are no such pre-configured options, guess I will have to use terminal.
ckosloff
Level 3
Level 3
 
Posts: 151
Joined: Tue Jul 21, 2009 8:54 pm

Re: Networking issue: LMDE refuses to create share in home

Postby ckosloff on Thu Mar 24, 2011 10:34 pm

altair4 wrote:IPT_MODULES="nf_conntrack_ftp nf_nat_ftp nf_conntrack_irc nf_nat_irc nf_conntrack_netbios_ns"


I added this line on both Mint machines and restarted, please elaborate, what does this line do?
Did not notice any changes.
altair4 wrote:[3] On the LMDE machine the names are different because ... well .. it's Debian :wink:
Code: Select all
sudo ufw enable
sudo ufw allow CIFS
sudo ufw allow IPP

I get error in CIFS:
Code: Select all
ckosloff@lmde10 ~ $ sudo ufw allow CIFS
ERROR: Could not find a profile matching 'CIFS'
ckosloff@lmde10 ~ $ sudo ufw allow cifs
ERROR: Could not find a profile matching 'cifs'

IPP went OK in lower case:
Code: Select all
ckosloff@lmde10 ~ $ sudo ufw allow IPP
ERROR: Could not find a profile matching 'IPP'
ckosloff@lmde10 ~ $ sudo ufw allow ipp
Rule added

Is that for printing?
This does not work either:
Code: Select all
ckosloff@lmde10 ~ $ sudo ufw allow samba
ERROR: Could not find a profile matching 'samba'

On another subject: router definitely will not take reservation for Debian machine, with IP only.
So far, this has been a non-issue (as said above), but it definitely is worth understanding why routers and Debian don't play together nicely.
ckosloff
Level 3
Level 3
 
Posts: 151
Joined: Tue Jul 21, 2009 8:54 pm

Re: Networking issue: LMDE refuses to create share in home

Postby altair4 on Fri Mar 25, 2011 7:19 am

On LMDE run the following command to view the list of available preset rules you can choose from:
Code: Select all
sudo ufw app list

You should get the following list:
Available applications:
AIM
Bonjour
CIFS
DNS
Deluge
IMAP
IMAPS
IPP
KTorrent
Kerberos Admin
Kerberos Full
Kerberos KDC
Kerberos Password
LDAP
LPD
MSN
MSN SSL
Mail submission
NFS
POP3
POP3S
PeopleNearby
SMTP
SSH
Socks
Telnet
Transmission
Transparent Proxy
VNC
WWW
WWW Cache
WWW Full
WWW Secure
XMPP
Yahoo
qBittorent

On another subject: router definitely will not take reservation for Debian machine, with IP only.
So far, this has been a non-issue (as said above), but it definitely is worth understanding why routers and Debian don't play together nicely.

I seriously doubt it has anything to do with Debian. Your Debian machine should be configured to get it's ip address from the router using DHCP. If you changed it to a static ip address then set it back to get it's ip address using DHCP. And make sure that the MAC address that the router is using to set the reserved ip address" matches the MAC address on the Debian machine. You can find that out by running
Code: Select all
sudo ifconfig

And also make sure that the ip address is within the preset range allowed by the router.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5521
Joined: Tue Feb 03, 2009 10:27 am

Re: Networking issue: LMDE refuses to create share in home

Postby ckosloff on Fri Mar 25, 2011 10:28 pm

@altair,
Thanks for continuing support in such a timely manner.
This is all I get:
Code: Select all
ckosloff@lmde10 ~ $ sudo ufw app list
[sudo] password for ckosloff:
Available applications:
  OpenSSH

Regarding the router issue, I also have a netbook with LMDE 32-bit, it is called littledeb.
Both lmde10 and littledeb don't show names in the router, and they are the only ones with blank names.
Yes, their addresses are within the allowed pool and MAC addresses match.
ckosloff
Level 3
Level 3
 
Posts: 151
Joined: Tue Jul 21, 2009 8:54 pm

Re: Networking issue: LMDE refuses to create share in home

Postby altair4 on Sat Mar 26, 2011 10:40 am

Just to recap in case I'm missing something:

You are now able to create shares in your home directory.
You are now able to access LMDE from both Linux and Windows by name.
You are able to access everyone else's shares on the LAN.

The three remaining issues are:

(1) The router doesn't log your LMDE machine name.
I really wouldn't obsess about it. Linux will broadcast it's netbios name to everyone else on the network. As long as your router isn't actually blocking that broadcast ( and it apparently is not ) then it doesn't matter.

(2) You can't set your router to supply a static ip address to LMDE or LMDE will not accept it.
The only thing I can think of is that you are setting a static ip address on LMDE itself so the router's DHCP is being ignored. You need to make sure LMDE's settings are for "Automatic (DHCP)"

(3) You have no presets in /etc/ufw/applications.d except for OpenSSH ( sudo ufw app list ).
I can't reproduce that either, sorry.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5521
Joined: Tue Feb 03, 2009 10:27 am

Re: Networking issue: LMDE refuses to create share in home

Postby ckosloff on Sat Mar 26, 2011 10:17 pm

altair4 wrote:Just to recap in case I'm missing something:
You are now able to create shares in your home directory.
You are now able to access LMDE from both Linux and Windows by name.
You are able to access everyone else's shares on the LAN.

All this is correct if firewalls are disabled.
altair4 wrote:The three remaining issues are:
(1) The router doesn't log your LMDE machine name.
I really wouldn't obsess about it. Linux will broadcast it's netbios name to everyone else on the network. As long as your router isn't actually blocking that broadcast ( and it apparently is not ) then it doesn't matter.

I'm not obsessing, just curious.
altair4 wrote:(2) You can't set your router to supply a static ip address to LMDE or LMDE will not accept it.
The only thing I can think of is that you are setting a static ip address on LMDE itself so the router's DHCP is being ignored. You need to make sure LMDE's settings are for "Automatic (DHCP)"

I think that it is rather the router that will not accept it, because it asks for a computer name and it only finds an IP.
I save the reservation with the IP, it shows saved, but after a while it mysteriously disappears.
I don't know how to 'make sure LMDE's settings are for "Automatic (DHCP)"'.
Please explain where to check and I will post.
altair4 wrote:(3) You have no presets in /etc/ufw/applications.d except for OpenSSH ( sudo ufw app list ).
I can't reproduce that either, sorry.

Only thing there is openssh-server.
I have enabled ipp which is not there either, but no luck for cifs or samba.
I just checked in littledeb and CIFS is there, along with lots of other apps.
Maybe lmde10 got misconfigured somehow?
ckosloff
Level 3
Level 3
 
Posts: 151
Joined: Tue Jul 21, 2009 8:54 pm

Re: Networking issue: LMDE refuses to create share in home

Postby altair4 on Sun Mar 27, 2011 8:46 am

I think that it is rather the router that will not accept it, because it asks for a computer name and it only finds an IP.
I save the reservation with the IP, it shows saved, but after a while it mysteriously disappears.

Open a terminal on LMDE and type:
Code: Select all
ifconfig

You will get something that looks like this:
eth0
Link encap:Ethernet HWaddr 00:04:23:2c:44:9f
inet addr:192.168.0.120 Bcast:192.168.0.255 Mask:255.255.255.0

Go into your router and go to the "Add DHCP Reservation" section and make it look like this and click "Save":
Screenshot.png
Screenshot.png (20.84 KiB) Viewed 2826 times


Now right click the "Network Connection" icon on the bottom taks bar of your desktop > Edit Connections > Auto etho > Edit > IPV4 Settings > Method: Automatic DHCP. If you connect wirelessly then make the appropriate changes to the path.

Then reboot the PC. If you don't get the ip address you specified in DHCP Reservation I can't help you.
I just checked in littledeb and CIFS is there, along with lots of other apps.
Maybe lmde10 got misconfigured somehow?

I would appear so. If LMDE10 is a PC and not a laptop then don't worry about a firewall - the router is a firewall. If LMDE is a Laptop then enable the firewall when you're out and about but disable it when you're in your LAN.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5521
Joined: Tue Feb 03, 2009 10:27 am

Re: Networking issue: LMDE refuses to create share in home

Postby ckosloff on Sun Mar 27, 2011 9:25 pm

@altair4,
Thank you so much for troubleshooting over the weekend.
I checked the DHCP setting and it was set to automatic, the default.
In router I typed lmde10 in computer name, set the correct IP address after checking in ifconfig and hit the Copy MAC Address button, the correct MAC was shown.
Also the name was not blank after having typed it in.
Saved and rebooted, reservation was gone. :(
Will continue to troubleshoot the list of applications in the firewall, cannot figure out why it is missing in lmde10 and it shows in littledeb.
lmde10 is an ancient desktop that only works properly on Linux, it is OK to leave firewall disabled until a better solution is found.
I am sure that I will be able to allow samba through firewall in littledeb, that is the only one that I take for a spin.
One last question: what is the purpose of the addition to the last line:
IPT_MODULES="nf_conntrack_ftp nf_nat_ftp nf_conntrack_irc nf_nat_irc nf_conntrack_netbios_ns"
ckosloff
Level 3
Level 3
 
Posts: 151
Joined: Tue Jul 21, 2009 8:54 pm

Re: Networking issue: LMDE refuses to create share in home

Postby altair4 on Mon Mar 28, 2011 6:36 am

One last question: what is the purpose of the addition to the last line:
IPT_MODULES="nf_conntrack_ftp nf_nat_ftp nf_conntrack_irc nf_nat_irc nf_conntrack_netbios_ns"

"netbios_ns" is the netbios name server protocol. It's function is to broadcast your machine's name to others on the network. It's disabled by default in ufw so that parameter is added to the base configuration to enable it. Opening up the port for netbios_ns isn't enough if ufw is set to block the protocol itself.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5521
Joined: Tue Feb 03, 2009 10:27 am

Re: Networking issue: LMDE refuses to create share in home

Postby ckosloff on Mon Mar 28, 2011 2:31 pm

I cannot add [SOLVED] because reached character max.
Anyway, thanks to all who replied, especially altair4.
ckosloff
Level 3
Level 3
 
Posts: 151
Joined: Tue Jul 21, 2009 8:54 pm

Linux Mint is funded by ads and donations.
 
Previous

Return to Other networking topics

Who is online

Users browsing this forum: No registered users and 3 guests