Slow video encoding

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Slow video encoding

Postby Bergschreck on Tue Apr 24, 2012 12:46 am

I installed LMDE/Xfce UP4 in parallel to Ubuntu Natty on my Toshiba Satellite Pro U200. I tried to encode a video with Avidemux to MPEG4 AVC.

The encoding speed is extremely slow, it encodes only 3 frames per second on this hardware. The same video with the same encoder settings makes 9 frames/sec with Avidemux on Ubuntu Natty. That's 3 times faster!

What's wrong here? Are some libraries compiled with wrong compiler settings? (maybe debug instead of optimize?)
Bergschreck
Level 1
Level 1
 
Posts: 29
Joined: Fri Apr 20, 2012 4:56 am

Linux Mint is funded by ads and donations.
 

Re: Slow video encoding

Postby Bergschreck on Tue Apr 24, 2012 1:23 pm

Now I installed Xubuntu Precise Pangolin in a third partition of the same machine and did a encode with avidemux (same video, same settings). The result is very astonishing:

LMDE/Xfce: 3 frames/sec
Ubuntu Natty: 9 frames/sec
Xubuntu Precise: 15 frames/sec

I think the difference is how the packages are compiled. Debian packages are compiled for i486, Ubuntu packages are compiled for i686.

IMHO this way LMDE has no future. :-(

I will keep Xubuntu Precise and remove the other 2 partitions.
Bergschreck
Level 1
Level 1
 
Posts: 29
Joined: Fri Apr 20, 2012 4:56 am

Re: Slow video encoding

Postby mank_in on Wed Apr 25, 2012 2:00 am

If you have multicore processor and use 32-bit LMDE, you must install 686-PAE kernel , see : http://www.linuxmint.com/rel_debian.php
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Slow video encoding

Postby Bergschreck on Wed Apr 25, 2012 11:21 am

Thanks for that hint. With 686-pae kernel I get 8 frames/sec. That's about the speed of Ubuntu Natty. I'm wondering how Ubuntu Precise can be so much faster. Maybe because libavcodec is also compiled for 486?
Bergschreck
Level 1
Level 1
 
Posts: 29
Joined: Fri Apr 20, 2012 4:56 am

Re: Slow video encoding

Postby mank_in on Wed Apr 25, 2012 4:27 pm

I don't use LMDE and Avidemux. Maybe you can activate multi threading in avidemux preferences : http://www.avidemux.org/admWiki/doku.ph ... ithreading
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Slow video encoding

Postby Bergschreck on Thu Apr 26, 2012 10:58 am

Avidemux settings were identical on all systems. Threading was set to auto-detect. But even if I set it manually to 2 threads (I have dual core cpu), that makes no difference. LMDE is considerably slower than Ubuntu Precise.
Bergschreck
Level 1
Level 1
 
Posts: 29
Joined: Fri Apr 20, 2012 4:56 am


Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 2 guests