Stuck on "mute"

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Stuck on "mute"

Postby nbob on Wed May 02, 2012 6:57 pm

Hello. I just installed LMDE XFCE 201214 on my pc.
Whenever I want to mute the sound I just press my mute/unmute button on my keyboard and sure enough it mutes the sound.

But
Unmuting is not so easy. Pressing the mute/unmute button on the keyboard does not unmute the speakers. I have to instead left-click on the mixer icon on my panel and then select-controls/ master/ click to unmute the speaker.
My Mixer: Sound Card: is set to Playback: Internal Audio Analog Stereo (PulseAudio Mixer)

I've tried adding application shortcuts to my keyboard, but this changes nothing.
Any help would be appreciated.
nbob
Level 1
Level 1
 
Posts: 19
Joined: Fri Nov 12, 2010 11:45 pm

Linux Mint is funded by ads and donations.
 

Re: Stuck on "mute"

Postby Beardedragon on Wed May 02, 2012 7:12 pm

Same here, no explanation, though I seldom mute with the mute button preferring the Space bar which does not have this problem. Try it.
Robert Collard, Madison, WI
HP s5710f, 2x AMD Athlon II 260@3.2Ghz, 3GB RAM, 640GB HD
Debian 7.1 Wheezy 3,2,0-4 Xfce 4.10 AMD-64
LMDE 3.10.5-1 Xfce 4.10 AMD-64
SalineOS 2.0 3.2.0-4 Xfce 4.8 AMD64
User avatar
Beardedragon
Level 4
Level 4
 
Posts: 346
Joined: Sat Jan 29, 2011 3:37 am

Re: Stuck on "mute"

Postby äxl on Thu May 10, 2012 6:47 pm

Could this program help? It's in the LMDE repositories:
Code: Select all
sudo apt-get install hotkeys
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Stuck on "mute"

Postby slmpika on Mon May 14, 2012 9:55 pm

Just wanted to add that I'm having the same problem and I'm running Lubuntu 12.04 on an HP Pavilion dm3-1030us.
slmpika
Level 1
Level 1
 
Posts: 1
Joined: Mon May 14, 2012 9:49 pm

Re: Stuck on "mute"

Postby äxl on Sun May 20, 2012 6:56 pm

I found out I have the same problem. Seems my keyboard mutes and unmutes Master correctly. But it doesn't unmute PulseAudio.
Channel and Mute symbol react in Volume Control but with no effect. Standard is ALSA Mixer. Do I have to remove ALSA or OSS?

For "hotkeys" you have to know keyboard type and key code. Maybe then you could edit/create a def file in /usr/share/hotkeys/

I haven't tried out Multimedia Systems Selector (gstreamer-properties). Maybe it helps to specify the output ...

Alsamixer says:
Code: Select all
ALSA lib conf.c:3406:(config_file_open) /usr/share/alsa/pulse-alsa.conf may be old or corrupted: consider to remove or fix it
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Stuck on "mute"

Postby Bonsaii on Fri May 25, 2012 6:33 am

According to ubuntu forum posts, Banshee, the multimedia program that comes with Mono, does not work too well with gnome3. There are plenty of reports about freezes and sound going mute.
Removing mono completely (also removes Tomboy notes, Giver and many libraries) seems to have solved my sound problems.
The system does not go mute anymore (so far).
Thinkpad T410s, LMDE 64Bit, Cinnamon
Bonsaii
Level 2
Level 2
 
Posts: 88
Joined: Sat Oct 09, 2010 8:49 am


Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: darethehair, Google Adsense [Bot] and 3 guests