[CLOSED] Audio issue (pulseaudio?)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

[CLOSED] Audio issue (pulseaudio?)

Postby Fyrentennimmar on Tue Jun 12, 2012 6:12 am

Hi everybody.

So I installed LMDE (the latest ISO x64) on my grandfather laptop and everything is fine but I've a weird audio problem: there is no volume control showing, the multimedia keys dont work and there is nothing showing under the "Sound" menu.

But audio works in the browser (like Youtube), mp3 work fine under Banshee and VLC didn't work by default but changing the output to ALSA and HDA NVidia ALC662 rev1 Analog Front speakers made it to work.

So I assume it's a Pulseaudio issue because the process is not showing under "System monitor" and if I try to start it manually I get:

E: [pulseaudio] module-dbus-protocol.c: dbus_server_listen() failed: org.freedesktop.DBus.Error.BadAddress: In D-Bus address, percent character was followed by characters other than hex digits
E: [pulseaudio] module-dbus-protocol.c: Starting the local D-Bus server failed.
E: [pulseaudio] module.c: Failed to load module "module-dbus-protocol" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Échec lors de l'initialisation du démon

Also there were none of these issues while running the live ISO, it showed after installation.

Do you guys have any idea what the problem is?
Last edited by Fyrentennimmar on Fri Jun 22, 2012 10:07 am, edited 1 time in total.
Level 1
Level 1
Posts: 2
Joined: Tue Jun 12, 2012 5:57 am

Linux Mint is funded by ads and donations.

Re: Audio issue (pulseaudio?)

Postby Bonsaii on Tue Jun 12, 2012 2:03 pm

Have you tried to re-install pulse audio?

Do you have pavucontrol installed?

What do you have under menu > preferences > sound ?

You can install various volume/sound control programs
and pick them to be shown in the panel.
Thinkpad T410s, LMDE 64Bit, Cinnamon
Level 2
Level 2
Posts: 88
Joined: Sat Oct 09, 2010 8:49 am

Re: Audio issue (pulseaudio?)

Postby Fyrentennimmar on Tue Jun 12, 2012 2:30 pm

Yes I already tried re-installation and it didn't do anything.

I'll check for pavucontrol (I don't have access to the computer now).

And under menu > preferences > sound, the "hardware" tab, there is nothing showing in the box labeled "Choose a device to configure: ", same for "input" and "output" tabs (again everything is fine with the live ISO, all those tabs are showing the devices).

Also I'm aware there are several volume control softs but I don't think it will be of any use since pulseaudio is simply not starting for whatever reason but I'll give it a try anyway.

EDIT: Well, I checked and pavucontrol wasn't there so I installed it and here is what shows when I lauch it:

Menu>Preferences>Sound gives me this:
Image Image

I also tried gnome-alsamixer and the output is:

So the problem really seems to be that pulseaudio simply won't start for whatever reason and that's what is screwing things. I guess I could try to get rid of it and work with ALSA (which seems to be fine) or figure why that bloody thing is failing to start. It's not a huge deal since sound is actually working but still I'd like to know what's going on with pulse.

Anyway thanks Bonsaii for trying to help, any other thought would be appreciated :)

EDIT2: Well I ended up insatllaing Mint 13 and everything is working fine so I'll stick to it for the time being (hope the Debian version continues to improve).
Level 1
Level 1
Posts: 2
Joined: Tue Jun 12, 2012 5:57 am

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 3 guests