Apparently missing files/libraries

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Apparently missing files/libraries

Postby tlcmd on Sat Oct 05, 2013 7:36 pm

Howdy,
JRivers has finally come out with a long awaited Linux version of Media Center 19 as of the first of October. My LMDE Mate apparently installs it, but I cannot find it and it is not in any list of programs. I asked for help on Linux forums and MikeTbob was kind enough to get me this far. From the correspondence so far, it appears that I am lacking:
E: Unable to locate package libxcb
E: Unable to locate package libxau
E: Unable to locate package libxdmp
E: Unable to locate package libcurl


How do I get them for LMDE (mate)??
Keep scrolling down for the whole of the posts on Linux Forums.

Thanks,
tlcmd (aka Dick)






Find the answer to your Linux question:

Home
Forum
GNU Linux Zone
Gaming / Multimedia / Entertainment
Help with install of JRivers Media Center 19 for Linux



Join Date
Jan 2010
Posts
45

Question Help with install of JRivers Media Center 19 for Linux

I need some help with this install of a proprietary software into Linux Mint Debian Edition (mate). And yes, this question is also posted on that forum. I do have the license which is necessary to enter once it is up and running. This the the LINUX version of JRiver Media Centre 19 which was finally introduced this past week for which many of us Linux users have been waiting. I cannot install it on LMDE Mate (others who are trying to install it on other Linux distros are experiencing the same thing). I'm hoping some of you Linux gurus can give us a help with it.
No charge to download and install, just to use. Here's the url:

[b] JRiver Media Center 19.0.52 for Debian [/b

Any help would be appreciated while we are waiting for the next upgrade. JRivers knows it's new and is expecting problems. So I thought I'd ask for help from some of y'all gurus since I am a relative noobie.

Thanks,
tlcmd (aka Dick)

Edit / Delete Edit Post Quick reply to this message Reply Reply With Quote Reply With Quote Multi-Quote This Message
6 Hours Ago #2
MikeTbob
MikeTbob is offline
Administrator MikeTbob's Avatar

Join Date
Apr 2006
Location
Texas
Posts
7,834

Are you getting an error message upon install? What's the deal? You have it installed but not launching?

Like




MikeTbob,
Thanks for the reply. My mediacenter installer does (apparently) install Media Center 19. But I cannot find it in LMDE (mate). When I follow the instructions to enter "mediacenter" into my terminal I get:

dick@music ~ $ mediacenter
JRiver install path (process: 5956): /usr/lib/jriver/Media Center 19/
CJRSharedToolsHelper::AuthenticateJRSharedLib
JRFileSystem::GetDirectoryAppdataCommon
CJRSharedToolsHelper::AuthenticateJRSharedLib
JRFileSystem::GetDirectoryDocuments
JRFileSystem::GetDirectoryDesktop
Illegal instruction
dick@music ~ $

When I hit ALT-F2, I get "Could not open location 'file:///home/dick/media%20center'"
But that ALT-F2 does show me a complete list of programs and Media Center is not one of them.
I am encouraged that at least one post showed that it could be installed. Others suggest that a deb file is missing.

However, I am a 73 year old not real computer literate guy, but I did successfully practice Internal Medicine for 30 years, so at least I know enough to ask for a consultant.

Would appreciate any help you might offer.

Here is the link to the JRivers Interact Media Center 19 forum. This program was just released on 1 October, so I know enough to expect problems. However, I've been running JRivers Media Jukebox on my Windows since Windows 98. I do have a dual boot with Windows XP and LMDE. But the two are on separate HDD's. ANd the rest of my LMDE works fine.

Thaks for any assistance,
tlcmd (aka Dick)





I found this on their forums.
We don't require a X server or X hardware support on the machine running MC.

We require this:
libX11-6: installed size 1.5 megs
the dependencies for this are:
libX11-data: installed size 1.6 megs
libxcb1: installed size .2 megs
libxau6: installed size .1 megs
libxdmp6: installed size .1 megs
libcurl3: installed size .1 megs (likely already there)
lame: installed size: 1.2 megs
You need to make sure these programs/libraries are installed on your system before you can run it.

Like



Join Date
Jan 2010
Posts
45

Repy

Quote Originally Posted by MikeTbob View Post
I found this on their forums.


You need to make sure these programs/libraries are installed on your system before you can run it.
MikeTbob,

I warned you that this 73 year old guy was not real computer literate. How do I find out if I have these programs/libraries on LMDE Mate?

Thanks,
tlcmd (aka Dick)




Try this, in a terminal/konsole window and see what happens.

Code:

sudo apt-get install libX11 libX11-data libxcb1 libxau6 libxdmp6 libcurl3 lame

Post the results.

Like



Join Date
Jan 2010
Posts
45

MikeTbob,
I really appreciate your working with me on this. Here are the results:
dick@music ~ $ sudo apt-get install libX11 libX11-data libxcb1 libxau6 libxdmp6 libcurl3 lame
[sudo] password for dick:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libX11
E: Unable to locate package libxdmp6
dick@music ~ $

Now, how do i get those two packages??
Thanks
tlcmd (AKA Dick)



I'd assume the X11 libs are installed and working if you have a desktop environment set up and working.
Try again with
Code:

sudo apt-get install libX11-data libxcb libxau libxdmp libcurl lame

Like




reply

Quote Originally Posted by MikeTbob View Post
I'd assume the X11 libs are installed and working if you have a desktop environment set up and working.
Try again with
Code:

sudo apt-get install libX11-data libxcb libxau libxdmp libcurl lame

Mike your last message came into my spam file. Here's the result:

dick@music ~ $ sudo apt-get install libX11-data libxcb libxau libxdmp libcurl lame
[sudo] password for dick:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libxcb
E: Unable to locate package libxau
E: Unable to locate package libxdmp
E: Unable to locate package libcurl

Now what?
Thanks,
Dick

Here's the result:

dick@music ~ $ sudo apt-get install libX11-data libxcb libxau libxdmp libcurl lame
[sudo] password for dick:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libxcb
E: Unable to locate package libxau
E: Unable to locate package libxdmp
E: Unable to locate package libcurl

Now what?
Thanks,
Dick
huh.
Well try changing it back to
Code:

sudo apt-get install libX11-data libxcb1 libxau6 libxdmp6 libcurl3 lame

I have a feeling this will fail also. I don't have access to Mint right now to check the repos for the files. I can't even find some of them on Fedora.
I'm off for a bit, will have to check this out later.
tlcmd
Level 3
Level 3
 
Posts: 180
Joined: Sat Jan 30, 2010 4:43 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 2 guests