How to make ear/headphones sole output?

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

How to make ear/headphones sole output?

Postby some_random_2835 on Thu Mar 13, 2014 12:48 am

Hi

Just upgraded to 201403 from 201303 via clean iso install.

My laptop has a problem in that, whenever I plug in ear/headphones it outputs audio via both the phones and the speakers (this happens with other operating systems, so I think it's a hardware problem). In 201303, I could set it to output only via the ear/headphones in the sound settings, however this option seems to be gone from 201403. Is there any other way to ouput solely through ear/headphones?

Thanks

some_random

Edit: Someone else previously edited this so that it appears identical to another post in "Update/Upgrade Issues", so a section of it didn't make sense. I have restored the above to it's original form. I understand that you don't like cross-posting and I'm sorry for that, but please don't change my post so that it doesn't make sense.
Last edited by some_random_2835 on Thu Mar 13, 2014 10:23 pm, edited 1 time in total.
some_random_2835
Level 1
Level 1
 
Posts: 8
Joined: Tue Aug 06, 2013 10:39 pm

Linux Mint is funded by ads and donations.
 

Re: How to make ear/headphones sole output?

Postby viking777 on Thu Mar 13, 2014 5:15 am

Sorry to cross-post, however this has been on the "Sound, Multimedia & Codecs" section for a week and hasn't been responded to.


Sorry to remove your cross post, but it is contrary to forum rules.

Do not create identical topics across multiple forum sections. Cross-posting creates unnecessary work for community users by separating potential answers and solutions - do not do it.


Maybe it hasn't been responded to because people don't know the answer?

In any case the approved method of drawing attention to unanswered questions is to 'bump' them.

To bump a topic, scroll to the bottom of the topic and click Bump topic, by Board index, Subscribe topic, and Bookmark topic (the Bump topic link will appear 48 hours after the last response).
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: How to make ear/headphones sole output?

Postby Markkram on Tue Mar 25, 2014 11:24 pm

Same problem, but UP7 to UP8 instead of clean install from iso.

Can control headphone-speaker-pcm-master through MATE Volume Control using Alsa mixer, but clicking mute/unmute button affecting the rest.
Playback with PulseAudio Mixer gives only Master slider, no speaker-headphone-other controls.

Miss the simplicity of choosing output device using the volume icon.
Maybe because of kernel as funnyman's problem viewtopic.php?f=196&t=156757
some_random can you confirm on this?
Markkram
Level 1
Level 1
 
Posts: 2
Joined: Tue Mar 25, 2014 10:53 pm

Re: How to make ear/headphones sole output?

Postby py-thon on Wed Mar 26, 2014 2:15 pm

Maybe one of those can help, although I haven't tried either:
viewtopic.php?f=48&t=126314
http://crunchbang.org/forums/viewtopic.php?id=20338
My automute-switch has disappeared from alsamixer as well.
Tower: Sparky 64 bit Mate+mintmenu - Netbook: LMDE Mate 32bit
py-thon
Level 4
Level 4
 
Posts: 263
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: How to make ear/headphones sole output?

Postby some_random_2835 on Thu Mar 27, 2014 11:05 pm

Markkram:
In attempting to confirm what you said about Alsa mixer and PulseAudio mixer, I have actually fixed the problem.

I downloaded pavucontrol (which is what I assume you meant by PulseAudio mixer), looked under "Output Devices", clicked the lock icon (disables locking channels together) and changed "Port" to "Headphones". Fixed.

I should probably let you know that I'm using cinnamon.

Not that it matters now but:

Confirmed on Alsa mixer: I downloaded Alsa mixer and I basically had the same problem. If I muted speakers, headphones would mute with it and if I had speakers on high, but headphones low, I would get nothing on either, but if I increased the volume on headphones it would increase the volume on speakers, etc.

So anyway I fixed the problem without even looking at py-thon's suggestions (thanks for those anyway py-thon).
some_random_2835
Level 1
Level 1
 
Posts: 8
Joined: Tue Aug 06, 2013 10:39 pm

Re: How to make ear/headphones sole output?

Postby Markkram on Sun Mar 30, 2014 6:33 am

Yes, installing pavucontrol is the easiest solution so far (+ add to panel of course), works on cinnamon and mate.
On acer aspire, am using cinnamon as well, just keep mate for comparison purpose.

Regarding "Playback with PulseAudio Mixer", actually within the scope of MATE Volume Control; it is one of the available options on the "Device" drop-down menu. Btw, glad that you reach pavucontrol by this.

Exactly the same hardware problem and solution as some_random, py-thon's suggestions are based on different issues. Nonetheless, THANKS TO BOTH OF YOU.
The cause might be the updated cinnamon. Expecting the simplicity back on cinnamon volume icon, by default without any hassle.
Markkram
Level 1
Level 1
 
Posts: 2
Joined: Tue Mar 25, 2014 10:53 pm

Re: How to make ear/headphones sole output?

Postby some_random_2835 on Sat Apr 12, 2014 10:22 pm

Right. So my only problem now is that I have to do this every time i boot. Chanels re-lock on restart and port resets back to speakers. It would be nice if, when you set things as I described above, then they stay that way.
some_random_2835
Level 1
Level 1
 
Posts: 8
Joined: Tue Aug 06, 2013 10:39 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 2 guests