How can I separate my headphones from my speakers?

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

How can I separate my headphones from my speakers?

Postby jacobgkau on Sat Apr 12, 2014 3:18 pm

Hello there. I've found a few topics close to what I'm trying to achieve, but they've all been a little bit different from my specific problem.

I've got LMDE installed on my desktop computer. Right now, when I don't have my headphones plugged in, sound goes through my back panel speakers (the port is on the motherboard, not a separate sound card.) When I do plug in the headphones, the sound stops coming out of the speakers, and starts coming out of the headphones, like it's supposed to.

However, I'd like to be able to switch between the two outputs without physically unplugging the headphones all the time, and I'd also like to be able to specify different outputs for different programs. The problem with doing either of these is that my headphones and speakers are all recognized as one output. This is how it's always been on Linux, but on Windows, I'm able to enable "simultaneous audio streams," which lets me choose between the two. Once again, the speakers are plugged into the motherboard directly, and the headphones are plugged into one of the ports on my case. When I plug in or unplug the headphones, the volume adjusts automatically-- the computer remembers what volume I had each device at individually. This leads me to believe that the computer can treat the two outputs as separate devices.

In the system tray sound icon, I see two outputs: "Built-in Audio Analog Stereo," which is what's selected, and the output for an HDMI port (I think it's referring to the one on my graphics card, rather than the one on my motherboard, but I don't use either.) In the "Sound" settings panel, I see different outputs: "Digital Output (S/PDIF)," which I don't use, and "Analog Output." Now here's where things get even more frustrating: when I have the headphones plugged in, a third option appears: "Headphones." However, whether I select "Headphones" or "Analog Output," the sound always goes through my headphones as long as they're plugged in. The "Headphones" option only shows up in the settings panel, not in the system tray icon-- "Built-in Audio Analog Stereo" is always selected in the tray.

Any ideas?
jacobgkau
Level 1
Level 1
 
Posts: 1
Joined: Sat Apr 12, 2014 2:49 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 2 guests