Internal Speaker Sound Not Working

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Internal Speaker Sound Not Working

Postby jw2014 on Mon Apr 21, 2014 4:00 pm

Hello all,

I just installed LMDE Cinnamon 2.0.14 64-bit as dual boot with OS X on a 2013 MacBook Air 6.2 (i7-4650U Haswell), and am still trying to get sound to come out of the internal speakers (works from headphone jack). Prior to installing LMDE Cinnamon, I had Ubuntu 13.10 64-bit installed, and the sound worked great. I would greatly appreciate any help.

Some information:

Code: Select all
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 3: ID 2807 Digital [ID 2807 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ID 4208 Analog [ID 4208 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


Code: Select all
sudo lshw -C sound
*-multimedia:0         
       description: Audio device
       product: Haswell-ULT HD Audio Controller
       vendor: Intel Corporation
       physical id: 3
       bus info: pci@0000:00:03.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:69 memory:b0a10000-b0a13fff
  *-multimedia:1
       description: Audio device
       product: Lynx Point-LP HD Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:68 memory:b0a14000-b0a17fff


Code: Select all
lspci | grep -i audio
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)
00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)


Code: Select all
lsmod | grep snd
snd_hda_intel          39672  4
snd_hda_codec         142551  1 snd_hda_intel
snd_hwdep              13148  1 snd_hda_codec
snd_pcm_oss            44847  0
snd_mixer_oss          22042  1 snd_pcm_oss
snd_pcm                84096  3 snd_pcm_oss,snd_hda_codec,snd_hda_intel
snd_page_alloc         17114  2 snd_pcm,snd_hda_intel
snd_seq_midi           12848  0
snd_seq_midi_event     13316  1 snd_seq_midi
snd_rawmidi            26805  1 snd_seq_midi
snd_seq                48834  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         13132  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              26614  2 snd_pcm,snd_seq
snd                    60869  18 snd_pcm_oss,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_mixer_oss
soundcore              13026  1 snd


I saw on another post a recommendation to modify /etc/modprobe.d/alsa-base.conf and change
Code: Select all
options snd-hda-intel model=auto
#change it into
options snd-hda-intel model=generic

I did not see options snd-hda-intel model=auto, added it (didn't work), and modified it (didn't work).

I also tried https://help.ubuntu.com/community/SoundTroubleshooting, but no dice.

Maybe my sound card isn't supported?
jw2014
Level 1
Level 1
 
Posts: 2
Joined: Sun Apr 20, 2014 3:37 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 3 guests