Cant connect to Bluetooth Audio device

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help

Cant connect to Bluetooth Audio device

Postby kickbert on Thu Apr 24, 2014 7:32 pm

Hi,

I recently installed linux mint and I'm trying to connect to a Logitech audio bluetooth device. I just cant seem to make it work.
I'm running Linux Mint 16 Cinnamon on a Sony Vaio VGN-FW285D laptop
In the Mint bluetooth manager I can pair the device but I can't connect. It connects for a second, the speakers make a beep sound and the LED on the receiver turns green for a split second and than it disconnects right away.

I tried it with blueman, the bluetooth manager but it wont connect either http://ibin.co/1K9enqbHICcz

Any ideas?
kickbert
Level 1
Level 1
 
Posts: 6
Joined: Fri Aug 30, 2013 8:08 pm

Linux Mint is funded by ads and donations.
 

Re: Cant connect to Bluetooth Audio device

Postby ergoman on Fri Apr 25, 2014 11:43 pm

ergoman
Level 1
Level 1
 
Posts: 5
Joined: Wed Jan 01, 2014 4:57 pm

Re: Cant connect to Bluetooth Audio device

Postby MiguelfromCanada on Sat Apr 25, 2015 9:22 am

I do have the same problem but to solve it it did not go as expected ,

First the instruction

-----------------------------------------------------------------------------
How i solve it:

1) Modify the /etc/bluetooth/audio.conf
================================

[General]
Enable = Source,Sink,Headset,Gateway,Control,Media
Disable = Socket

HFP=false

[A2DP]
SBCSources=1
MPEG12Sources=0

2) Check for pulseaudio module :
==========================

$ pactl list | grep -i module-bluetooth

If you dont have :
module-bluetooth-policy
module-bluetooth-discover
module-bluetooth-device

Just do :
$ sudo apt-get install pulseaudio-module-bluetooth
$ pulseaudio -k
$ pactl load-module module-bluetooth-device
$ pactl load-module module-switch-on-connect

3) Connect the bluetooth headset
===========================

Use blueman to pair, and connect audio sink
Use pavucontrol to change for A2DP (even if blueman said "audio profile off")

Please confirm that works for you too.

---------------------------------------------------------------------------------------
So, the way I understood I first went in the terminal then did

sudo gedit /etc/bluetooth/audio.conf

so this is after my modification... ( It gave a error message when I saved do someone see something wrong in there ??

-----------------------------------------------------------------------------------------------------

# Configuration file for the audio service

# This section contains options which are not specific to any
# particular interface
[General]

Enable = Source,Sink,Headset,Gateway,Control,Media
Disable = Socket

HFP=false

[A2DP]
SBCSources=1
MPEG12Sources=0

# Switch to master role for incoming connections (defaults to true)
#Master=true

# If we want to disable support for specific services
# Defaults to supporting all implemented services
#Disable=Gateway,Source,Socket

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
# Defaults to HCI
#SCORouting=PCM

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
#AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
[Headset]

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
HFP=true

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=1

# Set to true to enable use of fast connectable mode (faster page scanning)
# for HFP when incoming call starts. Default settings are restored after
# call is answered or rejected. Page scan interval is much shorter and page
# scan type changed to interlaced. Such allows faster connection initiated
# by a headset.
FastConnectable=false

# Just an example of potential config options for the other interfaces
#[A2DP]
#SBCSources=1
#MPEG12Sources=0

----------------------------------------------------------------------------

the result in the terminal after saving modification

(gedit:1200): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.SVZNXX': No such file or directory

(gedit:1200): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

(gedit:1200): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.KQBIXX': No such file or directory

(gedit:1200): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory
Lenovo-B50-30 miguel # pactl list | grep -i module-bluetooth
Name: module-bluetooth-policy


It gave a error message when I saved do someone see something wrong in there ??
MiguelfromCanada
Level 1
Level 1
 
Posts: 3
Joined: Mon Apr 20, 2015 9:11 am

Re: Cant connect to Bluetooth Audio device

Postby oldgranola on Thu May 07, 2015 12:38 pm

You don't need to go through all that, no need to edit any files. Its real easy with cinnamon but you do need to make sure that you indeed have working bluetooth hardware on your computer and don't need special 'drivers'. I don't so I've got a generic usb dongle. JeremyB has trouble shot this for many so look up his posts on the topic. Here's a command he always asks you to show the results from: lsusb; dmesg | grep -i firmware; uname -a

In the output list, if a USB device doesn't appear you have more work to do to figure it out. I just plugged in the dongle. Afterward, part of my output: "Bus 003 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)"
Then if you are good there....
First, don't use LM16, use LM17.1. second DONT' use blueman in cinnamon (does work with command line effort in XFCE). Instead use the "cinnamon-bluetooth program" and the cinnamon audio applet. If not already installed get them using your graphic software manager that comes with cinnamon. Open it, enable it. Pair it with your BT device. Activate the device. For my motorola headphones, I have to play with which connection 'mode' to use and then go to the cinnamon sound manager via "settings" and "output device" to tell the sound manager to output that particular protocol to the headphones. This is all done using the GUI's provided by the programs and Cinnamon. Again, no files to edit, nothing special to download except "cinnamon-bluetooth". A very similar method using Buez works for KDE. If you've tried to install a bunch of controllers you might want to first uninstal and start over with just one noted above.
oldgranola
Level 2
Level 2
 
Posts: 68
Joined: Fri Sep 05, 2014 1:39 am

Re: Cant connect to Bluetooth Audio device

Postby elchucko on Sun Aug 09, 2015 9:54 am

New to Linux. I'm using LinuxMint 17.1. I tried your command line or whatever it's called and found a list of usb mfg/devices. From that point I'm lost as to what specifically to do. I'm attempting to connect a Motorola Moto X (XT1060) phone. I can pair but connection fails. Can you assist as to what additional steps are needed? Thank you
elchucko
Level 3
Level 3
 
Posts: 161
Joined: Fri Dec 09, 2011 12:13 pm


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: jonna_983 and 6 guests