No sound in Left 4 Dead 2 with steam without disabling pulse

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

No sound in Left 4 Dead 2 with steam without disabling pulse

Postby crazyjust on Sun Apr 27, 2014 7:07 pm

I'm not sure if I should be posting this here or in the Gaming on Linux Mint section (moderator please move if neccesary).I used the debian installer, and installed steam in LMDE. In order to get sound working in l4f2 with steam, I have to enter "killall pulseaudio" in terminal. Does anyone else use steam with LMDE and experience this problem, or know how to correct it?
crazyjust
Level 1
Level 1
 
Posts: 9
Joined: Sat Sep 08, 2012 3:01 pm

Linux Mint is funded by ads and donations.
 

Re: No sound in Left 4 Dead 2 with steam without disabling p

Postby xerion567 on Sun Apr 27, 2014 7:44 pm

Hmmmm. I haven't used Steam in Linux yet, but I have a few guesses on what to try.

It could be that either Steam or LFD2 (or Wine, if it is being run this way) is set to bypass PulseAudio. PulseAudio is a finicky thing and doesn't like that sometimes (hence blocking access to the sound hardware). You may be able to make it happy by selecting "PulseAudio Mixer" or similar from within the game as your sound device. I'm doubly suspect of this if LFD2 is being run using Wine, in which case it may be the Wine settings that need to be tweaked.
All work and no play makes Linux a dull OS,
All work and no play makes Linux a dull OS,
All work and no play makes Linux...viewtopic.php?f=58&t=164690
User avatar
xerion567
Level 3
Level 3
 
Posts: 108
Joined: Sun Mar 30, 2014 12:38 am
Location: Colorado, USA

Postby crazyjust on Mon Apr 28, 2014 11:56 am

I'm not using wine.

Sent from my HTC One X using Tapatalk
crazyjust
Level 1
Level 1
 
Posts: 9
Joined: Sat Sep 08, 2012 3:01 pm


Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 1 guest