[SOLVED SORTA] Mic not working in LMDE

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

[SOLVED SORTA] Mic not working in LMDE

Postby mikhou on Tue Sep 14, 2010 12:56 pm

Hey guys,

I just installed LMDE 2 days ago, and I've had to make a couple of things work that were fairly easy so far. My wireless card wasn't turning on at startup, and my printer/scanner wasn't acting exactly right, but those things were fairly easy to fix. The only other hiccup has been my microphone, and, frankly, I'm not sure where to start. I searched LM, Ubuntu, and Debian forums, but I'm not coming up with any solutions. I'm running a Dell Inspiron 1420 with and HDA Intel mic, and I'm getting nothing on the microphone. Sound cards are working beautifully. Any thoughts? What other info do you need to help me out? Thanks for your time.

mikhou
Last edited by mikhou on Wed Sep 15, 2010 10:35 pm, edited 1 time in total.
mikhou
Level 4
Level 4
 
Posts: 234
Joined: Sat Sep 05, 2009 8:55 am

Linux Mint is funded by ads and donations.
 

Re: Mic not working in LMDE and I don't know where to start

Postby ukbrian on Tue Sep 14, 2010 1:01 pm

Try right clicking on the speaker icon on the right
Click on the Input tab and your mic should be listed there.
Image
good luck
bri
Last edited by ukbrian on Tue Sep 14, 2010 1:30 pm, edited 1 time in total.
User avatar
ukbrian
Level 4
Level 4
 
Posts: 276
Joined: Thu Jul 29, 2010 6:03 am
Location: Cheltenham, UK

Re: Mic not working in LMDE and I don't know where to start

Postby mikhou on Tue Sep 14, 2010 1:10 pm

I had checked that before, and when I go to the Input tab, I am presented with Microphone 1 and Microphone 2, but again, I'm not getting anything into the mic. I don't know if there is a conflict somewhere between Pulse Audio and something else or what. Thanks.
mikhou
Level 4
Level 4
 
Posts: 234
Joined: Sat Sep 05, 2009 8:55 am

Re: Mic not working in LMDE and I don't know where to start

Postby zole052 on Tue Sep 14, 2010 1:17 pm

First ckeck your sound card in the Input tab of 'Sound Preferences' and then install 'GNOME ALSA Mixer' and in it uncheck 'mute' on te 'line in' bar of your sound card.
Works for me :)
zole052
Level 2
Level 2
 
Posts: 59
Joined: Thu Jan 29, 2009 6:32 pm
Location: Umag, Croatia

Re: Mic not working in LMDE and I don't know where to start

Postby mikhou on Tue Sep 14, 2010 1:32 pm

No dice there either. I had previously installed Gnome Alsa Mixer in an attempt to get this working, and I don't even have a "Line in" bar on my sound card. Thanks.
mikhou
Level 4
Level 4
 
Posts: 234
Joined: Sat Sep 05, 2009 8:55 am

Re: Mic not working in LMDE and I don't know where to start

Postby secipolla on Tue Sep 14, 2010 1:52 pm

Check alsamixer itself (open from the terminal).
secipolla
Level 4
Level 4
 
Posts: 356
Joined: Sun Sep 05, 2010 5:19 pm

Re: Mic not working in LMDE and I don't know where to start

Postby mikhou on Tue Sep 14, 2010 11:49 pm

I checked the alsamixer and everything appears fine. Here's a little more info. My Microphone 2 is working fine. I plugged in my headset with mic, and it's working. It's just the internal Microphone 1 that is not working. Thanks.

mikhou

EDITED: Going back and running "alsamixer" from terminal, I see that you have to hit F4 to go to the capture devices. There I could choose Digital Mic as the default option (should have been set there automatically) and now it works. However, the gain is still pretty low. Any idea how to boost that? Thanks.
mikhou
Level 4
Level 4
 
Posts: 234
Joined: Sat Sep 05, 2009 8:55 am

Re: [SOLVED SORTA] Mic not working in LMDE

Postby Yeticannotski on Sat Mar 19, 2011 6:18 pm

Had the same problem with a Dell XPS M1330. In my case I had to use F6 switch (in alsamixer) from the "default soundcard" to mine actual soundcard (HDA Intel) and then I selected "Digital Mic" for all three input possibilities.
Yeticannotski
Level 1
Level 1
 
Posts: 15
Joined: Mon Mar 14, 2011 5:34 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 2 guests